]> git.pld-linux.org Git - packages/zfs.git/blobdiff - zfs.spec
- unpackaged files note
[packages/zfs.git] / zfs.spec
index 1895af9493e9e0ae2f9c4d534bd98a34922580c1..30128a47f038f2b2ecff2f8386db005b111abb96 100644 (file)
--- a/zfs.spec
+++ b/zfs.spec
@@ -1,15 +1,15 @@
-# TODO: PLDify init script
+# TODO:
+# - PLDify init script
+# - unpackaged initramfs-tools support:
+#   /usr/share/initramfs-tools/conf-hooks.d/zfs
+#   /usr/share/initramfs-tools/hooks/zfs
+#   /usr/share/initramfs-tools/scripts/zfs
 #
 # Conditional build:
-%bcond_without dist_kernel     # allow non-distribution kernel
 %bcond_without kernel          # don't build kernel modules
 %bcond_without userspace       # don't build userspace programs
 %bcond_with    verbose         # verbose build (V=1)
 #
-%if %{without kernel}
-%undefine      with_dist_kernel
-%endif
-
 # The goal here is to have main, userspace, package built once with
 # simple release number, and only rebuild kernel packages with kernel
 # version as part of release number, without the need to bump release
 exit 1
 %endif
 
-%if "%{_alt_kernel}" != "%{nil}"
-%if 0%{?build_kernels:1}
-%{error:alt_kernel and build_kernels are mutually exclusive}
-exit 1
-%endif
-%undefine      with_userspace
-%global                _build_kernels          %{alt_kernel}
-%else
-%global                _build_kernels          %{?build_kernels:,%{?build_kernels}}
-%endif
-
 %if %{without userspace}
 # nothing to be placed to debuginfo package
 %define                _enable_debug_packages  0
@@ -37,30 +26,27 @@ exit 1
 
 %define                _duplicate_files_terminate_build        0
 
-%define                kbrs    %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo "BuildRequires:kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2" ; done)
-%define                kpkg    %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo %%kernel_pkg ; done)
-%define                bkpkg   %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo %%build_kernel_pkg ; done)
-
 %define        pname   zfs
 %define        rel     1
 Summary:       Native Linux port of the ZFS filesystem
 Summary(pl.UTF-8):     Natywny linuksowy port systemu plików ZFS
 Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
-Version:       0.6.3
+Version:       0.6.5.4
 Release:       %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
 License:       CDDL (ZFS), GPL v2+ (ZPIOS)
 Group:         Applications/System
 Source0:       http://archive.zfsonlinux.org/downloads/zfsonlinux/zfs/%{pname}-%{version}.tar.gz
-# Source0-md5: 5bcc32c122934d421eba68e16826637d
+# Source0-md5: a0f77516c35088ed4dee56352f1aca58
 Patch0:                %{pname}-link.patch
+Patch1:                x32.patch
 URL:           http://zfsonlinux.org/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 BuildRequires: libtool
+BuildRequires: rpmbuild(macros) >= 1.701
 %if %{with kernel}
-BuildRequires: kernel%{_alt_kernel}-spl-devel >= 0.6.3
-BuildRequires: rpmbuild(macros) >= 1.379
-%{?with_dist_kernel:%{expand:%kbrs}}
+%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
+%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-spl-devel >= 0.6.3}
 %endif
 %if %{with userspace}
 BuildRequires: libblkid-devel
@@ -163,10 +149,8 @@ Summary(pl.UTF-8): ZFS - moduły jądra Linuksa\
 Release:       %{rel}@%{_kernel_ver_str}\
 Group:         Base/Kernel\
 Requires(post,postun): /sbin/depmod\
-%if %{with dist_kernel}\
 %requires_releq_kernel\
 Requires(postun):      %releq_kernel\
-%endif\
 \
 %description -n kernel%{_alt_kernel}-zfs\
 ZFS Linux kernel modules.\
@@ -179,10 +163,8 @@ Summary:   ZFS Linux kernel headers\
 Summary(pl.UTF-8):     ZFS - pliki nagłówkowe jądra Linuksa\
 Release:       %{rel}@%{_kernel_ver_str}\
 Group:         Development/Building\
-%if %{with dist_kernel}\
 Requires:      kernel%{_alt_kernel}-headers\
 Requires:      kernel-zfs-common-devel\
-%endif\
 \
 %description -n kernel%{_alt_kernel}-zfs-devel\
 ZFS Linux kernel headers configured for PLD kernel%{_alt_kernel},\
@@ -222,7 +204,8 @@ pakietu kernel%{_alt_kernel} w wersji %{_kernel_ver}.\
 %configure \\\
        --disable-silent-rules \\\
        --with-config="kernel" \\\
-       --with-linux=%{_kernelsrcdir}\
+       --with-linux=%{_kernelsrcdir}\\\
+       --with-linux-obj=%{_kernelsrcdir}\
 \
 %{__make} clean\
 %{__make} %{?with_verbose:V=1}\
@@ -230,11 +213,12 @@ p=`pwd`\
 %{__make} install DESTDIR=$p/installed INSTALL_MOD_DIR=misc\
 %{nil}
 
-%{?with_kernel:%{expand:%kpkg}}
+%{?with_kernel:%{expand:%create_kernel_packages}}
 
 %prep
 %setup -q -n %{pname}-%{version}
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__libtoolize}
@@ -242,7 +226,7 @@ p=`pwd`\
 %{__autoconf}
 %{__autoheader}
 %{__automake}
-%{?with_kernel:%{expand:%bkpkg}}
+%{?with_kernel:%{expand:%build_kernel_packages}}
 
 %if %{with userspace}
 %configure \
@@ -269,6 +253,9 @@ cp -a installed/* $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
        DEFAULT_INIT_DIR=/etc/rc.d/init.d
+
+install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
+%{__mv} $RPM_BUILD_ROOT%{_npkgconfigdir}/* $RPM_BUILD_ROOT%{_pkgconfigdir}
 %endif
 
 %clean
@@ -282,6 +269,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc AUTHORS COPYRIGHT DISCLAIMER OPENSOLARIS.LICENSE README.markdown
 %attr(755,root,root) /sbin/mount.zfs
+%attr(755,root,root) %{_bindir}/arc_summary.py
 %attr(755,root,root) %{_bindir}/arcstat.py
 %attr(755,root,root) %{_bindir}/dbufstat.py
 %attr(755,root,root) %{_sbindir}/fsck.zfs
@@ -300,7 +288,12 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_sysconfdir}/zfs/zed.d
 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/*.sh
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/zed.rc
-%attr(754,root,root) /etc/rc.d/init.d/zfs
+%attr(754,root,root) /etc/rc.d/init.d/zfs-import
+%attr(754,root,root) /etc/rc.d/init.d/zfs-mount
+%attr(754,root,root) /etc/rc.d/init.d/zfs-share
+%attr(754,root,root) /etc/rc.d/init.d/zfs-zed
+%config(noreplace) %verify(not md5 mtime size) /etc/default/zfs
+/etc/zfs/zfs-functions
 /usr/lib/modules-load.d/zfs.conf
 /etc/systemd/system-preset/50-zfs.preset
 %{systemdunitdir}/zed.service
@@ -329,6 +322,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/zpios.1*
 %{_mandir}/man1/ztest.1*
 %{_mandir}/man5/vdev_id.conf.5*
+%{_mandir}/man5/zfs-events.5*
 %{_mandir}/man5/zfs-module-parameters.5*
 %{_mandir}/man5/zpool-features.5*
 %{_mandir}/man8/fsck.zfs.8*
@@ -368,6 +362,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libzpool.la
 %{_includedir}/libspl
 %{_includedir}/libzfs
+%{_pkgconfigdir}/libzfs.pc
+%{_pkgconfigdir}/libzfs_core.pc
 
 %files static
 %defattr(644,root,root,755)
@@ -379,11 +375,13 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n dracut-zfs
 %defattr(644,root,root,755)
-%doc dracut/README.dracut.markdown
+%doc contrib/dracut/README.dracut.markdown
 %dir %{dracutlibdir}/modules.d/90zfs
+%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/export-zfs.sh
 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/module-setup.sh
 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/mount-zfs.sh
 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/parse-zfs.sh
+%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-lib.sh
 %endif
 
 %if %{with kernel}
This page took 0.03887 seconds and 4 git commands to generate.