]> git.pld-linux.org Git - packages/wxWidgets.git/blobdiff - wxWidgets.spec
- add link.patch which should fix some unresolved symbols
[packages/wxWidgets.git] / wxWidgets.spec
index 1cc838e5223c19b70091ff98b3134a0b7ae318f8..6afd9f9bb9a3bcfeea0eecf5dbc2a5f4714806b7 100644 (file)
@@ -7,26 +7,20 @@
 %bcond_with    debug                   # build with \--enable-debug
                                        # (binary incompatible with non-debug)
 #
-# Unpackaged files:
-#  /usr/bin/wxrc-2.8
-#  /usr/share/locale/it/LC_MESSAGES/wxmsw.mo
-#
-
 Summary:       wxWidgets library
 Summary(pl.UTF-8):     Biblioteka wxWidgets
 Name:          wxWidgets
-Version:       2.8.6
-Release:       0.5
-License:       wxWidgets Licence (LGPL with exception)
+Version:       2.9.1
+Release:       1
+License:       wxWindows Library Licence 3.1 (LGPL v2+ with exception)
 Group:         X11/Libraries
 Source0:       http://ftp.wxwidgets.org/pub/%{version}/%{name}-%{version}.tar.bz2
-# Source0-md5: 8a130e5b25448a17454a6b957a5e075c
+# Source0-md5: 81c20d7b2ba31becb18e467dbe09be8f
 Patch0:                %{name}-samples.patch
 Patch1:                %{name}-ogl.patch
 Patch2:                %{name}-ac.patch
-Patch3:                %{name}-gif0delay.patch
-Patch4:                %{name}-x11unicode.patch
-Patch5:                %{name}-gcc4.patch
+Patch3:                %{name}-x11unicode.patch
+Patch4:                %{name}-link.patch
 URL:           http://www.wxWidgets.org/
 BuildRequires: OpenGL-GLU-devel
 #BuildRequires:        SDL-devel
@@ -34,7 +28,6 @@ BuildRequires:        autoconf >= 2.59-9
 BuildRequires: automake
 #BuildRequires:        bakefile >= 0.2.1
 BuildRequires: cppunit-devel
-BuildRequires: esound-devel
 BuildRequires: expat-devel
 BuildRequires: flex
 BuildRequires: gettext-devel
@@ -138,19 +131,6 @@ wxWidgets example programs.
 %description examples -l pl.UTF-8
 Przykładowe programy wxWidgets.
 
-%package HelpGen
-Summary:       Help file generator for wxWidgets programs
-Summary(pl.UTF-8):     Generator plików pomocy dla programów wxWidgets
-Group:         Development/Tools
-Requires:      wxBase = %{version}-%{release}
-Obsoletes:     wxWindows-HelpGen
-
-%description HelpGen
-Help file generator for wxWidgets programs.
-
-%description HelpGen -l pl.UTF-8
-Generator plików pomocy dla programów wxWidgets.
-
 %package -n wxBase
 Summary:       wxBase library - non-GUI support classes of wxWidgets toolkit
 Summary(pl.UTF-8):     wxBase - biblioteka klas wxWidgets nie związanych z GUI
@@ -351,10 +331,10 @@ Requires: wxX11 = %{version}-%{release}
 Obsoletes:     wxWindows-utils
 
 %description utils
-Misc utils from wxWidgets project: helpviewer, makegen, etc.
+Misc utils from wxWidgets project: wxemulator, wxrc, etc.
 
 %description utils -l pl.UTF-8
-Różne narzędzia z projektu wxWidgets: helpviewer, makegen itp.
+Różne narzędzia z projektu wxWidgets: wxemulator, wxrc itp.
 
 %package -n wxX11
 Summary:       wxUniversal-based wxX11 library
@@ -472,11 +452,11 @@ obsługą UNICODE.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
+# is this still needed?
+#%patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
 
 %build
 # if bakefiles rebuild is needed:
@@ -489,7 +469,7 @@ cp -f /usr/share/automake/config.sub .
 %{__aclocal} -I build/aclocal
 %{__autoconf}
 
-CPPFLAGS="%{rpmcflags} -I`pwd`/include"; export CPPFLAGS
+CPPFLAGS="%{rpmcppflags} %{rpmcflags} -I`pwd`/include -fPIC"; export CPPFLAGS
 # avoid adding -s to LDFLAGS
 LDFLAGS=" "; export LDFLAGS
 args="%{?with_debug:--enable-debug}%{!?with_debug:--disable-debug} \
@@ -514,7 +494,6 @@ for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
                ${unicode} \
                %{!?with_gnomeprint:--without-gnomeprint}
        %{__make}
-       %{__make} -C contrib/src
        cd ..
 done
 
@@ -531,12 +510,10 @@ for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
                --enable-universal \
                ${unicode}
        %{__make}
-       %{__make} -C contrib/src
        if echo $objdir| grep -q disable-unicode ; then
                %{__make} -C utils
                %{__make} -C utils/emulator
                %{__make} -C utils/hhp2cached
-               # %{__make} -C contrib/utils
        fi
        cd ..
 done
@@ -561,16 +538,8 @@ for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
                datadir=$RPM_BUILD_ROOT%{_datadir} \
                libdir=$RPM_BUILD_ROOT%{_libdir} \
                mandir=$RPM_BUILD_ROOT%{_mandir} \
-               includedir=$RPM_BUILD_ROOT%{_includedir}
-
-       %{__make} -C contrib/src install \
-               prefix=$RPM_BUILD_ROOT%{_prefix} \
-               exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
-               bindir=$RPM_BUILD_ROOT%{_bindir} \
-               datadir=$RPM_BUILD_ROOT%{_datadir} \
-               libdir=$RPM_BUILD_ROOT%{_libdir} \
-               mandir=$RPM_BUILD_ROOT%{_mandir} \
-               includedir=$RPM_BUILD_ROOT%{_includedir}
+               includedir=$RPM_BUILD_ROOT%{_includedir} \
+               LOCALE_MSW_LINGUAS=
        cd ..
 done
 
@@ -587,34 +556,14 @@ for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
                datadir=$RPM_BUILD_ROOT%{_datadir} \
                libdir=$RPM_BUILD_ROOT%{_libdir} \
                mandir=$RPM_BUILD_ROOT%{_mandir} \
-               includedir=$RPM_BUILD_ROOT%{_includedir}
+               includedir=$RPM_BUILD_ROOT%{_includedir} \
+               LOCALE_MSW_LINGUAS=
        if echo $objdir| grep -q disable-unicode ; then
-#              install utils/dialoged/src/DialogEd $RPM_BUILD_ROOT%{_bindir}
                # TODO: install default config files and default backgrouds
-               install utils/HelpGen/src/HelpGen $RPM_BUILD_ROOT%{_bindir}
                install utils/emulator/src/wxemulator $RPM_BUILD_ROOT%{_bindir}
-               install utils/tex2rtf/src/tex2rtf $RPM_BUILD_ROOT%{_bindir}
                install utils/hhp2cached/hhp2cached $RPM_BUILD_ROOT%{_bindir}
-#              install utils/makegen/makegen $RPM_BUILD_ROOT%{_bindir}
                install utils/wxrc/wxrc $RPM_BUILD_ROOT%{_bindir}
-#              install -d $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
-#              install -m644 utils/makegen/templates/* \
-#                      $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
-#              install contrib/utils/wxrcedit/wxrcedit $RPM_BUILD_ROOT%{_bindir}
-#              install -d $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit
-#              install contrib/utils/wxrcedit/df/* \
-#                      $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit/
        fi
-
-       %{__make} -C contrib/src install \
-               prefix=$RPM_BUILD_ROOT%{_prefix} \
-               exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
-               bindir=$RPM_BUILD_ROOT%{_bindir} \
-               datadir=$RPM_BUILD_ROOT%{_datadir} \
-               libdir=$RPM_BUILD_ROOT%{_libdir} \
-               mandir=$RPM_BUILD_ROOT%{_mandir} \
-               includedir=$RPM_BUILD_ROOT%{_includedir}
-
        cd ..
 done
 %endif
@@ -663,32 +612,25 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f wxstd.lang
 %defattr(644,root,root,755)
-%doc docs/{changes,licence,licendoc,preamble,readme,todo}.txt
+%doc docs/{changes,licence,licendoc,preamble,readme}.txt
 
 %files devel
 %defattr(644,root,root,755)
-%doc docs/html
 %doc docs/tech docs/univ
 %{_includedir}/wx*
 %dir %{_libdir}/wx
 %dir %{_libdir}/wx/include
 %dir %{_libdir}/wx/config
-%{_aclocaldir}/*.m4
+%{_aclocaldir}/wxwin.m4
 
 %files -n bakefile-wxWidgets
 %defattr(644,root,root,755)
-%{_datadir}/bakefile/presets/*.bkl
+%{_datadir}/bakefile/presets/wx*.bkl
 
 %files examples
 %defattr(644,root,root,755)
 %{_examplesdir}/%{name}-%{version}
 
-%if %{with x11}
-%files HelpGen
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/HelpGen
-%endif
-
 %if %{with ansi}
 %files -n wxBase
 %defattr(644,root,root,755)
@@ -771,9 +713,10 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with ansi}
 %files utils
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/*
-%exclude %{_bindir}/HelpGen
-%exclude %{_bindir}/wx*-config
+%attr(755,root,root) %{_bindir}/hhp2cached
+%attr(755,root,root) %{_bindir}/wxemulator
+%attr(755,root,root) %{_bindir}/wxrc
+%attr(755,root,root) %{_bindir}/wxrc-*
 
 %files -n wxX11
 %defattr(644,root,root,755)
This page took 0.036503 seconds and 4 git commands to generate.