]> git.pld-linux.org Git - packages/wesnoth.git/blobdiff - wesnoth.spec
- release 4 (rebuild against libpng-1.5)
[packages/wesnoth.git] / wesnoth.spec
index 2ba7a264196f2368c3b923a94c190bda8b8e86cc..1d7c250b4767bc6ea17da4a169f19d4f9678fba7 100644 (file)
@@ -1,5 +1,6 @@
 # TODO
 # - unpackaged language files
+#
 # Conditional build
 %bcond_without server  # without server
 %bcond_without tools   # without tools
@@ -9,19 +10,19 @@ Summary:     Strategy game with a fantasy theme
 Summary(hu.UTF-8):     Fantasy környezetben játszódó stratégiai játék
 Summary(pl.UTF-8):     Strategiczna gra z motywem fantasy
 Name:          wesnoth
-Version:       1.8
-Release:       1
+Version:       1.10
+Release:       4
 Epoch:         1
 License:       GPL v2+
 Group:         X11/Applications/Games/Strategy
 Source0:       http://downloads.sourceforge.net/wesnoth/%{name}-%{version}.tar.bz2
-# Source0-md5: 07e4b97512e307c54dcfd86659a61e41
+# Source0-md5: 707daa13e2f5b3976d9b169aab62dc29
 Source1:       %{name}d.init
-Patch0:                %{name}-libpng.patch
-Patch1:                %{name}-desktop.patch
-Patch2:                %{name}-locale_dir.patch
+Source2:       %{name}.tmpfiles
+Patch0:                %{name}-desktop.patch
+Patch1:                %{name}-locale_dir.patch
 URL:           http://www.wesnoth.org/
-BuildRequires: SDL-devel >= 1.2.7
+BuildRequires: SDL-devel >= 1.2.14-4
 BuildRequires: SDL_image-devel >= 1.2
 BuildRequires: SDL_mixer-devel >= 1.2
 BuildRequires: SDL_net-devel >= 1.2
@@ -29,6 +30,7 @@ BuildRequires:        SDL_ttf-devel >= 2.0.8
 BuildRequires: asciidoc
 BuildRequires: boost-devel >= 1.33
 BuildRequires: cmake >= 2.4
+BuildRequires: dbus-devel
 %{?with_fribidi:BuildRequires: fribidi-devel}
 BuildRequires: gettext-devel
 BuildRequires: libpng-devel
@@ -38,9 +40,10 @@ BuildRequires:       lua51-devel
 BuildRequires: pango-devel
 BuildRequires: pkgconfig
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: rpmbuild(macros) >= 1.600
 BuildRequires: sed >= 4.0
 BuildRequires: zlib-devel
+Requires:      SDL >= 1.2.14-4
 # sr@Latn vs. sr@latin
 Conflicts:     glibc-misc < 6:2.7
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -78,6 +81,8 @@ Requires(postun):     /usr/sbin/userdel
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
 Requires:      rc-scripts >= 0.4.0.17
+Provides:      group(wesnothd)
+Provides:      user(wesnothd)
 # sr@Latn vs. sr@latin
 Conflicts:     glibc-misc < 6:2.7
 
@@ -110,20 +115,15 @@ Edytor map i narzędzia do tłumaczeń.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 
 # don't install locales in %{_datadir}/%{name}
 %{__sed} -i 's,${DATADIR}/${LOCALEDIR},${LOCALEDIR},' CMakeLists.txt
 
-# link using libpng instead of libpng12
-%{__sed} -i 's,png12,png,' src/CMakeLists.txt
-
 %build
 install -d build
 cd build
-%cmake .. \
-       -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
-       -DCMAKE_INSTALL_PREFIX=%{_prefix} \
+%cmake \
+       .. \
        -DENABLE_STRICT_COMPILATION="off" \
        -DBINDIR="%{_bindir}" \
        -DMANDIR="%{_mandir}" \
@@ -132,16 +132,14 @@ cd build
        %{?with_server:-DENABLE_CAMPAIGN_SERVER="on"} \
        %{!?with_tools:-DENABLE_EDITOR="off"} \
        %{?with_tools:-DENABLE_TOOLS="on"} \
-       %{!?with_fribidi:-DENABLE_FRIBIDI="off"} \
-%if "%{_lib}" == "lib64"
-       -DLIB_SUFFIX=64
-%endif
+       %{!?with_fribidi:-DENABLE_FRIBIDI="off"}
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},/var/run/wesnothd,/etc/rc.d/init.d,%{_docdir}/%{name}-%{version}}
+install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},/var/run/wesnothd,/etc/rc.d/init.d} \
+       $RPM_BUILD_ROOT{/usr/lib/tmpfiles.d,%{_docdir}/%{name}-%{version}}
 
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
@@ -152,22 +150,26 @@ gzip -9nf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{changelog,README}
 
 %if %{with server}
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/wesnothd
+install %{SOURCE2} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
 %endif
 
 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/nb{_NO,}
 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/fur{_IT,}
 
 # unsupported(?)
-rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/ca_ES@valencia
-rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/la
-rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/racv
-rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/en@shaw
-rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian
-rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavianlatin
-rm -rf $RPM_BUILD_ROOT%{_mandir}/ca_ES@valencia
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/ang@latin
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/ca_ES@valencia
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/la
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/racv
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/en@shaw
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavianlatin
+%{__rm} -r $RPM_BUILD_ROOT%{_mandir}/ca_ES@valencia
+%{__rm} -r $RPM_BUILD_ROOT%{_mandir}/sr@ijekavian
+%{__rm} -r $RPM_BUILD_ROOT%{_mandir}/sr@ijekavianlatin
 
 # the same as manuals from %{_mandir}/man?
-rm -rf $RPM_BUILD_ROOT%{_mandir}/en_GB
+%{__rm} -r $RPM_BUILD_ROOT%{_mandir}/en_GB
 
 %find_lang %{name} --all-name
 
@@ -197,21 +199,20 @@ fi
 %{_mandir}/man6/wesnoth.6*
 %lang(cs) %{_mandir}/cs/man6/wesnoth.6*
 %lang(de) %{_mandir}/de/man6/wesnoth.6*
-%lang(es) %{_mandir}/es/man6/wesnoth.6*
 %lang(et) %{_mandir}/et/man6/wesnoth.6*
+%lang(es) %{_mandir}/es/man6/wesnoth.6*
 %lang(fi) %{_mandir}/fi/man6/wesnoth.6*
 %lang(fr) %{_mandir}/fr/man6/wesnoth.6*
 %lang(gl) %{_mandir}/gl/man6/wesnoth.6*
 %lang(hu) %{_mandir}/hu/man6/wesnoth.6*
+%lang(id) %{_mandir}/id/man6/wesnoth.6*
 %lang(it) %{_mandir}/it/man6/wesnoth.6*
-%lang(ja) %{_mandir}/ja/man6/wesnoth.6*
 %lang(lt) %{_mandir}/lt/man6/wesnoth.6*
 %lang(pl) %{_mandir}/pl/man6/wesnoth.6*
-%lang(pt_BR) %{_mandir}/pt_BR/man6/wesnoth.6*
+%lang(ru) %{_mandir}/ru/man6/wesnoth.6*
 %lang(sk) %{_mandir}/sk/man6/wesnoth.6*
 %lang(sr) %{_mandir}/sr/man6/wesnoth.6*
 %lang(sr@latin) %{_mandir}/sr@latin/man6/wesnoth.6*
-%lang(tr) %{_mandir}/tr/man6/wesnoth.6*
 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnoth.6*
 %lang(zh_TW) %{_mandir}/zh_TW/man6/wesnoth.6*
 %{_datadir}/%{name}
@@ -231,18 +232,23 @@ fi
 %lang(et) %{_mandir}/et/man6/wesnothd.6*
 %lang(fi) %{_mandir}/fi/man6/wesnothd.6*
 %lang(fr) %{_mandir}/fr/man6/wesnothd.6*
+%lang(gl) %{_mandir}/gl/man6/wesnothd.6*
 %lang(hu) %{_mandir}/hu/man6/wesnothd.6*
+%lang(id) %{_mandir}/id/man6/wesnothd.6*
 %lang(it) %{_mandir}/it/man6/wesnothd.6*
 %lang(ja) %{_mandir}/ja/man6/wesnothd.6*
 %lang(lt) %{_mandir}/lt/man6/wesnothd.6*
 %lang(pl) %{_mandir}/pl/man6/wesnothd.6*
 %lang(pt_BR) %{_mandir}/pt_BR/man6/wesnothd.6*
+%lang(ru) %{_mandir}/ru/man6/wesnothd.6*
 %lang(sk) %{_mandir}/sk/man6/wesnothd.6*
 %lang(sr) %{_mandir}/sr/man6/wesnothd.6*
 %lang(sr@latin) %{_mandir}/sr@latin/man6/wesnothd.6*
 %lang(tr) %{_mandir}/tr/man6/wesnothd.6*
 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnothd.6*
+%lang(zh_TW) %{_mandir}/zh_TW/man6/wesnothd.6*
 %attr(770,wesnothd,wesnothd) %dir /var/run/wesnothd
+/usr/lib/tmpfiles.d/%{name}.conf
 %endif
 
 %if %{with tools}
This page took 0.033165 seconds and 4 git commands to generate.