]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - webapp.spec
setuptools is likely to be used
[projects/template-specs.git] / webapp.spec
index 76e7a480a8e8840f457cfe89d83088314c6b7851..2e20c8d2e052150f8a085a245eb39cc925b6f06a 100644 (file)
@@ -1,24 +1,27 @@
 Summary:       Package that uses webapps configuration
 Summary(pl.UTF-8):     Pakiet używający konfiguracji aplikacji WWW
 Name:          template-webapp
-Version:       0.2
-Release:       0.7
+Version:       0.3
+Release:       0.3
 License:       GPL
 Group:         Applications/WWW
 #Source0:      %{name}-%{version}.tar.gz
 # Source0-md5: -
+#Source1:      apache.conf
+#Source2:      lighttpd.conf
 #URL:          -
 BuildRequires: rpmbuild(macros) >= 1.268
 Requires:      webapps
-%if %{with trigger}
-Requires(triggerpostun):       sed >= 4.0
-%endif
-# see SOURCES/webapps.README for description and complete listing
+# see packages/webapps/webapps.README for description and complete listing
 #Requires:     webserver(access)
 #Requires:     webserver(alias)
 #Requires:     webserver(auth)
 #Requires:     webserver(cgi)
+#Requires:     webserver(expires)
 #Requires:     webserver(indexfile)
+#Requires:     webserver(mime)
+#Requires:     webserver(php)
+#Requires:     webserver(setenv)
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -44,19 +47,45 @@ konfiguracji aplikacji WWW do katalogu konfiguracyjnego serwera WWW.
 cat > apache.conf <<'EOF'
 Alias /%{name} %{_appdir}
 <Directory %{_appdir}>
-       Allow from all
+       # Apache 2.x
+       <IfModule !mod_authz_core.c>
+               Order allow,deny
+               Allow from all
+       </IfModule>
+       # Apache 2.4
+       <IfModule mod_authz_core.c>
+               Require all granted
+       </IfModule>
 </Directory>
 EOF
 
+cat > lighttpd.conf <<'EOF'
+alias.url += (
+       "/%{name}" => "%{_appdir}",
+)
+EOF
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_sysconfdir}
-#install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
+
+cp -a . $RPM_BUILD_ROOT%{_appdir}
+
+cp -p apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
+cp -p apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
+cp -p lighttpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
+
+mv $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir}}/apache.conf
+mv $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir}}/lighttpd.conf
+cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
+
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
+cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
 
-#install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
-install apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
-install apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
-install lighttpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
+%clean
+rm -rf $RPM_BUILD_ROOT
 
 # %webapp_* macros usage extracted from /usr/lib/rpm/macros.build:
 #
@@ -82,95 +111,6 @@ install lighttpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
 %triggerun -- lighttpd
 %webapp_unregister lighttpd %{_webapp}
 
-%if 00000000000000000000000000000000000
-# SAMPLE TRIGGER FOR MIGRATION PURPOSES
-%triggerpostun -- %{name} < 1.3.9-1.4
-# rescue app configs. issue this in old config dir to get a list:
-# rpm -qfl .|grep `pwd`/|awk -F/ '{print $NF}'|egrep -v 'apache|httpd'|xargs
-for i in config.inc.php; do
-       if [ -f /etc/%{name}/$i.rpmsave ]; then
-               mv -f %{_sysconfdir}/$i{,.rpmnew}
-               mv -f /etc/%{name}/$i.rpmsave %{_sysconfdir}/$i
-       fi
-done
-
-# nuke very-old config location (this mostly for Ra)
-if [ -f /etc/httpd/httpd.conf ]; then
-       sed -i -e "/^Include.*%{name}.conf/d" /etc/httpd/httpd.conf
-       httpd_reload=1
-fi
-
-# migrate from httpd (apache2) config dir
-if [ -f /etc/httpd/%{name}.conf.rpmsave ]; then
-       cp -f %{_sysconfdir}/httpd.conf{,.rpmnew}
-       mv -f /etc/httpd/%{name}.conf.rpmsave %{_sysconfdir}/httpd.conf
-       httpd_reload=1
-fi
-
-# migrate from apache-config macros
-if [ -f /etc/%{name}/apache.conf.rpmsave ]; then
-       if [ -d /etc/apache/webapps.d ]; then
-               cp -f %{_sysconfdir}/apache.conf{,.rpmnew}
-               cp -f /etc/%{name}/apache.conf.rpmsave %{_sysconfdir}/apache.conf
-       fi
-
-       if [ -d /etc/httpd/webapps.d ]; then
-               cp -f %{_sysconfdir}/httpd.conf{,.rpmnew}
-               cp -f /etc/%{name}/apache.conf.rpmsave %{_sysconfdir}/httpd.conf
-       fi
-       rm -f /etc/%{name}/apache.conf.rpmsave
-fi
-
-# same but without separate %{_sysconfdir} for package
-if [ -f /etc/apache-%{name}.conf.rpmsave ]; then
-       if [ -d /etc/apache/webapps.d ]; then
-               cp -f %{_sysconfdir}/apache.conf{,.rpmnew}
-               cp -f /etc/apache-%{name}.conf.rpmsave %{_sysconfdir}/apache.conf
-       fi
-
-       if [ -d /etc/httpd/webapps.d ]; then
-               cp -f %{_sysconfdir}/httpd.conf{,.rpmnew}
-               cp -f /etc/apache-%{name}.conf.rpmsave %{_sysconfdir}/httpd.conf
-       fi
-       rm -f /etc/apache-%{name}.conf.rpmsave
-fi
-
-# update htpasswd path
-#sed -i -e 's,/etc/%{name},%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
-
-# migrating from earlier apache-config?
-if [ -L /etc/apache/conf.d/99_%{name}.conf ] || [ -L /etc/httpd/httpd.conf/99_%{name}.conf ]; then
-       if [ -L /etc/apache/conf.d/99_%{name}.conf ]; then
-               rm -f /etc/apache/conf.d/99_%{name}.conf
-               apache_reload=1
-       fi
-       if [ -L /etc/httpd/httpd.conf/99_%{name}.conf ]; then
-               rm -f /etc/httpd/httpd.conf/99_%{name}.conf
-               httpd_reload=1
-       fi
-else
-       # no earlier registration. assume migration from Ra
-       if [ -d /etc/apache/webapps.d ]; then
-               apache_reload=1
-       fi
-       if [ -d /etc/httpd/webapps.d ]; then
-               httpd_reload=1
-       fi
-fi
-
-if [ "$apache_reload" ]; then
-       /usr/sbin/webapp register apache %{_webapp}
-       %service -q apache reload
-fi
-if [ "$httpd_reload" ]; then
-       /usr/sbin/webapp register httpd %{_webapp}
-       %service -q httpd reload
-fi
-%endif # END OF SAMPLE TRIGGER
-
-%clean
-rm -rf $RPM_BUILD_ROOT
-
 %files
 %defattr(644,root,root,755)
 %dir %attr(750,root,http) %{_sysconfdir}
@@ -178,3 +118,4 @@ rm -rf $RPM_BUILD_ROOT
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
+%{_appdir}
This page took 0.044748 seconds and 4 git commands to generate.