]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - webapp.spec
golang: update
[projects/template-specs.git] / webapp.spec
index a35302318ba064887233c1b1ee726c9760ca968f..2e20c8d2e052150f8a085a245eb39cc925b6f06a 100644 (file)
@@ -7,8 +7,8 @@ License:        GPL
 Group:         Applications/WWW
 #Source0:      %{name}-%{version}.tar.gz
 # Source0-md5: -
-Source1:       apache.conf
-Source2:       lighttpd.conf
+#Source1:      apache.conf
+#Source2:      lighttpd.conf
 #URL:          -
 BuildRequires: rpmbuild(macros) >= 1.268
 Requires:      webapps
@@ -17,9 +17,10 @@ Requires:    webapps
 #Requires:     webserver(alias)
 #Requires:     webserver(auth)
 #Requires:     webserver(cgi)
+#Requires:     webserver(expires)
 #Requires:     webserver(indexfile)
+#Requires:     webserver(mime)
 #Requires:     webserver(php)
-#Requires:     webserver(rewrite)
 #Requires:     webserver(setenv)
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -46,7 +47,15 @@ konfiguracji aplikacji WWW do katalogu konfiguracyjnego serwera WWW.
 cat > apache.conf <<'EOF'
 Alias /%{name} %{_appdir}
 <Directory %{_appdir}>
-       Allow from all
+       # Apache 2.x
+       <IfModule !mod_authz_core.c>
+               Order allow,deny
+               Allow from all
+       </IfModule>
+       # Apache 2.4
+       <IfModule mod_authz_core.c>
+               Require all granted
+       </IfModule>
 </Directory>
 EOF
 
@@ -75,6 +84,9 @@ cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
 cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
 
+%clean
+rm -rf $RPM_BUILD_ROOT
+
 # %webapp_* macros usage extracted from /usr/lib/rpm/macros.build:
 #
 # Usage:
@@ -99,9 +111,6 @@ cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
 %triggerun -- lighttpd
 %webapp_unregister lighttpd %{_webapp}
 
-%clean
-rm -rf $RPM_BUILD_ROOT
-
 %files
 %defattr(644,root,root,755)
 %dir %attr(750,root,http) %{_sysconfdir}
This page took 0.064188 seconds and 4 git commands to generate.