]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - webapp.spec
- update non-opt ocaml packaging
[projects/template-specs.git] / webapp.spec
index ed6d93543e82d6c33b29557c9a34a19b7bbb0486..2e20c8d2e052150f8a085a245eb39cc925b6f06a 100644 (file)
@@ -1,17 +1,14 @@
 Summary:       Package that uses webapps configuration
 Summary(pl.UTF-8):     Pakiet używający konfiguracji aplikacji WWW
 Name:          template-webapp
-Version:       0.4
-Release:       0.4
+Version:       0.3
+Release:       0.3
 License:       GPL
 Group:         Applications/WWW
 #Source0:      %{name}-%{version}.tar.gz
 # Source0-md5: -
-# For apache 1.x
-Source1:       apache.conf
-# For apache 2.4+
-Source2:       httpd.conf
-Source3:       lighttpd.conf
+#Source1:      apache.conf
+#Source2:      lighttpd.conf
 #URL:          -
 BuildRequires: rpmbuild(macros) >= 1.268
 Requires:      webapps
@@ -20,11 +17,11 @@ Requires:   webapps
 #Requires:     webserver(alias)
 #Requires:     webserver(auth)
 #Requires:     webserver(cgi)
+#Requires:     webserver(expires)
 #Requires:     webserver(indexfile)
+#Requires:     webserver(mime)
 #Requires:     webserver(php)
-#Requires:     webserver(rewrite)
 #Requires:     webserver(setenv)
-Conflicts:     apache-base < 2.4.0-1
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -50,14 +47,15 @@ konfiguracji aplikacji WWW do katalogu konfiguracyjnego serwera WWW.
 cat > apache.conf <<'EOF'
 Alias /%{name} %{_appdir}
 <Directory %{_appdir}>
-       Allow from all
-</Directory>
-EOF
-
-cat > httpd.conf <<'EOF'
-Alias /%{name} %{_appdir}
-<Directory %{_appdir}>
-       Require all granted
+       # Apache 2.x
+       <IfModule !mod_authz_core.c>
+               Order allow,deny
+               Allow from all
+       </IfModule>
+       # Apache 2.4
+       <IfModule mod_authz_core.c>
+               Require all granted
+       </IfModule>
 </Directory>
 EOF
 
@@ -72,17 +70,22 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_sysconfdir}
 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
 
+cp -a . $RPM_BUILD_ROOT%{_appdir}
+
 cp -p apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
-cp -p httpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
+cp -p apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
 cp -p lighttpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
 
 mv $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir}}/apache.conf
-mv $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir}}/httpd.conf
 mv $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir}}/lighttpd.conf
+cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
 
 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
-cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
-cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
+cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
+
+%clean
+rm -rf $RPM_BUILD_ROOT
 
 # %webapp_* macros usage extracted from /usr/lib/rpm/macros.build:
 #
@@ -96,10 +99,10 @@ cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
 %triggerun -- apache1 < 1.3.37-3, apache1-base
 %webapp_unregister apache %{_webapp}
 
-%triggerin -- apache-base
+%triggerin -- apache < 2.2.0, apache-base
 %webapp_register httpd %{_webapp}
 
-%triggerun -- apache-base
+%triggerun -- apache < 2.2.0, apache-base
 %webapp_unregister httpd %{_webapp}
 
 %triggerin -- lighttpd
@@ -108,9 +111,6 @@ cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
 %triggerun -- lighttpd
 %webapp_unregister lighttpd %{_webapp}
 
-%clean
-rm -rf $RPM_BUILD_ROOT
-
 %files
 %defattr(644,root,root,755)
 %dir %attr(750,root,http) %{_sysconfdir}
This page took 0.050032 seconds and 4 git commands to generate.