]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - webapp.spec
- update non-opt ocaml packaging
[projects/template-specs.git] / webapp.spec
index 1fb83265b0ea02355e37bced542a696fe62fda85..2e20c8d2e052150f8a085a245eb39cc925b6f06a 100644 (file)
@@ -2,13 +2,13 @@ Summary:      Package that uses webapps configuration
 Summary(pl.UTF-8):     Pakiet używający konfiguracji aplikacji WWW
 Name:          template-webapp
 Version:       0.3
-Release:       0.1
+Release:       0.3
 License:       GPL
 Group:         Applications/WWW
 #Source0:      %{name}-%{version}.tar.gz
 # Source0-md5: -
-Source1:       apache.conf
-Source2:       lighttpd.conf
+#Source1:      apache.conf
+#Source2:      lighttpd.conf
 #URL:          -
 BuildRequires: rpmbuild(macros) >= 1.268
 Requires:      webapps
@@ -17,7 +17,9 @@ Requires:     webapps
 #Requires:     webserver(alias)
 #Requires:     webserver(auth)
 #Requires:     webserver(cgi)
+#Requires:     webserver(expires)
 #Requires:     webserver(indexfile)
+#Requires:     webserver(mime)
 #Requires:     webserver(php)
 #Requires:     webserver(setenv)
 BuildArch:     noarch
@@ -45,13 +47,21 @@ konfiguracji aplikacji WWW do katalogu konfiguracyjnego serwera WWW.
 cat > apache.conf <<'EOF'
 Alias /%{name} %{_appdir}
 <Directory %{_appdir}>
-       Allow from all
+       # Apache 2.x
+       <IfModule !mod_authz_core.c>
+               Order allow,deny
+               Allow from all
+       </IfModule>
+       # Apache 2.4
+       <IfModule mod_authz_core.c>
+               Require all granted
+       </IfModule>
 </Directory>
 EOF
 
 cat > lighttpd.conf <<'EOF'
 alias.url += (
-    "/%{name}" => "%{_appdir}",
+       "/%{name}" => "%{_appdir}",
 )
 EOF
 
@@ -60,17 +70,22 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_sysconfdir}
 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
 
-cp -a apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
-cp -a apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
-cp -a lighttpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
+cp -a . $RPM_BUILD_ROOT%{_appdir}
+
+cp -p apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
+cp -p apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
+cp -p lighttpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
 
 mv $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir}}/apache.conf
 mv $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir}}/lighttpd.conf
-cp -a $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
+cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
+
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
+cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
 
-cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
-cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
-cp -a $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
+%clean
+rm -rf $RPM_BUILD_ROOT
 
 # %webapp_* macros usage extracted from /usr/lib/rpm/macros.build:
 #
@@ -96,9 +111,6 @@ cp -a $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
 %triggerun -- lighttpd
 %webapp_unregister lighttpd %{_webapp}
 
-%clean
-rm -rf $RPM_BUILD_ROOT
-
 %files
 %defattr(644,root,root,755)
 %dir %attr(750,root,http) %{_sysconfdir}
This page took 0.035558 seconds and 4 git commands to generate.