]> git.pld-linux.org Git - packages/wayland.git/blobdiff - wayland.spec
- temporarily move wayland-egl headers to -devel for Mesa 18.1.x; release 2
[packages/wayland.git] / wayland.spec
index d55d5d66ad1c1e03394a0a77dc26677510bc0ed4..e6ecb6bc1d27cbf897dc3476202f9e7f9aeb70df 100644 (file)
@@ -2,29 +2,36 @@
 # Conditional build:
 %bcond_without apidocs         # don't build API documentation
 %bcond_without static_libs     # don't build static libraries
-#
+
+# see wayland-egl.pc
+%define        wayland_egl_ver 18.1.0
 Summary:       Wayland - protocol for a compositor to talk to its clients
 Summary(pl.UTF-8):     Wayland - protokół między serwerem składającym a klientami
 Name:          wayland
-Version:       1.0.5
-Release:       1
+Version:       1.15.0
+Release:       2
 License:       MIT
 Group:         Libraries
-Source0:       http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
-# Source0-md5: e2e9ebfbaf9b013471c620b99938d764
-Patch0:                %{name}-publican.patch
-URL:           http://wayland.freedesktop.org/
+Source0:       https://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
+# Source0-md5: b7393c17fdce9a8d383edab656c92fd2
+Patch0:                %{name}-missing.patch
+Patch1:                %{name}-man.patch
+URL:           https://wayland.freedesktop.org/
 BuildRequires: autoconf >= 2.64
 BuildRequires: automake >= 1:1.11
-BuildRequires: docbook-style-xsl
-BuildRequires: doxygen
-BuildRequires: expat-devel
-BuildRequires: libffi-devel
+BuildRequires: expat-devel >= 1.95
+BuildRequires: libffi-devel >= 3
 BuildRequires: libtool >= 2:2.2
-BuildRequires: libxslt-progs
+# for DTD valudation
+BuildRequires: libxml2-devel >= 2.0
 BuildRequires: pkgconfig
-BuildRequires: pkgconfig(libffi)
-%{?with_apidocs:BuildRequires: publican >= 3}
+%if %{with apidocs}
+BuildRequires: docbook-style-xsl-nons
+BuildRequires: doxygen >= 1.6.0
+BuildRequires: graphviz >= 2.26.0
+BuildRequires: libxslt-progs
+BuildRequires: xmlto
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -69,10 +76,51 @@ Static Wayland libraries.
 %description static -l pl.UTF-8
 Statyczne biblioteki Wayland.
 
+%package egl
+Summary:       Wayland EGL library
+Summary(pl.UTF-8):     Biblioteka Wayland EGL
+Group:         Libraries
+Obsoletes:     Mesa-libwayland-egl < %{wayland_egl_ver}
+
+%description egl
+Wayland EGL library.
+
+%description egl -l pl.UTF-8
+Biblioteka Wayland EGL.
+
+%package egl-devel
+Summary:       Header files for Wayland EGL library
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki Wayland EGL
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+Requires:      %{name}-egl = %{version}-%{release}
+Obsoletes:     Mesa-libwayland-egl-devel < %{wayland_egl_ver}
+
+%description egl-devel
+Header files for Wayland EGL library.
+
+%description egl-devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki Wayland EGL.
+
+%package egl-static
+Summary:       Static Wayland EGL library
+Summary(pl.UTF-8):     Statyczna biblioteka Wayland EGL
+Group:         Development/Libraries
+Requires:      %{name}-egl-devel = %{version}-%{release}
+
+%description egl-static
+Static Wayland EGL library.
+
+%description egl-static -l pl.UTF-8
+Statyczna biblioteka Wayland EGL.
+
 %package apidocs
 Summary:       Wayland API and protocol documentation
 Summary(pl.UTF-8):     Dokumentacja API biblioteki oraz protokołu Wayland
 Group:         Documentation
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
 
 %description apidocs
 Wayland API and protocol documentation.
@@ -82,11 +130,11 @@ Dokumentacja API biblioteki oraz protokołu Wayland.
 
 %prep
 %setup -q
-
-# this file is required by publican 3.0; publican patch adds it in en-US dir
-test ! -f doc/Wayland/en_US/Revision_History.xml
-
 %patch0 -p1
+%patch1 -p1
+
+# force regeneration (.so link is broken, double man3/)
+%{__rm} doc/man/*.3
 
 %build
 %{__libtoolize}
@@ -95,8 +143,10 @@ test ! -f doc/Wayland/en_US/Revision_History.xml
 %{__autoheader}
 %{__automake}
 %configure \
+       %{!?with_apidocs:--disable-documentation} \
        --disable-silent-rules \
-       %{!?with_static_libs:--disable-static}
+       %{?with_static_libs:--enable-static}
+
 %{__make}
 
 %install
@@ -105,10 +155,18 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+%if %{with apidocs}
+# referenced by some installed wl_*.3 man pages
+cp -p doc/doxygen/man/man3/wayland-{client,client-core,server,server-core,util}.h.3 \
+       doc/doxygen/man/man3/wayland-{client,server,shm,util}.c.3 $RPM_BUILD_ROOT%{_mandir}/man3
+%endif
+
 # obsoleted by pkg-config
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libwayland-*.la
+%if %{with apidocs}
 # packaged as %doc in -devel
 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/wayland
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -132,14 +190,29 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libwayland-client.so
 %attr(755,root,root) %{_libdir}/libwayland-cursor.so
 %attr(755,root,root) %{_libdir}/libwayland-server.so
-%{_includedir}/wayland-*.h
+%{_includedir}/wayland-client*.h
+%{_includedir}/wayland-cursor.h
+%{_includedir}/wayland-server*.h
+%{_includedir}/wayland-util.h
+%{_includedir}/wayland-version.h
+%dir %{_datadir}/wayland
+%{_datadir}/wayland/wayland.dtd
+%{_datadir}/wayland/wayland.xml
+%{_datadir}/wayland/wayland-scanner.mk
 %{_pkgconfigdir}/wayland-client.pc
 %{_pkgconfigdir}/wayland-cursor.pc
+%{_pkgconfigdir}/wayland-scanner.pc
 %{_pkgconfigdir}/wayland-server.pc
 %{_aclocaldir}/wayland-scanner.m4
-%{_aclocaldir}/wayland-scanner.mk
-%{_mandir}/man3/wl_display_connect.3*
-%{_mandir}/man3/wl_display_connect_to_fd*
+%if %{with apidocs}
+%{_mandir}/man3/wayland-*.c.3*
+%{_mandir}/man3/wayland-*.h.3*
+%{_mandir}/man3/wl_*.3*
+%endif
+# NOTE: temporarily here because they're used but not included in Mesa 18.1.x
+# TODO: move to -egl-devel after transition to Mesa 18.2.x
+%{_includedir}/wayland-egl.h
+%{_includedir}/wayland-egl-core.h
 
 %if %{with static_libs}
 %files static
@@ -152,5 +225,23 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with apidocs}
 %files apidocs
 %defattr(644,root,root,755)
-%doc doc/Wayland/Wayland/en-US/html/*
+%doc doc/publican/Wayland/en-US/html/*
+%endif
+
+%files egl
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libwayland-egl.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libwayland-egl.so.1
+
+%files egl-devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libwayland-egl.so
+%{_includedir}/wayland-egl-backend.h
+%{_pkgconfigdir}/wayland-egl.pc
+%{_pkgconfigdir}/wayland-egl-backend.pc
+
+%if %{with static_libs}
+%files egl-static
+%defattr(644,root,root,755)
+%{_libdir}/libwayland-egl.a
 %endif
This page took 0.030208 seconds and 4 git commands to generate.