]> git.pld-linux.org Git - packages/wayland.git/blobdiff - wayland.spec
- temporarily move wayland-egl headers to -devel for Mesa 18.1.x; release 2
[packages/wayland.git] / wayland.spec
index 6d26e88078d40616cd6163f070b31715d89f561a..e6ecb6bc1d27cbf897dc3476202f9e7f9aeb70df 100644 (file)
@@ -2,26 +2,31 @@
 # Conditional build:
 %bcond_without apidocs         # don't build API documentation
 %bcond_without static_libs     # don't build static libraries
-#
+
+# see wayland-egl.pc
+%define        wayland_egl_ver 18.1.0
 Summary:       Wayland - protocol for a compositor to talk to its clients
 Summary(pl.UTF-8):     Wayland - protokół między serwerem składającym a klientami
 Name:          wayland
-Version:       1.7.0
-Release:       1
+Version:       1.15.0
+Release:       2
 License:       MIT
 Group:         Libraries
-Source0:       http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
-# Source0-md5: 6f46ac47c3a18c6503a40b5fa58a1066
+Source0:       https://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
+# Source0-md5: b7393c17fdce9a8d383edab656c92fd2
+Patch0:                %{name}-missing.patch
 Patch1:                %{name}-man.patch
-URL:           http://wayland.freedesktop.org/
+URL:           https://wayland.freedesktop.org/
 BuildRequires: autoconf >= 2.64
 BuildRequires: automake >= 1:1.11
 BuildRequires: expat-devel >= 1.95
 BuildRequires: libffi-devel >= 3
 BuildRequires: libtool >= 2:2.2
+# for DTD valudation
+BuildRequires: libxml2-devel >= 2.0
 BuildRequires: pkgconfig
 %if %{with apidocs}
-BuildRequires: docbook-style-xsl
+BuildRequires: docbook-style-xsl-nons
 BuildRequires: doxygen >= 1.6.0
 BuildRequires: graphviz >= 2.26.0
 BuildRequires: libxslt-progs
@@ -71,10 +76,51 @@ Static Wayland libraries.
 %description static -l pl.UTF-8
 Statyczne biblioteki Wayland.
 
+%package egl
+Summary:       Wayland EGL library
+Summary(pl.UTF-8):     Biblioteka Wayland EGL
+Group:         Libraries
+Obsoletes:     Mesa-libwayland-egl < %{wayland_egl_ver}
+
+%description egl
+Wayland EGL library.
+
+%description egl -l pl.UTF-8
+Biblioteka Wayland EGL.
+
+%package egl-devel
+Summary:       Header files for Wayland EGL library
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki Wayland EGL
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+Requires:      %{name}-egl = %{version}-%{release}
+Obsoletes:     Mesa-libwayland-egl-devel < %{wayland_egl_ver}
+
+%description egl-devel
+Header files for Wayland EGL library.
+
+%description egl-devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki Wayland EGL.
+
+%package egl-static
+Summary:       Static Wayland EGL library
+Summary(pl.UTF-8):     Statyczna biblioteka Wayland EGL
+Group:         Development/Libraries
+Requires:      %{name}-egl-devel = %{version}-%{release}
+
+%description egl-static
+Static Wayland EGL library.
+
+%description egl-static -l pl.UTF-8
+Statyczna biblioteka Wayland EGL.
+
 %package apidocs
 Summary:       Wayland API and protocol documentation
 Summary(pl.UTF-8):     Dokumentacja API biblioteki oraz protokołu Wayland
 Group:         Documentation
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
 
 %description apidocs
 Wayland API and protocol documentation.
@@ -84,12 +130,11 @@ Dokumentacja API biblioteki oraz protokołu Wayland.
 
 %prep
 %setup -q
+%patch0 -p1
 %patch1 -p1
 
 # force regeneration (.so link is broken, double man3/)
 %{__rm} doc/man/*.3
-# force doxygen man regeneration
-%{__rm} -r doc/doxygen/man
 
 %build
 %{__libtoolize}
@@ -100,7 +145,7 @@ Dokumentacja API biblioteki oraz protokołu Wayland.
 %configure \
        %{!?with_apidocs:--disable-documentation} \
        --disable-silent-rules \
-       %{!?with_static_libs:--disable-static}
+       %{?with_static_libs:--enable-static}
 
 %{__make}
 
@@ -110,8 +155,11 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+%if %{with apidocs}
 # referenced by some installed wl_*.3 man pages
-cp -p doc/doxygen/man/man3/wayland-util.h.3 $RPM_BUILD_ROOT%{_mandir}/man3
+cp -p doc/doxygen/man/man3/wayland-{client,client-core,server,server-core,util}.h.3 \
+       doc/doxygen/man/man3/wayland-{client,server,shm,util}.c.3 $RPM_BUILD_ROOT%{_mandir}/man3
+%endif
 
 # obsoleted by pkg-config
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libwayland-*.la
@@ -142,7 +190,11 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libwayland-client.so
 %attr(755,root,root) %{_libdir}/libwayland-cursor.so
 %attr(755,root,root) %{_libdir}/libwayland-server.so
-%{_includedir}/wayland-*.h
+%{_includedir}/wayland-client*.h
+%{_includedir}/wayland-cursor.h
+%{_includedir}/wayland-server*.h
+%{_includedir}/wayland-util.h
+%{_includedir}/wayland-version.h
 %dir %{_datadir}/wayland
 %{_datadir}/wayland/wayland.dtd
 %{_datadir}/wayland/wayland.xml
@@ -153,9 +205,14 @@ rm -rf $RPM_BUILD_ROOT
 %{_pkgconfigdir}/wayland-server.pc
 %{_aclocaldir}/wayland-scanner.m4
 %if %{with apidocs}
-%{_mandir}/man3/wayland-util.h.3*
+%{_mandir}/man3/wayland-*.c.3*
+%{_mandir}/man3/wayland-*.h.3*
 %{_mandir}/man3/wl_*.3*
 %endif
+# NOTE: temporarily here because they're used but not included in Mesa 18.1.x
+# TODO: move to -egl-devel after transition to Mesa 18.2.x
+%{_includedir}/wayland-egl.h
+%{_includedir}/wayland-egl-core.h
 
 %if %{with static_libs}
 %files static
@@ -170,3 +227,21 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc doc/publican/Wayland/en-US/html/*
 %endif
+
+%files egl
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libwayland-egl.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libwayland-egl.so.1
+
+%files egl-devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libwayland-egl.so
+%{_includedir}/wayland-egl-backend.h
+%{_pkgconfigdir}/wayland-egl.pc
+%{_pkgconfigdir}/wayland-egl-backend.pc
+
+%if %{with static_libs}
+%files egl-static
+%defattr(644,root,root,755)
+%{_libdir}/libwayland-egl.a
+%endif
This page took 0.035375 seconds and 4 git commands to generate.