]> git.pld-linux.org Git - packages/vim.git/blobdiff - vim.spec
- up to 8.2.1524
[packages/vim.git] / vim.spec
index 1436f14a0840ba61abecdd54a2745f1908fbde37..b095226b3ec53559ac2f8ba3975a822844d34433 100644 (file)
--- a/vim.spec
+++ b/vim.spec
@@ -4,7 +4,7 @@
 %bcond_without athena          # don't build Athena Widgets-based gvim
 %bcond_without motif           # don't build Motif-based gvim
 %bcond_without gtk             # don't build GTK+-based gvim support
-%bcond_with    gtk3            # use GTK+ 3.x instead of 2.x
+%bcond_without gtk3            # use GTK+ 2.x instead of 3.x
 %bcond_without gnome           # don't build GNOME-based gvim support
 %bcond_without heavy           # don't build heavy (full-featured GNOME-based gvim/vim)
 %bcond_without gui             # don't build any GUI
 %bcond_without x11             # don't build vimx (non-GUI with X11 clipboard support)
 %bcond_with    lua             # with Lua interp in vim package
 %bcond_with    perl            # with Perl interp in vim package
-%bcond_with    python          # with Python interp in vim package
+%bcond_with    python          # with Python 2 interp in vim package
+%bcond_with    python3         # with Python 3 interp in vim package
 %bcond_with    ruby            # with Ruby interp in vim package
 %bcond_with    tcl             # with Tcl interp
+%bcond_with    x               # with X11 support
 %bcond_without selinux         # without selinux support
 %bcond_without home_etc        # without home_etc support
 
@@ -29,7 +31,7 @@
 # wget ftp://ftp.vim.org/pub/editors/vim/patches/8.0/MD5SUMS -O - | tail -n1 | awk '{print $2}'
 # VCS Commits: https://github.com/vim/vim/commits/master
 
-%define                ver             8.1.1005
+%define                ver             8.2.1524
 %define                rel             1
 Summary:       Vi IMproved - a Vi clone
 Summary(de.UTF-8):     VIsual editor iMproved
@@ -50,7 +52,7 @@ License:      Charityware
 Group:         Applications/Editors/Vim
 #Source0:      ftp://ftp.vim.org/pub/vim/unix/%{name}-%{ver}.tar.bz2
 Source0:       https://github.com/vim/vim/archive/v%{ver}.tar.gz
-# Source0-md5: 66228b5c4c1a3e0892bd24a3f08a5ea3
+# Source0-md5: 00e6782f70651a49b976c85ec0ab1895
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: bc4d1e115ca506ad7751b9bd2b773a7f
 Source2:       http://skawina.eu.org/mikolaj/usr_doc_pl.zip
@@ -115,14 +117,14 @@ BuildRequires:    attr-devel
 BuildRequires: autoconf >= 2.12
 BuildRequires: gpm-devel
 %if "%{pld_release}" == "ac"
-%if %{with athena} || %{with x11}
+%if %{with athena} || %{with x11} || %{with x}
 BuildRequires: XFree86-devel
 %endif
 BuildRequires: gettext-devel
 %else
 BuildRequires: gettext-tools
 %{?with_athena:BuildRequires:  xorg-lib-libXaw-devel}
-%if %{with x11} || %{with gui}
+%if %{with x11} || %{with gui} || %{with x}
 BuildRequires: xorg-lib-libICE-devel
 BuildRequires: xorg-lib-libSM-devel
 BuildRequires: xorg-lib-libX11-devel
@@ -137,6 +139,7 @@ BuildRequires:      gtk+3-devel >= 3.0
 BuildRequires: gtk+2-devel >= 2:2.6.0
 %endif
 %endif
+BuildRequires: libcanberra-devel
 %{?with_gnome:BuildRequires:   libgnomeui-devel >= 2.2.0.1}
 %if %{with selinux} || %{with heavy}
 BuildRequires: libselinux-devel
@@ -152,6 +155,11 @@ BuildRequires:     perl-devel
 %endif
 %if %{with python} || %{with heavy}
 BuildRequires: python-devel >= 2.3
+%endif
+%if %{with python3} || %{with heavy}
+BuildRequires: python3-devel
+%endif
+%if %{with python} || %{with python3} || %{with heavy}
 BuildRequires: rpm-pythonprov
 %endif
 BuildRequires: rpm >= 4.4.9-56
@@ -776,7 +784,7 @@ cp -p runtime/gvim.desktop gvim-motif.desktop
 %patch12 -p1
 %patch14 -p1
 %patch15 -p1
-%patch17 -p0
+%patch17 -p1
 %patch18 -p1
 %patch19 -p1
 %patch20 -p1
@@ -843,6 +851,7 @@ build() {
                --%{!?with_lua:dis}%{?with_lua:en}able-luainterp \
                --%{!?with_perl:dis}%{?with_perl:en}able-perlinterp \
                --%{!?with_python:dis}%{?with_python:en}able-pythoninterp \
+               --%{!?with_python3:dis}%{?with_python3:en}able-python3interp \
                --%{!?with_ruby:dis}%{?with_ruby:en}able-rubyinterp \
                --%{!?with_tcl:dis}%{?with_tcl:en}able-tclinterp \
                %{!?with_selinux:--disable-selinux} \
@@ -869,6 +878,7 @@ build vim.static \
        --disable-gui \
        --without-x \
        --with-features=small \
+       --disable-canberra \
        --disable-luainterp \
        --disable-perlinterp \
        --disable-pythoninterp \
@@ -887,6 +897,7 @@ build vim.light \
        --disable-gui \
        --without-x \
        --with-features=small \
+       --disable-canberra \
        --disable-luainterp \
        --disable-perlinterp \
        --disable-pythoninterp \
@@ -899,13 +910,15 @@ build vim.light \
 
 build vim.ncurses \
        --disable-gui \
-       --without-x \
+       %{__with_without x} \
+       --disable-canberra \
        --with-features=huge
 
 %if %{with x11}
 build vimx \
        --disable-gui \
        --with-x \
+       --disable-canberra \
        --with-features=huge
 %endif
 
@@ -915,6 +928,7 @@ build gvim.athena \
        --enable-gui=athena \
        --with-x \
        --enable-fontset \
+       --disable-canberra \
        --disable-gpm \
        --without-gnome
 
@@ -927,6 +941,7 @@ build gvim.motif \
        --with-x \
        --enable-multibyte \
        --enable-fontset \
+       --disable-canberra \
        --disable-gpm \
        --without-gnome
 
@@ -943,6 +958,7 @@ build gvim.gtk \
        --enable-gtk2-check \
 %endif
        --with-x \
+       --disable-canberra \
        --disable-gpm
 
 %endif
@@ -967,8 +983,10 @@ build vim.heavy \
        --enable-luainterp \
        --enable-perlinterp \
        --enable-pythoninterp \
+       --enable-python3interp \
        --enable-rubyinterp \
        --enable-tclinterp \
+       --disable-canberra \
        --disable-gpm
 
 build gvim.heavy \
@@ -980,6 +998,7 @@ build gvim.heavy \
        --enable-luainterp \
        --enable-perlinterp \
        --enable-pythoninterp \
+       --enable-python3interp \
        --enable-rubyinterp \
        --enable-tclinterp \
        --disable-gpm
This page took 0.037125 seconds and 4 git commands to generate.