]> git.pld-linux.org Git - packages/vim.git/blobdiff - vim.spec
- updated to patchversion 6.0.208
[packages/vim.git] / vim.spec
index d45f6e37dd9252281960891816942ab712049ff9..ade21d0de6343017bf4c1d52943d695194c3929c 100644 (file)
--- a/vim.spec
+++ b/vim.spec
@@ -6,11 +6,13 @@
 # _without_gtk         - without gtk+-based gvim support
 # _without_gnome       - without gnome-based gvim support
 # _with_ispell         - with spell checking (non-standard feature; disables RIGHTLEFT and FKMAP)
-# _with_python         - with support for pyhon scripts
-# _with_perl           - with support for perl scripts
+# _with_perl           - with perl interp
+# _with_python         - with python interp
+# _with_ruby           - with ruby interp
+# _with_tcl            - with tcl interp
 
 %define                _ver            6.0
-%define                _patchlevel     158
+%define                _patchlevel     208
 Summary:       Vi IMproved - a Vi clone
 Summary(de):   VIsual editor iMproved
 Summary(es):   Editor visual incrementado
@@ -53,6 +55,8 @@ BuildRequires:        ncurses-devel
 %{!?_without_static:BuildRequires:     ncurses-static}
 %{?_with_perl:BuildRequires:           perl-devel}
 %{?_with_python:BuildRequires:         python-devel}
+%{?_with_ruby:BuildRequires:           ruby}
+%{?_with_tcl:BuildRequires:            tcl-devel}
 Requires:      %{name}-rt = %{version}
 %{?_without_static:Requires:   %{name}-static = %{version}}
 Obsoletes:     vim-enhanced
@@ -242,7 +246,7 @@ bibliotek GNOME.
 %{?_with_ispell:%patch4 -p1}
 
 # these patches are to "extra" package which we don't need (nor use)
-rm -f patches/6.0.{027,048,053,064,070,073,093,106,107,115,116,117,119,123,121,122,125,135}
+rm -f patches/6.0.{027,048,053,064,070,073,093,106,107,115,116,117,119,123,121,122,125,135,161,162,164,165,179,186,188,205,207}
 # apply the rest of official patches
 for f in patches/6.0.* ; do
        echo "Applying official patch `basename $f` ..."
@@ -259,7 +263,10 @@ autoconf
        %{?_with_perl:--enable-perlinterp} \
        %{!?_with_python:--disable-pythoninterp} \
        %{?_with_python:--enable-pythoninterp} \
-       --disable-rubyinterp \
+       %{!?_with_ruby:--disable-rubyinterp} \
+       %{?_with_ruby:--enable-rubyinterp} \
+       %{!?_with_tcl:--disable-tclinterp} \
+       %{?_with_tcl:--enable-tclinterp} \
        --enable-cscope \
        --enable-gpm \
        --with-features=huge \
@@ -280,6 +287,7 @@ LDFLAGS="%{rpmldflags} -static"
        --without-x \
        --disable-perlinterp \
        --disable-pythoninterp \
+       --disable-rubyinterp \
        --disable-tclinterp \
        --disable-cscope \
        --disable-gpm \
@@ -303,6 +311,10 @@ LDFLAGS="%{rpmldflags}"
        %{?_with_perl:--enable-perlinterp} \
        %{!?_with_python:--disable-pythoninterp} \
        %{?_with_python:--enable-pythoninterp} \
+       %{!?_with_ruby:--disable-rubyinterp} \
+       %{?_with_ruby:--enable-rubyinterp} \
+       %{!?_with_tcl:--disable-tclinterp} \
+       %{?_with_tcl:--enable-tclinterp} \
        --enable-cscope \
        --enable-fontset \
        --disable-gpm \
@@ -322,6 +334,10 @@ mv -f vim gvim.athena
        %{?_with_perl:--enable-perlinterp} \
        %{!?_with_python:--disable-pythoninterp} \
        %{?_with_python:--enable-pythoninterp} \
+       %{!?_with_ruby:--disable-rubyinterp} \
+       %{?_with_ruby:--enable-rubyinterp} \
+       %{!?_with_tcl:--disable-tclinterp} \
+       %{?_with_tcl:--enable-tclinterp} \
        --enable-multibyte \
        --enable-cscope \
        --enable-fontset \
@@ -342,6 +358,10 @@ mv -f vim gvim.motif
        %{?_with_perl:--enable-perlinterp} \
        %{!?_with_python:--disable-pythoninterp} \
        %{?_with_python:--enable-pythoninterp} \
+       %{!?_with_ruby:--disable-rubyinterp} \
+       %{?_with_ruby:--enable-rubyinterp} \
+       %{!?_with_tcl:--disable-tclinterp} \
+       %{?_with_tcl:--enable-tclinterp} \
        --disable-gpm \
        --enable-cscope \
        --enable-fontset \
@@ -360,6 +380,10 @@ mv -f vim gvim.gtk
        %{?_with_perl:--enable-perlinterp} \
        %{!?_with_python:--disable-pythoninterp} \
        %{?_with_python:--enable-pythoninterp} \
+       %{!?_with_ruby:--disable-rubyinterp} \
+       %{?_with_ruby:--enable-rubyinterp} \
+       %{!?_with_tcl:--disable-tclinterp} \
+       %{?_with_tcl:--enable-tclinterp} \
        --disable-gpm \
        --enable-cscope \
        --enable-fontset \
@@ -375,7 +399,7 @@ install -d $RPM_BUILD_ROOT{%{_sysconfdir}/vim,%{_bindir}} \
        $RPM_BUILD_ROOT{%{_prefix}/X11R6/bin,%{_applnkdir}/Development/Editors}
 
 %{__make} install DESTDIR=$RPM_BUILD_ROOT
-rm $RPM_BUILD_ROOT%{_bindir}/*
+rm -f $RPM_BUILD_ROOT%{_bindir}/*
 
 %{!?_without_static:install src/vim.ncurses    $RPM_BUILD_ROOT%{_bindir}/vim}
 %{?_without_static:install src/vim.ncurses     $RPM_BUILD_ROOT/bin/vi}
This page took 0.052322 seconds and 4 git commands to generate.