]> git.pld-linux.org Git - packages/vim.git/blobdiff - vim.spec
- added egrep patch (check for egrep unconditionaly)
[packages/vim.git] / vim.spec
index daab1a65abb560db17502a885f6aec07f899473e..3f89ac6b7c2b8b5b97f16d526ce1e5194182752d 100644 (file)
--- a/vim.spec
+++ b/vim.spec
@@ -1,18 +1,17 @@
 #
 # Conditional build:
 # _without_static      - without static version
-# _without_athena      - without Athena Widgets-based gvim. DOESN'T WORK.
+# _without_athena      - without Athena Widgets-based gvim
 # _without_motif       - without Motif-based gvim
 # _without_gtk         - without gtk+-based gvim support
 # _without_gnome       - without gnome-based gvim support
-# _with_ispell         - with spell checking (non-standard feature; disables RIGHTLEFT and FKMAP)
 # _with_perl           - with perl interp
 # _with_python         - with python interp
 # _with_ruby           - with ruby interp
 # _with_tcl            - with tcl interp
 
 %define                _ver            6.1
-%define                _patchlevel     057
+%define                _patchlevel     212
 
 Summary:       Vi IMproved - a Vi clone
 Summary(de):   VIsual editor iMproved
@@ -25,13 +24,13 @@ Summary(tr):        Geli
 Summary(uk):   Visual editor IMproved - ´ÄÉÎÏ ÷¦ÒÎÉÊ òÅÄÁËÔÏÒ :)
 Name:          vim
 Version:       %{_ver}.%{_patchlevel}
-Release:       1
+Release:       2
 Epoch:         4
 License:       Charityware
 Group:         Applications/Editors/Vim
-Source0:       ftp://ftp.vim.org/pub/editors/vim/unix/%{name}-%{version}.tar.bz2
-Source1:       ftp://ftp.vim.org/pub/editors/vim/extra/%{name}-%{version}-lang.tar.gz
-Source2:       ftp://ftp.vim.org/pub/editors/vim/extra/%{name}-%{version}-extra.tar.gz
+Source0:       ftp://ftp.vim.org/pub/editors/vim/unix/%{name}-%{_ver}.tar.bz2
+Source1:       ftp://ftp.vim.org/pub/editors/vim/extra/%{name}-%{_ver}-lang.tar.gz
+Source2:       ftp://ftp.vim.org/pub/editors/vim/extra/%{name}-%{_ver}-extra.tar.gz
 # packed from  ftp://ftp.vim.org/pub/editors/vim/patches/6.1.*
 Source3:       %{name}-patches-%{_ver}.%{_patchlevel}.tar.bz2
 Source4:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
@@ -45,7 +44,11 @@ Patch2:              %{name}-paths.patch
 Patch3:                %{name}-ispell.patch
 Patch4:                %{name}-ispell-axp.patch
 Patch5:                %{name}-ac25x.patch
+Patch6:                %{name}-vimrc.patch
+Patch7:                %{name}-no_libelf.patch
+Patch8:                %{name}-egrep.patch
 URL:           http://www.vim.org/
+BuildRequires: acl-devel
 BuildRequires: autoconf
 BuildRequires: gettext-devel
 BuildRequires: gpm-devel
@@ -214,6 +217,19 @@ zalecana, mo
 ðÁËÅÔ vim-static ×ÓÔÁÎÏ×ÌÀ¤ Ò¦ÚÎÏ×ÉÄ vim ÑË /bin/vi, ÝÏ ÚÒÕÞÎÏ ÄÌÑ
 ÚÁÐÕÓËÕ ÎÁצÔØ ÔÏĦ, ËÏÌÉ ÚÍÏÎÔÏ×ÁÎÁ Ô¦ÌØËÉ ËÏÒÎØÏ×Á ÆÁÊÌÏ×Á ÓÉÓÔÅÍÁ.
 
+%package ispell
+Summary:       Vim with ispell support
+Summary(pl):   Vim z wsparciem dla ispella
+Group:         Applications/Editors/Vim
+Requires:      %{name}-rt = %{version}
+
+%description ispell
+Text editor similar to Vi. This version is built with ispell support.
+
+%description ispell -l pl
+Edytor tekstu podobny do Vi. Ta wersja zosta³a skompilowana ze
+wsparciem dla ispella.
+
 %package rt
 Summary:       Vim runtime files
 Summary(cs):   Soubory nezbytné pro libovolný editor ViM
@@ -419,17 +435,43 @@ done
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%{?_with_ispell:%patch3 -p1}
+%patch3 -p1
 %ifarch alpha
-%{?_with_ispell:%patch4 -p1}
+%patch4 -p1
 %endif
 %patch5 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
 
 %build
 cd src
-autoconf
+%{__autoconf}
 # needed to prevent deconfiguring
 cp -f configure auto
+
+%if %{!?_without_static:1}%{?_without_static:0}
+%{__make} distclean
+LDFLAGS="%{rpmldflags} -static"
+%configure \
+       --disable-gui \
+       --without-x \
+       --disable-perlinterp \
+       --disable-pythoninterp \
+       --disable-rubyinterp \
+       --disable-tclinterp \
+       --disable-cscope \
+       --disable-gpm \
+       --disable-multibyte \
+       --with-features=small \
+       --with-tlib=tinfo \
+       --disable-nls
+
+%{__make} SPELL_OBJ= vim
+mv -f vim vim.static
+LDFLAGS="%{rpmldflags}"
+%endif
+
 %configure \
        --disable-gui \
        --without-x \
@@ -448,35 +490,35 @@ cp -f configure auto
        --with-tlib=ncurses \
        --enable-nls
 
-%{__make} vim
+%{__make} SPELL_OBJ= vim
 mv -f vim vim.ncurses
 %{__make} xxd/xxd
 
-%if %{!?_without_static:1}%{?_without_static:0}
 %{__make} distclean
-LDFLAGS="%{rpmldflags} -static"
-%configure \
+%configure CFLAGS="%{rpmcflags} -DFEAT_SPELL_HL" \
        --disable-gui \
        --without-x \
-       --disable-perlinterp \
-       --disable-pythoninterp \
-       --disable-rubyinterp \
-       --disable-tclinterp \
-       --disable-cscope \
-       --disable-gpm \
-       --disable-multibyte \
-       --with-features=small \
-       --with-tlib=tinfo \
-       --disable-nls
+       %{!?_with_perl:--disable-perlinterp} \
+       %{?_with_perl:--enable-perlinterp} \
+       %{!?_with_python:--disable-pythoninterp} \
+       %{?_with_python:--enable-pythoninterp} \
+       %{!?_with_ruby:--disable-rubyinterp} \
+       %{?_with_ruby:--enable-rubyinterp} \
+       %{!?_with_tcl:--disable-tclinterp} \
+       %{?_with_tcl:--enable-tclinterp} \
+       --enable-cscope \
+       --enable-gpm \
+       --with-features=huge \
+       --enable-multibyte \
+       --with-tlib=ncurses \
+       --enable-nls
 
 %{__make} vim
-mv -f vim vim.static
-%endif
+mv -f vim vim.ispell
 
 %if %{!?_without_athena:1}%{?_without_athena:0}
 %{__make} distclean
-LDFLAGS="%{rpmldflags}"
-%configure \
+%configure CFLAGS="%{rpmcflags} -DFEAT_SPELL_HL" \
        --with-features=huge \
        --enable-gui=athena \
        --with-x \
@@ -499,7 +541,7 @@ mv -f vim gvim.athena
 
 %if %{!?_without_motif:1}%{?_without_motif:0}
 %{__make} distclean
-%configure \
+%configure CFLAGS="%{rpmcflags} -DFEAT_SPELL_HL" \
        --with-features=huge \
        --enable-gui=motif \
        --with-x \
@@ -523,7 +565,7 @@ mv -f vim gvim.motif
 
 %if %{!?_without_gtk:1}%{?_without_gtk:0}
 %{__make} distclean
-%configure \
+%configure CFLAGS="%{rpmcflags} -DFEAT_SPELL_HL" \
        --with-features=huge \
        --enable-gui=gtk \
        --with-x \
@@ -545,7 +587,7 @@ mv -f vim gvim.gtk
 
 %if %{!?_without_gnome:1}%{?_without_gnome:0}
 %{__make} distclean
-%configure \
+%configure CFLAGS="%{rpmcflags} -DFEAT_SPELL_HL" \
        --with-features=huge \
        --enable-gui=gnome \
        --with-x \
@@ -578,6 +620,7 @@ rm -f $RPM_BUILD_ROOT%{_bindir}/*
 %{?_without_static:install src/vim.ncurses     $RPM_BUILD_ROOT/bin/vi}
 %{!?_without_static:install src/vim.static     $RPM_BUILD_ROOT/bin/vi}
 %{?_without_static:ln -sf /bin/vi              $RPM_BUILD_ROOT%{_bindir}/vim}
+install src/vim.ispell                         $RPM_BUILD_ROOT%{_bindir}/vim.ispell
 install src/xxd/xxd                            $RPM_BUILD_ROOT%{_bindir}/xxd
 install src/vimtutor                           $RPM_BUILD_ROOT%{_bindir}/vimtutor
 
@@ -594,6 +637,7 @@ echo ".so vim.1" > $RPM_BUILD_ROOT%{_mandir}/man1/rvim.1
 echo ".so vim.1" > $RPM_BUILD_ROOT%{_mandir}/man1/vi.1
 echo ".so vim.1" > $RPM_BUILD_ROOT%{_mandir}/man1/view.1
 
+
 mv -f $RPM_BUILD_ROOT%{_datadir}/vim/v*/vimrc_example.vim $RPM_BUILD_ROOT%{_sysconfdir}/vim/vimrc
 mv -f $RPM_BUILD_ROOT%{_datadir}/vim/v*/gvimrc_example.vim $RPM_BUILD_ROOT%{_sysconfdir}/vim/gvimrc
 
@@ -627,6 +671,10 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/vim
 %attr(755,root,root) %{_bindir}/rvim
 
+%files ispell
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/vim.ispell
+
 %files -n xxd
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/xxd
@@ -696,7 +744,7 @@ rm -rf $RPM_BUILD_ROOT
 %lang(fr) %{_datadir}/vim/v*/lang/menu_fr_fr*
 %lang(hu) %{_datadir}/vim/v*/lang/menu_hu_hu*
 %lang(it) %{_datadir}/vim/v*/lang/menu_it_it*
-%lang(jp) %{_datadir}/vim/v*/lang/menu_ja_jp*
+%lang(ja) %{_datadir}/vim/v*/lang/menu_ja_jp*
 %lang(ko) %{_datadir}/vim/v*/lang/menu_ko_kr*
 %lang(nl) %{_datadir}/vim/v*/lang/menu_nl_nl*
 %lang(pl) %{_datadir}/vim/v*/lang/menu_pl_pl*
This page took 0.067534 seconds and 4 git commands to generate.