]> git.pld-linux.org Git - packages/tmux.git/blobdiff - tmux.spec
Rel 3; update from git
[packages/tmux.git] / tmux.spec
index 954df7a80e92f12798de4ec6c0ebecd936144b3d..f5262504fd07dd229a2e50c8ffda21af8dd78771 100644 (file)
--- a/tmux.spec
+++ b/tmux.spec
@@ -1,20 +1,36 @@
 # TODO:
 # - vim doesn't detect filetype
-# - pass LDFLAGS (fix as-needed problem first)
-Summary:       tmux is a terminal multiplexer
+#
+# Conditional build:
+%bcond_without systemd         # without system integration
+
+%define commit  e809c2ec359b0fd6151cf33929244b7a7d637119
+
+Summary:       tmux - a terminal multiplexer
 Summary(hu.UTF-8):     tmux egy terminál-sokszorozó
+Summary(pl.UTF-8):     tmux - multiplekser terminali
 Name:          tmux
-Version:       1.4
-Release:       1
-License:       BSD
+Version:       3.3a
+Release:       3
+License:       ISC
 Group:         Applications/Terminal
-Source0:       http://dl.sourceforge.net/tmux/%{name}-%{version}.tar.gz
-# Source0-md5: 0bfc7dd9a5bab192406167589c716a21
+#Source0Download: https://github.com/tmux/tmux/releases
+# Source0:     https://github.com/tmux/tmux/releases/download/%{version}/%{name}-%{version}.tar.gz
+Source0:        https://github.com/tmux/tmux/archive/%{commit}.zip
+# Source0-md5: f8eeb580e28377656d1d60f3b29e4dad
 Source1:       %{name}-filedetect.vim
-Patch0:                %{name}-makefile.patch
+Source2:       https://raw.githubusercontent.com/keith/tmux.vim/master/syntax/tmux.vim
+# Source2-md5: cd1169a1757b515b5c57816d339c6f72
+Source3:       https://raw.githubusercontent.com/imomaliev/tmux-bash-completion/master/completions/tmux
+# Source3-md5: 6d65c0f42c74f61602a399d7bb04a85c
+Source4:       tmux@.service
+URL:           http://tmux.github.io/
 BuildRequires: libevent-devel
-BuildRequires: ncurses-devel
-URL:           http://tmux.sourceforge.net/
+BuildRequires: libutempter-devel
+BuildRequires: ncurses-devel >= 5
+BuildRequires: pkgconfig
+BuildRequires: rpmbuild(macros) >= 1.673
+%{?with_systemd:BuildRequires: systemd-devel}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -30,10 +46,18 @@ csatlakozhatsz és irányíthatod egyetlen képernyőről. tmux
 lecsatlakozhat a képernyőről és folytathatja a futását a háttérben, és
 később újracsatlakozhatsz.
 
+%description -l pl.UTF-8
+tmux to multiplekser terminali: pozwala na tworzenie wielu terminali
+(lub okien) z osobnymi programami, dostęp do nich i sterowanie z
+pojedynczego ekranu. tmux może być odłączony od ekranu i nadal działać
+w tle, a następnie ponownie podłączony.
+
 %package -n vim-syntax-tmux
 Summary:       Vim syntax file to tmux config files
 Summary(hu.UTF-8):     Vim syntax fájl a tmux konfigurációs fájljához
+Summary(pl.UTF-8):     Plik składni Vima dla plików konfiguracyjnych tmuksa
 Group:         Applications/Editors/Vim
+Requires:      vim-rt
 
 %description -n vim-syntax-tmux
 Vim syntax file to tmux config files.
@@ -41,15 +65,30 @@ Vim syntax file to tmux config files.
 %description -n vim-syntax-tmux -l hu.UTF-8
 Vim syntax fájl a tmux konfigurációs fájljához.
 
+%package -n bash-completion-tmux
+Summary:       Bash completion for tmux
+Summary(pl.UTF-8):     Bashowe dopełnianie poleceń dla tmuksa
+Group:         Applications/Shells
+Requires:      %{name} = %{version}-%{release}
+Requires:      bash-completion >= 2.0
+
+%description -n bash-completion-tmux
+This package provides bash-completion for tmux.
+
+%description -n bash-completion-tmux -l pl.UTF-8
+Ten pakiet dostarcza bashowe dopełnianie składni dla polecenia tmux.
+
 %prep
-%setup -q
-%patch0 -p1
+%setup -q -n %{name}-%{commit}
 
 %build
-./configure
-CFLAGS="%{rpmcflags} -I/usr/include/ncursesw" %{__make} \
-       CC="%{__cc}" \
-       PREFIX=%{_prefix}
+[ ! -x configure ] && ./autogen.sh
+# note: on Linux use plain glibc functions instead of utf8proc
+%configure \
+       CPPFLAGS="%{rpmcppflags} -I/usr/include/ncursesw" \
+       %{__enable_disable systemd}
+
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -60,18 +99,27 @@ rm -rf $RPM_BUILD_ROOT
 
 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/{ftdetect,syntax}
 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/ftdetect/tmux.vim
-install examples/tmux.vim $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
+install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
+install -d $RPM_BUILD_ROOT%{bash_compdir}
+sed -e '1s,#!/usr/bin/env bash,#!/bin/bash,' %{SOURCE3} > $RPM_BUILD_ROOT%{bash_compdir}/%{name}
+install -d $RPM_BUILD_ROOT%{systemdunitdir}
+install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc CHANGES FAQ NOTES TODO examples/*.conf
-%attr(755,root,root) %{_bindir}/*
-%{_mandir}/man1/tmux*
+%doc CHANGES COPYING README
+%attr(755,root,root) %{_bindir}/tmux
+%{_mandir}/man1/tmux.1*
+%{systemdunitdir}/tmux@.service
 
 %files -n vim-syntax-tmux
 %defattr(644,root,root,755)
 %{_datadir}/vim/vimfiles/ftdetect/tmux.vim
 %{_datadir}/vim/vimfiles/syntax/tmux.vim
+
+%files -n bash-completion-tmux
+%defattr(644,root,root,755)
+%{bash_compdir}/%{name}
This page took 0.175736 seconds and 4 git commands to generate.