]> git.pld-linux.org Git - packages/tmux.git/blobdiff - tmux.spec
Rel 3; update from git
[packages/tmux.git] / tmux.spec
index 7c0137e0d823dfe4707a2422ca5d34086832233c..f5262504fd07dd229a2e50c8ffda21af8dd78771 100644 (file)
--- a/tmux.spec
+++ b/tmux.spec
@@ -1,21 +1,36 @@
 # TODO:
 # - vim doesn't detect filetype
-# - pass LDFLAGS (fix as-needed problem first)
+#
+# Conditional build:
+%bcond_without systemd         # without system integration
+
+%define commit  e809c2ec359b0fd6151cf33929244b7a7d637119
+
 Summary:       tmux - a terminal multiplexer
 Summary(hu.UTF-8):     tmux egy terminál-sokszorozó
 Summary(pl.UTF-8):     tmux - multiplekser terminali
 Name:          tmux
-Version:       2.0
-Release:       1
-License:       BSD
+Version:       3.3a
+Release:       3
+License:       ISC
 Group:         Applications/Terminal
-Source0:       http://downloads.sourceforge.net/tmux/%{name}-%{version}.tar.gz
-# Source0-md5: 9fb6b443392c3978da5d599f1e814eaa
+#Source0Download: https://github.com/tmux/tmux/releases
+# Source0:     https://github.com/tmux/tmux/releases/download/%{version}/%{name}-%{version}.tar.gz
+Source0:        https://github.com/tmux/tmux/archive/%{commit}.zip
+# Source0-md5: f8eeb580e28377656d1d60f3b29e4dad
 Source1:       %{name}-filedetect.vim
-URL:           http://tmux.sourceforge.net/
+Source2:       https://raw.githubusercontent.com/keith/tmux.vim/master/syntax/tmux.vim
+# Source2-md5: cd1169a1757b515b5c57816d339c6f72
+Source3:       https://raw.githubusercontent.com/imomaliev/tmux-bash-completion/master/completions/tmux
+# Source3-md5: 6d65c0f42c74f61602a399d7bb04a85c
+Source4:       tmux@.service
+URL:           http://tmux.github.io/
 BuildRequires: libevent-devel
 BuildRequires: libutempter-devel
-BuildRequires: ncurses-devel
+BuildRequires: ncurses-devel >= 5
+BuildRequires: pkgconfig
+BuildRequires: rpmbuild(macros) >= 1.673
+%{?with_systemd:BuildRequires: systemd-devel}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -55,7 +70,7 @@ Summary:      Bash completion for tmux
 Summary(pl.UTF-8):     Bashowe dopełnianie poleceń dla tmuksa
 Group:         Applications/Shells
 Requires:      %{name} = %{version}-%{release}
-Requires:      bash-completion
+Requires:      bash-completion >= 2.0
 
 %description -n bash-completion-tmux
 This package provides bash-completion for tmux.
@@ -64,13 +79,14 @@ This package provides bash-completion for tmux.
 Ten pakiet dostarcza bashowe dopełnianie składni dla polecenia tmux.
 
 %prep
-%setup -q
+%setup -q -n %{name}-%{commit}
 
 %build
-%{__aclocal}
-%{__autoconf}
+[ ! -x configure ] && ./autogen.sh
+# note: on Linux use plain glibc functions instead of utf8proc
 %configure \
-       CPPFLAGS="-I/usr/include/ncursesw"
+       CPPFLAGS="%{rpmcppflags} -I/usr/include/ncursesw" \
+       %{__enable_disable systemd}
 
 %{__make}
 
@@ -83,20 +99,21 @@ rm -rf $RPM_BUILD_ROOT
 
 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/{ftdetect,syntax}
 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/ftdetect/tmux.vim
-install examples/tmux.vim $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
-install -d $RPM_BUILD_ROOT%{_datadir}/bash-completion
-install examples/bash_completion_tmux.sh $RPM_BUILD_ROOT%{_datadir}/bash-completion/%{name}
-install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
-ln -s ../../%{_datadir}/bash-completion/%{name} $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
+install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
+install -d $RPM_BUILD_ROOT%{bash_compdir}
+sed -e '1s,#!/usr/bin/env bash,#!/bin/bash,' %{SOURCE3} > $RPM_BUILD_ROOT%{bash_compdir}/%{name}
+install -d $RPM_BUILD_ROOT%{systemdunitdir}
+install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc CHANGES FAQ README TODO examples/*.conf
+%doc CHANGES COPYING README
 %attr(755,root,root) %{_bindir}/tmux
 %{_mandir}/man1/tmux.1*
+%{systemdunitdir}/tmux@.service
 
 %files -n vim-syntax-tmux
 %defattr(644,root,root,755)
@@ -105,5 +122,4 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n bash-completion-tmux
 %defattr(644,root,root,755)
-%{_sysconfdir}/bash_completion.d/%{name}
-%{_datadir}/bash-completion/%{name}
+%{bash_compdir}/%{name}
This page took 0.038348 seconds and 4 git commands to generate.