]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - template.spec
sample to setup shadow py3 tree
[projects/template-specs.git] / template.spec
index a4b4a0556b81ec4e967d291a65436241c8f718ee..6b75431d76afc3e5b1a93aa6b449754134a6c012 100644 (file)
@@ -10,6 +10,8 @@ Version:      _
 Release:       0.1
 License:       - (enter GPL/GPL v2/GPL v3/LGPL/BSD/BSD-like/other license name here)
 Group:         Applications
+# SF URL: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
+# github URL https://github.com/USER/PROJECT/archive/v%{version}/%{plugin}-%{version}.tar.gz
 Source0:       %{name}-%{version}.tar.gz
 # Source0-md5: -
 #Source1:      -
@@ -21,6 +23,11 @@ BuildRequires:       rpmbuild(macros) >= 1.228
 Requires(post,preun):  /sbin/chkconfig
 Requires:      rc-scripts
 %endif
+%if %{with systemd_service}
+BuildRequires: rpmbuild(macros) >= 1.647
+Requires(post,preun,postun):   systemd-units >= 38
+Requires:      systemd-units >= 0.38
+%endif
 #BuildRequires:        -
 #BuildRequires:        autoconf
 #BuildRequires:        automake
@@ -47,6 +54,10 @@ BuildRoot:   %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Summary:       -
 Summary(pl.UTF-8):     -
 Group:         -
+# noarch subpackages only when building with rpm5
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
 
 %description subpackage
 
@@ -161,17 +172,28 @@ fi
 %endif
 
 %if %{with initscript}
-%post init
+%post
 /sbin/chkconfig --add %{name}
 %service %{name} restart
 
-%preun init
+%preun
 if [ "$1" = "0" ]; then
        %service -q %{name} stop
        /sbin/chkconfig --del %{name}
 fi
 %endif
 
+%if %{with systemd_service}
+%post
+%systemd_post %{name}.service
+
+%preun
+%systemd_preun %{name}.service
+
+%postun
+%systemd_reload
+%endif
+
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS CREDITS CHANGES ChangeLog NEWS README THANKS TODO
@@ -190,6 +212,10 @@ fi
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
 %endif
 
+%if %{with systemd_service}
+%{systemdunitdir}/%{name}.service
+%endif
+
 #%{_examplesdir}/%{name}-%{version}
 
 %if %{with subpackage}
This page took 0.056485 seconds and 4 git commands to generate.