]> git.pld-linux.org Git - packages/subversion.git/blobdiff - subversion.spec
- rebuild with perl 5.24.0
[packages/subversion.git] / subversion.spec
index ae494078b3908f93b972305b63e932a12fbd4a86..e598c9a0a20f9f053cd7d6cef418d643ebac27fe 100644 (file)
@@ -50,12 +50,12 @@ Summary:    A Concurrent Versioning system similar to but better than CVS
 Summary(pl.UTF-8):     System kontroli wersji podobny, ale lepszy, niż CVS
 Summary(pt_BR.UTF-8):  Sistema de versionamento concorrente
 Name:          subversion
-Version:       1.9.2
-Release:       1
+Version:       1.9.4
+Release:       2
 License:       Apache v2.0
 Group:         Development/Version Control
 Source0:       http://www.apache.org/dist/subversion/%{name}-%{version}.tar.bz2
-# Source0-md5: 0a7e55bb58fe77072f19e108a56b468b
+# Source0-md5: 29121a038f87641055a8183f49e9739f
 Source1:       %{name}-dav_svn.conf
 Source2:       %{name}-authz_svn.conf
 Source3:       %{name}-svnserve.init
@@ -69,6 +69,7 @@ Patch1:               %{name}-DESTDIR.patch
 Patch2:                %{name}-ruby-datadir-path.patch
 Patch3:                %{name}-tests.patch
 Patch4:                x32-libdir.patch
+Patch5:                %{name}-swig_py.patch
 URL:           http://subversion.apache.org/
 %{?with_apache:BuildRequires:  apache-devel >= 2.4.14}
 BuildRequires: apr-devel >= 1:1.3
@@ -80,8 +81,8 @@ BuildRequires:        cyrus-sasl-devel
 %if %{with kwallet} || %{with gnome}
 BuildRequires: dbus-devel
 %endif
-BuildRequires: db-devel >= 4.1.25
 %{!?with_db6:BuildRequires:    db-devel < 6}
+BuildRequires: db-devel >= 4.1.25
 BuildRequires: expat-devel
 BuildRequires: gettext-tools
 %{?with_gnome:BuildRequires:   glib2-devel >= 2.0}
@@ -444,6 +445,7 @@ uwierzytelniać się przy użyciu Portfela KDE.
 %patch2 -p0
 %patch3 -p1
 %patch4 -p1
+%patch5 -p0
 
 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
 
@@ -556,7 +558,8 @@ install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
        $RPM_BUILD_ROOT%{_sysconfdir}/%{name} \
        $RPM_BUILD_ROOT/home/services/subversion{,/repos}
 
-%{__make} install -j1 \
+%{__make} -j1 install \
+       pkgconfig_dir=%{_pkgconfigdir} \
        toolsdir=%{_bindir} \
        DESTDIR=$RPM_BUILD_ROOT \
        APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
@@ -569,21 +572,24 @@ install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
        swig_pydir=%{py_sitedir}/libsvn \
        swig_pydir_extra=%{py_sitedir}/svn \
 %endif
+       install-tools
+
 %if %{with csvn}
-       install-ctypes-python \
+# manually execute install-ctypes-python target
+cd subversion/bindings/ctypes-python
+%py_install
+cd ../../..
 %endif
-       install-tools
 
 %if %{with ruby}
-%{__make} install -j1 \
+%{__make} -j1 install-swig-rb install-swig-rb-doc \
        SWIG_RB_RI_DATADIR=$RPM_BUILD_ROOT%{ruby_ridir} \
-       DESTDIR=$RPM_BUILD_ROOT \
-       install-swig-rb install-swig-rb-doc
+       DESTDIR=$RPM_BUILD_ROOT
 
 # not our package
 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/OptionParser
 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Time
-%if "%{ruby_version}" >= "2.0"
+%if "%{ruby_abi}" >= "2.0"
 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/File
 %endif
 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
@@ -611,9 +617,9 @@ install -p tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
 %endif
 
 # rename not to conflict with standard packages. (are these needed at all?)
-mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff
-mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff3
-mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff4
+%{__mv} $RPM_BUILD_ROOT%{_bindir}/{,svn}diff
+%{__mv} $RPM_BUILD_ROOT%{_bindir}/{,svn}diff3
+%{__mv} $RPM_BUILD_ROOT%{_bindir}/{,svn}diff4
 
 %if %{with python} || %{with csvn}
 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
@@ -817,28 +823,30 @@ fi
 %{_libdir}/libsvn_subr-1.la
 %{_libdir}/libsvn_wc-1.la
 %if %{with gnome}
-%{_npkgconfigdir}/libsvn_auth_gnome_keyring.pc
+# only for feature check, linking will fail (no libsvn_auth_gnome_keyring.so)
+%{_pkgconfigdir}/libsvn_auth_gnome_keyring.pc
 %endif
 %if %{with kwallet}
-%{_npkgconfigdir}/libsvn_auth_kwallet.pc
+# only for feature check, linking will fail (no libsvn_auth_kwallet.so)
+%{_pkgconfigdir}/libsvn_auth_kwallet.pc
 %endif
-%{_npkgconfigdir}/libsvn_client.pc
-%{_npkgconfigdir}/libsvn_delta.pc
-%{_npkgconfigdir}/libsvn_diff.pc
-%{_npkgconfigdir}/libsvn_fs.pc
+%{_pkgconfigdir}/libsvn_client.pc
+%{_pkgconfigdir}/libsvn_delta.pc
+%{_pkgconfigdir}/libsvn_diff.pc
+%{_pkgconfigdir}/libsvn_fs.pc
 %if %{without net_client_only}
-%{_npkgconfigdir}/libsvn_fs_base.pc
-%endif
-%{_npkgconfigdir}/libsvn_fs_fs.pc
-%{_npkgconfigdir}/libsvn_fs_util.pc
-%{_npkgconfigdir}/libsvn_fs_x.pc
-%{_npkgconfigdir}/libsvn_ra.pc
-%{_npkgconfigdir}/libsvn_ra_local.pc
-%{_npkgconfigdir}/libsvn_ra_serf.pc
-%{_npkgconfigdir}/libsvn_ra_svn.pc
-%{_npkgconfigdir}/libsvn_repos.pc
-%{_npkgconfigdir}/libsvn_subr.pc
-%{_npkgconfigdir}/libsvn_wc.pc
+%{_pkgconfigdir}/libsvn_fs_base.pc
+%endif
+%{_pkgconfigdir}/libsvn_fs_fs.pc
+%{_pkgconfigdir}/libsvn_fs_util.pc
+%{_pkgconfigdir}/libsvn_fs_x.pc
+%{_pkgconfigdir}/libsvn_ra.pc
+%{_pkgconfigdir}/libsvn_ra_local.pc
+%{_pkgconfigdir}/libsvn_ra_serf.pc
+%{_pkgconfigdir}/libsvn_ra_svn.pc
+%{_pkgconfigdir}/libsvn_repos.pc
+%{_pkgconfigdir}/libsvn_subr.pc
+%{_pkgconfigdir}/libsvn_wc.pc
 %{_includedir}/%{name}-1
 %{_examplesdir}/%{name}-%{version}
 
This page took 0.068854 seconds and 4 git commands to generate.