]> git.pld-linux.org Git - packages/subversion.git/blobdiff - subversion.spec
- require new rcsparse package
[packages/subversion.git] / subversion.spec
index af98f023032ee8e30930391a5b9f25fd19df5294..bec0783a46ec4b99e2b29658508d86668ff6623e 100644 (file)
@@ -1,37 +1,43 @@
-%bcond_with    internal_neon
+#
+# Conditional build:
+%bcond_with    internal_neon           # build with internal neon
+%bcond_with    net_client_only         # build only net client
+#      
 %include        /usr/lib/rpm/macros.python
-%define        repov 5870
 Summary:       A Concurrent Versioning system similar to but better than CVS
 Summary(pl):   System kontroli wersji podobny, ale lepszy, ni¿ CVS
 Summary(pt_BR):        Sistema de versionamento concorrente
 Name:          subversion
-Version:       0.28
+Version:       0.32.1
 Release:       0.1
 License:       Apache/BSD Style
 Group:         Development/Version Control
-#Source0Download:      http://subversion.tigris.org/servlets/ProjectDocumentList?folderID=260
-Source0:       http://subversion.tigris.org/files/documents/15/%{repov}/subversion-%{version}.tar.gz
-# Source0-md5: 62a10c5ec13815e29f9bc100a1ee6dcc
+Source0:       http://svn.collab.net/tarballs/%{name}-%{version}.tar.gz
+# Source0-md5: b06717a8ef50db4b5c4d380af00bd901
 Source1:       %{name}-dav_svn.conf
 Source2:       %{name}-authz_svn.conf
 URL:           http://subversion.tigris.org/
-BuildRequires: apache-devel >= 2.0.47-0.2
-BuildRequires: apr-devel >= 2.0.47-0.2
+%if %{with net_client_only}
+%global apache_modules_api 0
+%else
+BuildRequires: apache-devel >= 2.0.47-0.6
+BuildRequires:  db-devel >= 4.1.25
+BuildRequires:  rpmbuild(macros) >= 1.120
+BuildRequires:  swig >= 1.3.17
+BuildRequires:  swig-python >= 1.3.17
+%endif
+BuildRequires: apr-devel >= 1:0.9.4
+BuildRequires: apr-util-devel >= 1:0.9.4
 BuildRequires: autoconf >= 2.53
 BuildRequires: bison
-BuildRequires: db-devel >= 4.1.25
-BuildRequires: docbook-style-xsl >= 1.60.1
+BuildRequires: docbook-style-xsl >= 1.56
 BuildRequires: expat-devel
 BuildRequires: libtool >= 1.4-9
-%{!?with_internal_neon:BuildRequires:  neon-devel = 0.23.9}
-BuildRequires: python >= 2.2
-BuildRequires: rpm-pythonprov >= 4.0.2-50
-BuildRequires: rpmbuild(macros) >= 1.120
-BuildRequires: swig >= 1.3.17
-BuildRequires: swig-python >= 1.3.17
+BuildRequires: libxslt-progs
+%{!?with_internal_neon:BuildRequires:  neon-devel >= 0.24.1}
+BuildRequires:  python >= 2.2
+BuildRequires:  rpm-pythonprov >= 4.0.2-50
 BuildRequires: texinfo
-Requires(post):        /usr/sbin/fix-info-dir
-Requires(postun):      /usr/sbin/fix-info-dir
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _apachelibdir   /usr/lib/apache
@@ -126,14 +132,29 @@ Biblioteka statyczna subversion.
 %description static -l pt_BR
 Este pacote provê um cliente estático do subversion.
 
+%package tools
+Summary:       Subversion tools and scripts
+Summary(pl):   Narzêdzia oraz skrypty dla subversion
+Summary(pt_BR):        Módulos python para acessar os recursos do Subversion
+Group:         Applications
+%pyrequires_eq python
+Requires:      python-rcsparse >= 0.1-0.20031026.0
+Requires:      python-subversion = %{version}
+
+%description tools
+Subversion tools and scripts.
+
+%description tools -l pl
+Narzêdzia oraz skrypty dla subversion.
+
+
 %package -n python-subversion
 Summary:       Subversion python bindings
 Summary(pl):   Dowi±zania do subversion dla pythona
 Summary(pt_BR):        Módulos python para acessar os recursos do Subversion
 Group:         Development/Languages/Python
-Requires:      python >= 2.2
-Obsoletes:     subversion-python
 %pyrequires_eq python
+Obsoletes:     subversion-python
 
 %description -n python-subversion
 Subversion python bindings.
@@ -180,22 +201,34 @@ chmod +x ./autogen.sh && ./autogen.sh
 
 # don't enable dso - currently it's broken
 %configure \
+%if %{with net_client_only}
+       --without-apache \
+       --without-swig \
+       --without-apxs \
+       --without-berkeley-db \
+%else
        --disable-dso \
        --disable-mod-activation \
+       --with-apxs=%{_sbindir}/apxs \
+       --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
+%endif
        %{!?with_internal_neon:--with-neon=%{_prefix}} \
        --with-apr=%{_bindir}/apr-config \
-       --with-apr-util=%{_bindir}/apu-config \
-       --with-apxs=%{_sbindir}/apxs \
-       --with-berkeley-db=%{_includedir}/db4:%{_libdir}
+       --with-apr-util=%{_bindir}/apu-config
+
 %{__make}
+
+%if ! %{with net_client_only}
 %{__make} swig-py \
        swig_pydir=%{py_sitedir}/libsvn \
        swig_pydir_extra=%{py_sitedir}/svn
+%endif
 
 # build documentation; build process for documentation is severely
 # braindamaged -- authors suggests to untar docbook distribution in
 # build directory, hence the hack here
-%{__make} -C doc/book XSL_DIR=/usr/share/sgml/docbook/xsl-stylesheets/ all-html
+%{__make} -C doc/book all-html \
+       XSL_DIR=/usr/share/sgml/docbook/xsl-stylesheets/
 
 # prepare for %%doc below
 mv -f doc/book/book/html-chunk svn-handbook
@@ -206,9 +239,9 @@ cp -f doc/book/book/images/*.png svn-handbook/images/
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_apachelibdir},%{_infodir}}
 
-%{__make} LC_ALL=C \
-       install \
-       install-swig-py \
+%{__make} install \
+       LC_ALL=C \
+       %{!?with_net_client_only:install-swig-py} \
        DESTDIR=$RPM_BUILD_ROOT \
        swig_pydir=%{py_sitedir}/libsvn \
        swig_pydir_extra=%{py_sitedir}/svn
@@ -217,8 +250,14 @@ install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/65_mod_dav_svn
 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/66_mod_authz_svn.conf
 install doc/programmer/design/*.info* $RPM_BUILD_ROOT%{_infodir}/
 
+%if ! %{with net_client_only}
+install tools/cvs2svn/cvs2svn.py       $RPM_BUILD_ROOT%{_bindir}/cvs2svn
+install tools/cvs2svn/cvs2svn.1                $RPM_BUILD_ROOT%{_mandir}/man1
+cp tools/cvs2svn/README tools/cvs2svn/README.cvs2svn
+
 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -248,11 +287,14 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc BUGS CHANGES COPYING IDEAS INSTALL README
+%doc BUGS CHANGES COPYING INSTALL README
 %doc svn-handbook doc/book/misc-docs/misc-docs.html
+%doc tools/hook-scripts/*.{pl,py,example}
+%doc tools/hook-scripts/mailer/*.{py,example}
 %attr(755,root,root) %{_bindir}/svn*
 #%exclude %{_bindir}/svn-config
 %{_mandir}/man1/*
+%{?with_internal_neon:%exclude %{_mandir}/man1/neon*}
 
 %files libs
 %defattr(644,root,root,755)
@@ -270,9 +312,16 @@ fi
 %defattr(644,root,root,755)
 %{_libdir}/lib*.a
 
+%if ! %{with net_client_only}
+%files tools
+%defattr(644,root,root,755)
+%doc tools/cvs2svn/README*
+%attr(755,root,root) %{_bindir}/cvs*
+%{_mandir}/man1/cvs*
+
 %files -n python-subversion
 %defattr(644,root,root,755)
-%doc tools/backup tools/cvs2svn/*.py tools/examples/*.py
+%doc tools/backup/*.py tools/examples/*.py
 %dir %{py_sitedir}/svn
 %dir %{py_sitedir}/libsvn
 %{py_sitedir}/svn/*.py[co]
@@ -289,3 +338,5 @@ fi
 %doc subversion/mod_authz_svn/INSTALL
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_authz_svn.conf
 %attr(755,root,root) %{_apachelibdir}/mod_authz_svn.so
+
+%endif
This page took 0.050299 seconds and 4 git commands to generate.