]> git.pld-linux.org Git - packages/subversion.git/blobdiff - subversion.spec
- added init to create default repo
[packages/subversion.git] / subversion.spec
index c95f5417e3c963a754e8eb12c7591ea3fbb69f0e..ad7efa944b3d7d467f53282eb58bfafd77b4c328 100644 (file)
@@ -1,7 +1,14 @@
 #
+# todo:
+# - remove net_client_only and add db bcond (then without apache and
+#   without db => net_client_only - spec will be more simpler, I think)
+#
 # Conditional build:
-%bcond_with    internal_neon           # build with internal neon
-%bcond_with    net_client_only         # build only net client
+%bcond_with            internal_neon           # build with internal neon
+%bcond_with            net_client_only         # build only net client
+%bcond_without python                          # build without python bindings
+%bcond_without perl                            # build without perl bindings
+%bcond_without apache                          # build without apache support (webdav, etc)
 #      
 %include       /usr/lib/rpm/macros.python
 %{!?with_net_client_only:%include      /usr/lib/rpm/macros.perl}
@@ -9,12 +16,12 @@ Summary:     A Concurrent Versioning system similar to but better than CVS
 Summary(pl):   System kontroli wersji podobny, ale lepszy, ni¿ CVS
 Summary(pt_BR):        Sistema de versionamento concorrente
 Name:          subversion
-Version:       1.0.1
-Release:       1
+Version:       1.0.5
+Release:       2
 License:       Apache/BSD Style
 Group:         Development/Version Control
-Source0:       http://svn.collab.net/tarballs/%{name}-%{version}.tar.bz2
-# Source0-md5: 50ca608d260b76d99ed85909acb7ae92
+Source0:       http://subversion.tigris.org/tarballs/%{name}-%{version}.tar.bz2
+# Source0-md5: 8e8288fee061f5278ec201fc5e5e141c
 Source1:       %{name}-dav_svn.conf
 Source2:       %{name}-authz_svn.conf
 Source3:       %{name}-svnserve.init
@@ -22,19 +29,22 @@ Source4:    %{name}-svnserve.sysconfig
 #Patch0:               %{name}-svnlook.patch
 #Patch1:               %{name}-hot_backup_num.patch
 URL:           http://subversion.tigris.org/
-Requires:      %{name}-libs = %{version}-%{release}
 %if %{with net_client_only}
 %global apache_modules_api 0
 %else
 BuildRequires: automake
-BuildRequires: apache-devel >= 2.0.47-0.6
+%{?with_apache:BuildRequires:  apache-devel >= 2.0.47-0.6}
 BuildRequires: db-devel >= 4.1.25
 BuildRequires: rpmbuild(macros) >= 1.120
+%if %{with python} || %{with perl}
 BuildRequires: swig >= 1.3.19
-BuildRequires: swig-python >= 1.3.19
+%endif
+%{?with_python:BuildRequires:  swig-python >= 1.3.19}
+%if %{with perl}
 BuildRequires: swig-perl >= 1.3.19
-BuildRequires: perl-devel >= 5.8.0
-BuildRequires: rpm-perlprov
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
+%endif
 %endif
 BuildRequires: apr-devel >= 1:0.9.5
 BuildRequires: apr-util-devel >= 1:0.9.5
@@ -44,11 +54,14 @@ BuildRequires:      docbook-style-xsl >= 1.56
 BuildRequires: expat-devel
 BuildRequires: libtool >= 1.4-9
 BuildRequires: libxslt-progs
-%{!?with_internal_neon:BuildRequires:  neon-devel >= 0.24.1}
+%{!?with_internal_neon:BuildRequires:  neon-devel >= 0.24.6}
+%if %{with python}
 BuildRequires: python-devel >= 2.2
 BuildRequires: rpm-pythonprov >= 4.0.2-50
+%endif
 BuildRequires: texinfo
 BuildRequires: which
+Requires:      %{name}-libs = %{version}-%{release}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _apachelibdir   /usr/%{_lib}/apache
@@ -101,6 +114,7 @@ Summary:    Subversion libraries and modules
 Summary(pl):   Biblioteka subversion oraz ³adowalne modu³y
 Group:         Libraries
 Obsoletes:     libsubversion0
+%{!?with_internal_neon:Requires:       neon >= 0.24.6}
 
 %description libs
 Subversion libraries and modules.
@@ -114,6 +128,8 @@ Summary(pl):        Pliki nag
 Summary(pt_BR):        Arquivos de desenvolvimento para o Subversion
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
+Requires:      apr-util-devel >= 1:0.9.5
+%{!?with_internal_neon:Requires:       neon-devel >= 0.24.6}
 Obsoletes:     libsubversion0-devel
 
 %description devel
@@ -242,6 +258,8 @@ Modu
 #%patch0 -p0
 #%patch1 -p1
 
+rm -rf apr-util{,/xml/expat}/autom4te.cache
+
 %build
 cp -f /usr/share/automake/config.sub ac-helpers
 chmod +x ./autogen.sh && ./autogen.sh
@@ -256,8 +274,16 @@ chmod +x ./autogen.sh && ./autogen.sh
 %else
        --disable-dso \
        --disable-mod-activation \
+%if %{with apache}
        --with-apxs=%{_sbindir}/apxs \
+%else
+       --without-apache \
+       --without-apxs \
        --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
+%endif
+%if !%{with python} && !%{with perl}
+       --without-swig \
+%endif
 %endif
        %{!?with_internal_neon:--with-neon=%{_prefix}} \
        --with-apr=%{_bindir}/apr-config \
@@ -265,12 +291,15 @@ chmod +x ./autogen.sh && ./autogen.sh
 
 %{__make}
 
-%if ! %{with net_client_only}
+%if !%{with net_client_only}
 # python
+%if %{with python}
 %{__make} swig-py \
        swig_pydir=%{py_sitedir}/libsvn \
        swig_pydir_extra=%{py_sitedir}/svn
+%endif
 # perl
+%if %{with perl}
 bdir=$(pwd)
 %{__make} install-swig-pl-lib \
        LC_ALL=C \
@@ -284,6 +313,7 @@ env APR_CONFIG=%{_bindir}/apr-config \
 env LIBRARY_PATH=${bdir}/swig-pl-lib-buildroot%{_libdir} %{__make}
 cd ../../../../
 %endif
+%endif
 
 # build documentation; build process for documentation is severely
 # braindamaged -- authors suggests to untar docbook distribution in
@@ -300,16 +330,19 @@ cp -f doc/book/book/images/*.png svn-handbook/images/
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
        $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_apachelibdir},%{_infodir}} \
-       $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}}
+       $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
+       $RPM_BUILD_ROOT/home/services/subversion
 
 %{__make} install \
        LC_ALL=C \
-       %{!?with_net_client_only:install-swig-py} \
+%if !%{with net_client_only} && %{with python}
+       install-swig-py \
+%endif
        DESTDIR=$RPM_BUILD_ROOT \
        swig_pydir=%{py_sitedir}/libsvn \
        swig_pydir_extra=%{py_sitedir}/svn
 
-%if ! %{with net_client_only}
+%if !%{with net_client_only} && %{with perl}
 %{__make} install-swig-pl-lib \
        LC_ALL=C \
        DESTDIR=$RPM_BUILD_ROOT
@@ -317,20 +350,23 @@ install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
        DESTDIR=$RPM_BUILD_ROOT
 %endif
 
+%if %{with apache}
 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/65_mod_dav_svn.conf
 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/66_mod_authz_svn.conf
 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
+%endif
 install doc/programmer/design/*.info* $RPM_BUILD_ROOT%{_infodir}/
 
-%if ! %{with net_client_only}
+%if !%{with net_client_only}
 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
-
+%if %{with python}
 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
 %endif
+%endif
 
 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
@@ -351,9 +387,12 @@ rm -rf $RPM_BUILD_ROOT
 if [ -f /var/lock/subsys/svnserve ]; then
        /etc/rc.d/init.d/svnserve restart 1>&2
 else
+       if [ ! -d /home/services/subversion/repos ]; then
+               echo "Creating default repository in /home/services/subversion/repos..."
+               svnadmin create /home/services/subversion/repos
+       fi
        echo "Run \"/etc/rc.d/init.d/svnserve start\" to start subversion svnserve daemon."
 fi
-
 %preun svnserve
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/svnserve ]; then
@@ -361,6 +400,7 @@ if [ "$1" = "0" ]; then
        fi
 fi
 
+
 %post -n apache-mod_dav_svn
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
@@ -407,19 +447,23 @@ fi
 %defattr(644,root,root,755)
 %{_libdir}/lib*.a
 
-%if ! %{with net_client_only}
+%if !%{with net_client_only}
 %files svnserve
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/svnserve
 %{_mandir}/man?/svnserve*
+%dir /home/services/subversion
+%if %{with apache}
 %attr(754,root,root) /etc/rc.d/init.d/svnserve
 %attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) /etc/sysconfig/svnserve
+%endif
 
 %files tools
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/svn-hot-backup
 /etc/bash_completion.d/%{name}
 
+%if %{with python}
 %files -n python-subversion
 %defattr(644,root,root,755)
 %doc tools/backup/*.py tools/examples/*.py
@@ -429,7 +473,9 @@ fi
 %{py_sitedir}/libsvn/*.py[co]
 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
 %{_examplesdir}/python-%{name}-%{version}
+%endif
 
+%if %{with perl}
 %files -n perl-subversion
 %defattr(644,root,root,755)
 %{perl_vendorarch}/SVN
@@ -438,7 +484,9 @@ fi
 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
 %{perl_vendorarch}/auto/SVN/*/*.bs
 %{_mandir}/man3/*.3pm*
+%endif
 
+%if %{with apache}
 %files -n apache-mod_dav_svn
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_dav_svn.conf
@@ -450,3 +498,4 @@ fi
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_authz_svn.conf
 %attr(755,root,root) %{_apachelibdir}/mod_authz_svn.so
 %endif
+%endif
This page took 0.034904 seconds and 4 git commands to generate.