]> git.pld-linux.org Git - packages/subversion.git/blobdiff - subversion.spec
- svn-hot-backup if !with_net_client_only
[packages/subversion.git] / subversion.spec
index b0c60a279547e736d9b2c8c260032d72faa6c595..8ab0457be57b230eb7be728073aec7cc6e5f8eb6 100644 (file)
@@ -1,57 +1,69 @@
 #
-# TODO:
-# - separate subpackage with svnserve + init.d script + sysconfig file
+# todo:
+# - remove net_client_only and add db bcond (then without apache and
+#   without db => net_client_only - spec will be more simpler, I think)
 #
 # Conditional build:
-%bcond_with    internal_neon           # build with internal neon
-%bcond_with    net_client_only         # build only net client
-#      
-%include       /usr/lib/rpm/macros.python
+%bcond_with    net_client_only                 # build only net client
+%bcond_without python                          # build without python bindings
+%bcond_without perl                            # build without perl bindings
+%bcond_without apache                          # build without apache support (webdav, etc)
+#
 %{!?with_net_client_only:%include      /usr/lib/rpm/macros.perl}
+%define        apxs    /usr/sbin/apxs
 Summary:       A Concurrent Versioning system similar to but better than CVS
 Summary(pl):   System kontroli wersji podobny, ale lepszy, ni¿ CVS
 Summary(pt_BR):        Sistema de versionamento concorrente
 Name:          subversion
-Version:       0.34.0
+Version:       1.3.2
 Release:       1
 License:       Apache/BSD Style
 Group:         Development/Version Control
-Source0:       http://svn.collab.net/tarballs/%{name}-%{version}.tar.gz
-# Source0-md5: 52f3a73858566d4d7045e449d94390e3
+Source0:       http://subversion.tigris.org/downloads/%{name}-%{version}.tar.gz
+# Source0-md5: f790c49c219b4196e37ebfa71ab797d5
 Source1:       %{name}-dav_svn.conf
 Source2:       %{name}-authz_svn.conf
 Source3:       %{name}-svnserve.init
 Source4:       %{name}-svnserve.sysconfig
-Patch0:                %{name}-perl.patch
-Patch1:                %{name}-svnlook.patch
+Patch0:                %{name}-home_etc.patch
+Patch1:                %{name}-DESTDIR.patch
+Patch2:                %{name}-neon.patch
 URL:           http://subversion.tigris.org/
 %if %{with net_client_only}
 %global apache_modules_api 0
 %else
-BuildRequires: apache-devel >= 2.0.47-0.6
+%{?with_apache:BuildRequires:  apache-devel >= 2.2.0-8}
+BuildRequires: automake
 BuildRequires: db-devel >= 4.1.25
-BuildRequires: rpmbuild(macros) >= 1.120
-BuildRequires: swig >= 1.3.17
-BuildRequires: swig-python >= 1.3.17
-BuildRequires: perl-devel >= 5.8.0
-BuildRequires: rpm-perlprov
+BuildRequires: rpmbuild(macros) >= 1.268
+%if %{with perl}
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
+BuildRequires: swig-perl >= 1.3.24
+%endif
 %endif
-BuildRequires: apr-devel >= 1:0.9.5
-BuildRequires: apr-util-devel >= 1:0.9.5
-BuildRequires: autoconf >= 2.53
+BuildRequires: apr-devel >= 1:1.0.0
+BuildRequires: apr-util-devel >= 1:1.0.0
+BuildRequires: autoconf >= 2.59
 BuildRequires: bison
-BuildRequires: docbook-style-xsl >= 1.56
 BuildRequires: expat-devel
+BuildRequires: gettext-devel
 BuildRequires: libtool >= 1.4-9
-BuildRequires: libxslt-progs
-%{!?with_internal_neon:BuildRequires:  neon-devel >= 0.24.1}
+BuildRequires: neon-devel >= 0.26.0
+%if %{with python}
 BuildRequires: python >= 2.2
-BuildRequires: rpm-pythonprov >= 4.0.2-50
+BuildRequires: python-devel >= 2.2
+BuildRequires: python-modules >= 2.2
+BuildRequires: sed >= 4.0
+BuildRequires: swig-python >= 1.3.24
+%endif
 BuildRequires: texinfo
+BuildRequires: which
+Requires:      %{name}-libs = %{version}-%{release}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _apachelibdir   /usr/lib/apache
-%define                _libexecdir     %{_libdir}/svn
+%define                _apachelibdir   %(%{apxs} -q LIBEXECDIR 2>/dev/null)
+%define                _libexecdir             %{_libdir}/svn
 
 %description
 The goal of the Subversion project is to build a version control
@@ -99,6 +111,7 @@ System) na comunidade opensource, fornecendo grandes melhorias.
 Summary:       Subversion libraries and modules
 Summary(pl):   Biblioteka subversion oraz ³adowalne modu³y
 Group:         Libraries
+Requires:      neon >= 0.24.7
 Obsoletes:     libsubversion0
 
 %description libs
@@ -112,7 +125,9 @@ Summary:    Header files and develpment documentation for subversion
 Summary(pl):   Pliki nag³ówkowe i dokumetacja do subversion
 Summary(pt_BR):        Arquivos de desenvolvimento para o Subversion
 Group:         Development/Libraries
-Requires:      %{name}-libs = %{version}
+Requires:      %{name}-libs = %{version}-%{release}
+Requires:      apr-util-devel >= 1:1.0.0
+Requires:      neon-devel >= 0.24.7
 Obsoletes:     libsubversion0-devel
 
 %description devel
@@ -146,8 +161,9 @@ Este pacote prov
 Summary:       Subversion svnserve
 Summary(pl):   Subversion svnserve
 Group:         Networking/Daemons
-PreReq:                rc-scripts
 Requires(post,preun):  /sbin/chkconfig
+Requires:      %{name} = %{version}-%{release}
+Requires:      rc-scripts
 
 %description svnserve
 Subversion svnserve server.
@@ -161,6 +177,7 @@ Summary(pl):        Narz
 Summary(pt_BR):        Módulos python para acessar os recursos do Subversion
 Group:         Applications
 %pyrequires_eq python
+Requires:      %{name} = %{version}-%{release}
 Requires:      python-rcsparse >= 0.1-0.20031026.0
 Requires:      python-subversion = %{version}
 
@@ -170,12 +187,27 @@ Subversion tools and scripts.
 %description tools -l pl
 Narzêdzia oraz skrypty dla subversion.
 
+%package -n bash-completion-subversion
+Summary:       bash completion for subversion
+Summary(pl):   Dope³nienia basha dla subversion
+Group:         Applications/Shells
+Requires:      %{name} = %{version}-%{release}
+Requires:      bash-completion
+Conflicts:     %{name}-tools <= 1.1.0-0.rc6.1
+
+%description -n bash-completion-subversion
+Bash completion for subversion.
+
+%description -n bash-completion-subversion -l pl
+Dope³nienia basha dla subversion.
+
 %package -n python-subversion
 Summary:       Subversion python bindings
 Summary(pl):   Dowi±zania do subversion dla pythona
 Summary(pt_BR):        Módulos python para acessar os recursos do Subversion
 Group:         Development/Languages/Python
 %pyrequires_eq python
+Requires:      %{name}-libs = %{version}-%{release}
 Obsoletes:     subversion-python
 
 %description -n python-subversion
@@ -192,6 +224,7 @@ Summary:    Subversion perl bindings
 Summary(pl):   Dowi±zania do subversion dla perla
 Summary(pt_BR):        Módulos perl para acessar os recursos do Subversion
 Group:         Development/Languages/Perl
+Requires:      %{name}-libs = %{version}-%{release}
 Obsoletes:     subversion-perl
 
 %description -n perl-subversion
@@ -207,8 +240,8 @@ M
 Summary:       Apache module: Subversion Server
 Summary(pl):   Modu³ apache: Serwer Subversion
 Group:         Networking/Daemons
-Requires:      apache >= 2.0.47
-Requires:      apache(modules-api) = %{apache_modules_api}
+Requires:      %{name} = %{version}-%{release}
+Requires:      apache(modules-api) = %apache_modules_api
 Requires:      apache-mod_dav
 
 %description -n apache-mod_dav_svn
@@ -221,9 +254,8 @@ Modu
 Summary:       Apache module: Subversion Server - path-based authorization
 Summary(pl):   Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion
 Group:         Networking/Daemons
-Requires:      apache-mod_dav_svn = %{version}
-Requires:      apache >= 2.0.47
-Requires:      apache(modules-api) = %{apache_modules_api}
+Requires:      apache(modules-api) = %apache_modules_api
+Requires:      apache-mod_dav_svn = %{version}-%{release}
 
 %description -n apache-mod_authz_svn
 Apache module: Subversion Server - path-based authorization.
@@ -233,14 +265,21 @@ Modu
 
 %prep
 %setup -q
-%patch0 -p1
-%patch1 -p0
+rm -rf apr apr-util neon
+%patch0 -p0
+%patch1 -p1
+%patch2 -p1
 
 %build
+cp -f /usr/share/automake/config.sub ac-helpers
 chmod +x ./autogen.sh && ./autogen.sh
 
 # don't enable dso - currently it's broken
 %configure \
+       --with-editor=vi \
+       --with-zlib \
+       --with-python=%{_bindir}/python \
+       --with-perl5=%{_bindir}/perl \
 %if %{with net_client_only}
        --without-apache \
        --without-swig \
@@ -249,80 +288,96 @@ chmod +x ./autogen.sh && ./autogen.sh
 %else
        --disable-dso \
        --disable-mod-activation \
+%if %{with apache}
        --with-apxs=%{_sbindir}/apxs \
+%else
+       --without-apache \
+       --without-apxs \
        --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
 %endif
-       %{!?with_internal_neon:--with-neon=%{_prefix}} \
-       --with-apr=%{_bindir}/apr-config \
-       --with-apr-util=%{_bindir}/apu-config
+%if !%{with python} && !%{with perl}
+       --without-swig \
+%endif
+%endif
+       --with-neon=%{_prefix} \
+       --disable-neon-version-check \
+       --with-apr=%{_bindir}/apr-1-config \
+       --with-apr-util=%{_bindir}/apu-1-config
 
 %{__make}
 
-%if ! %{with net_client_only}
+%if !%{with net_client_only}
 # python
+%if %{with python}
 %{__make} swig-py \
        swig_pydir=%{py_sitedir}/libsvn \
        swig_pydir_extra=%{py_sitedir}/svn
+%endif
 # perl
-bdir=$(pwd)
-%{__make} install-swig-pl-lib \
-       LC_ALL=C \
-       DESTDIR=${bdir}/swig-pl-lib-buildroot
+%if %{with perl}
+%{__make} swig-pl-lib
+odir=$(pwd)
+cd subversion/bindings/swig/perl/native
+%{__perl} Makefile.PL INSTALLDIRS=vendor
 %{__make}
-cd subversion/bindings/swig/perl
-env APR_CONFIG=%{_bindir}/apr-config \
-       %{__perl} Makefile.PL \
-       INSTALLDIRS=vendor
-env LIBRARY_PATH=${bdir}/swig-pl-lib-buildroot%{_libdir} %{__make}
-cd ../../../../
+cd $odir
+%endif
 %endif
 
-# build documentation; build process for documentation is severely
-# braindamaged -- authors suggests to untar docbook distribution in
-# build directory, hence the hack here
-ln -s /usr/share/sgml/docbook/xsl-stylesheets doc/book/tools/xsl
-%{__make} -C doc/book all-html
-
-# prepare for %%doc below
-mv -f doc/book/book/html-chunk svn-handbook
-mkdir svn-handbook/images/
-cp -f doc/book/book/images/*.png svn-handbook/images/
+%{__sed} -i -e 's/@SVN_DB_INCLUDES@//g' -e 's/@SVN_DB_LIBS@//g' svn-config
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
-install -d $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_apachelibdir},%{_infodir}}
+install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
+       $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_apachelibdir},%{_infodir}} \
+       $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
+       $RPM_BUILD_ROOT/home/services/subversion{,/repos}
 
 %{__make} install \
-       LC_ALL=C \
-       %{!?with_net_client_only:install-swig-py} \
+%if !%{with net_client_only} && %{with python}
+       install-swig-py \
+%endif
+       APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
        DESTDIR=$RPM_BUILD_ROOT \
        swig_pydir=%{py_sitedir}/libsvn \
        swig_pydir_extra=%{py_sitedir}/svn
 
-%if ! %{with net_client_only}
+%if !%{with net_client_only} && %{with perl}
 %{__make} install-swig-pl-lib \
-       LC_ALL=C \
-       DESTDIR=$RPM_BUILD_ROOT
-%{__make} -C subversion/bindings/swig/perl install \
        DESTDIR=$RPM_BUILD_ROOT
+odir=$(pwd)
+cd subversion/bindings/swig/perl/native
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT \
+       PREFIX=$RPM_BUILD_ROOT%{_prefix} \
+       LIBDIR=$RPM_BUILD_ROOT%{_libdir}
+cd $odir
 %endif
 
+install svn-config $RPM_BUILD_ROOT%{_bindir}
+
+%if %{with apache}
 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/65_mod_dav_svn.conf
 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/66_mod_authz_svn.conf
 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
-install doc/programmer/design/*.info* $RPM_BUILD_ROOT%{_infodir}/
-
-%if ! %{with net_client_only}
-install tools/cvs2svn/cvs2svn.py       $RPM_BUILD_ROOT%{_bindir}/cvs2svn
-install tools/cvs2svn/cvs2svn.1                $RPM_BUILD_ROOT%{_mandir}/man1
-cp tools/cvs2svn/README tools/cvs2svn/README.cvs2svn
+%endif
 
+%if !%{with net_client_only}
+install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
+%if %{with python}
 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
+find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
+install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
+%endif
 %endif
 
+install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
+install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+
+%find_lang %{name}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -334,78 +389,89 @@ rm -rf $RPM_BUILD_ROOT
 
 %post  libs -p /sbin/ldconfig
 %postun        libs -p /sbin/ldconfig
+%post   -n python-subversion -p /sbin/ldconfig
+%postun -n perl-subversion -p /sbin/ldconfig
 
 %post svnserve
-if [ -f /var/lock/subsys/svnserve ]; then
-       /etc/rc.d/init.d/svnserve restart 1>&2
-else
-       echo "Run \"/etc/rc.d/init.d/svnserve start\" to start subversion svnserve daemon."
-fi
+/sbin/chkconfig --add svnserve
+%service svnserve restart "svnserve daemon"
 
 %preun svnserve
 if [ "$1" = "0" ]; then
-       if [ -f /var/lock/subsys/svnserve ]; then
-               /etc/rc.d/init.d/svnserve restart 1>&2
-       fi
+       %service svnserve stop
+       /sbin/chkconfig --del svnserve
 fi
 
 %post -n apache-mod_dav_svn
-if [ -f /var/lock/subsys/httpd ]; then
-       /etc/rc.d/init.d/httpd restart 1>&2
-else
-       echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
-fi
+%service -q httpd restart
 
 %preun -n apache-mod_dav_svn
 if [ "$1" = "0" ]; then
-       if [ -f /var/lock/subsys/httpd ]; then
-               /etc/rc.d/init.d/httpd restart 1>&2
-       fi
+       %service -q httpd restart
 fi
 
 %files
 %defattr(644,root,root,755)
 %doc BUGS CHANGES COPYING INSTALL README
-%doc svn-handbook doc/book/misc-docs/misc-docs.html
+%doc doc/*/*.html
 %doc tools/hook-scripts/*.{pl,py,example}
 %doc tools/hook-scripts/mailer/*.{py,example}
+%doc tools/xslt/*
 %attr(755,root,root) %{_bindir}/svn*
 %exclude %{_bindir}/svnserve
+%exclude %{_bindir}/svn-config
+%if %{without net_client_only}
+%exclude %{_bindir}/svn-hot-backup
+%endif
 %{_mandir}/man1/*
 %{_mandir}/man5/*
 %{_mandir}/man8/*
 %exclude %{_mandir}/man?/svnserve*
-%{?with_internal_neon:%exclude %{_mandir}/man1/neon*}
 
-%files libs
+%files libs -f %{name}.lang
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/lib*.so.*
+%if %{with perl} || %{with python}
+%exclude %{_libdir}/lib*_swig_*.so.*
+%endif
 
 %files devel
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/svn-config
 %{_includedir}/%{name}*
 %attr(755,root,root) %{_libdir}/lib*.so
 %{_libdir}/lib*.la
-%{_infodir}/svn*
+%if %{with perl} || %{with python}
+%exclude %{_libdir}/lib*_swig_*.so
+%exclude %{_libdir}/lib*swig*.la
+%endif
+%{_examplesdir}/%{name}-%{version}
 
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/lib*.a
 
-%if ! %{with net_client_only}
+%if %{without net_client_only}
 %files svnserve
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/svnserve
 %{_mandir}/man?/svnserve*
+%dir /home/services/subversion
+%dir /home/services/subversion/repos
+%if %{with apache}
 %attr(754,root,root) /etc/rc.d/init.d/svnserve
-%attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) /etc/sysconfig/svnserve
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
+%endif
 
 %files tools
 %defattr(644,root,root,755)
-%doc tools/cvs2svn/README*
-%attr(755,root,root) %{_bindir}/cvs*
-%{_mandir}/man1/cvs*
+%attr(755,root,root) %{_bindir}/svn-hot-backup
 
+%files -n bash-completion-subversion
+%defattr(644,root,root,755)
+/etc/bash_completion.d/%{name}
+
+%if %{with python}
 %files -n python-subversion
 %defattr(644,root,root,755)
 %doc tools/backup/*.py tools/examples/*.py
@@ -414,7 +480,12 @@ fi
 %{py_sitedir}/svn/*.py[co]
 %{py_sitedir}/libsvn/*.py[co]
 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
+%{_examplesdir}/python-%{name}-%{version}
+%attr(755,root,root) %{_libdir}/lib*_swig_py*.so*
+%{_libdir}/lib*_swig_py*.la
+%endif
 
+%if %{with perl}
 %files -n perl-subversion
 %defattr(644,root,root,755)
 %{perl_vendorarch}/SVN
@@ -423,15 +494,21 @@ fi
 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
 %{perl_vendorarch}/auto/SVN/*/*.bs
 %{_mandir}/man3/*.3pm*
+%attr(755,root,root) %{_libdir}/lib*_swig_perl*.so*
+%{_libdir}/lib*_swig_perl*.la
+%endif
 
+%if %{with apache}
 %files -n apache-mod_dav_svn
 %defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_dav_svn.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd/httpd.conf/*_mod_dav_svn.conf
 %attr(755,root,root) %{_apachelibdir}/mod_dav_svn.so
 
 %files -n apache-mod_authz_svn
 %defattr(644,root,root,755)
 %doc subversion/mod_authz_svn/INSTALL
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_authz_svn.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd/httpd.conf/*_mod_authz_svn.conf
 %attr(755,root,root) %{_apachelibdir}/mod_authz_svn.so
 %endif
+
+%endif # net_client_only
This page took 0.046539 seconds and 4 git commands to generate.