]> git.pld-linux.org Git - packages/subversion.git/blobdiff - subversion.spec
fix ruby packaging
[packages/subversion.git] / subversion.spec
index ade834e63a99babe8abe056ac696b489e8cb38fe..247c53b7996d08d3fd2f8ced8ec8a81f8794ff0f 100644 (file)
@@ -6,20 +6,24 @@
 %bcond_without perl                    # build without Perl bindings
 %bcond_without ruby                    # build without Ruby bindings
 %bcond_without apache                  # build without Apache support (webdav, etc)
-%bcond_without javahl                  # build without javahl support (Java high-level bindings)
+%bcond_without java                    # build without javahl support (Java high-level bindings)
 %bcond_without tests                   # don't perform "make check"
 %bcond_without kwallet                 # build without kde4 wallet support
 %bcond_without kde                     # build without kde4 support (alias for kwallet)
 %bcond_without gnome                   # build without gnome keyring support
 %bcond_without db                      # disable Subversion Berkeley DB based filesystem library
+%bcond_with    db6                     # allow BDB6 (not tested by upstream, released on AGPL)
 
-# for AC: --without csvn,gnome,javahl,kde,ruby
+# for AC: --without csvn,gnome,java,kde,ruby
 
 %if %{with net_client_only}
 %undefine      with_apache
 %undefine      with_db
 %undefine      with_swig
-%undefine      with_javahl
+%undefine      with_java
+%undefine      with_csvn
+%undefine      with_gnome
+%undefine      with_kde
 %endif
 
 %if %{without swig}
@@ -45,12 +49,12 @@ Summary:    A Concurrent Versioning system similar to but better than CVS
 Summary(pl.UTF-8):     System kontroli wersji podobny, ale lepszy, niż CVS
 Summary(pt_BR.UTF-8):  Sistema de versionamento concorrente
 Name:          subversion
-Version:       1.8.0
-Release:       0.1
+Version:       1.8.9
+Release:       2
 License:       Apache v2.0
 Group:         Development/Version Control
-Source0:       http://www.idg.pl/mirrors/apache/subversion/%{name}-%{version}.tar.bz2
-# Source0-md5: f053a9948dfe5c70eff5c00509723214
+Source0:       http://www.apache.org/dist/subversion/%{name}-%{version}.tar.bz2
+# Source0-md5: bd495517a760ddd764ce449a891971db
 Source1:       %{name}-dav_svn.conf
 Source2:       %{name}-authz_svn.conf
 Source3:       %{name}-svnserve.init
@@ -86,11 +90,11 @@ BuildRequires:      pkgconfig
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.656
 BuildRequires: sed >= 4.0
+BuildRequires: serf-devel >= 1.2.1
 BuildRequires: sqlite3-devel >= 3.6.18
 BuildRequires: texinfo
 BuildRequires: which
-BuildRequires: serf-devel >= 1.2.1
-%if %{with javahl}
+%if %{with java}
 BuildRequires: jdk >= 1.5
 BuildRequires: libstdc++-devel
 %endif
@@ -106,6 +110,7 @@ BuildRequires:      swig-python >= 1.3.24
 %if %{with ruby}
 BuildRequires: rpm-rubyprov
 BuildRequires: ruby-devel >= 1:1.8.2
+BuildRequires: ruby-irb
 BuildRequires: ruby-rubygems
 BuildRequires: swig-ruby >= 1.3.24
 %endif
@@ -181,6 +186,7 @@ Summary(pt_BR.UTF-8):       Arquivos de desenvolvimento para o Subversion
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      apr-util-devel >= 1:1.0.0
+Requires:      serf-devel >= 1.2.1
 Obsoletes:     libsubversion0-devel
 
 %description devel
@@ -256,6 +262,9 @@ Group:              Applications/Shells
 Requires:      %{name} = %{version}-%{release}
 Requires:      bash-completion
 Conflicts:     %{name}-tools <= 1.1.0-0.rc6.1
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
 
 %description -n bash-completion-subversion
 Bash completion for subversion.
@@ -444,6 +453,7 @@ chmod +x ./autogen.sh && ./autogen.sh
        --disable-mod-activation \
 %if %{with db}
        --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
+       %{?with_db6:--enable-bdb6} \
 %else
        --without-berkeley-db \
 %endif
@@ -559,12 +569,14 @@ install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
 
 %if %{with ruby}
 %{__make} install -j1 \
+       SWIG_RB_RI_DATADIR=$RPM_BUILD_ROOT%{ruby_ridir} \
        DESTDIR=$RPM_BUILD_ROOT \
-       install-swig-rb install-swig-rb-doc \
+       install-swig-rb install-swig-rb-doc
 
 # not our package
 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/OptionParser
 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Time
+%{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/File
 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
 %endif
This page took 0.03393 seconds and 4 git commands to generate.