]> git.pld-linux.org Git - packages/setup.git/blobdiff - setup.spec
- let's keep obsoletes in one place, basesystem is imo better for that
[packages/setup.git] / setup.spec
index e475664595bdd16e24a60836ce078d219b024bf3..a8a5ea433af6f5ead0be7c34efaf5c99f57cebbd 100644 (file)
@@ -1,6 +1,12 @@
+#
 # TODO:
 # - make some README.PLD with system features description
-# - use joinpasswd in post
+#
+# Conditional build:
+%bcond_with    ssp     # enable stack-smashing protector (vide dietlibc.spec)
+#
+%define        iana_etc_ver    1.04
+#
 Summary:       Simple setup files
 Summary(de):   Einfache Setup-Dateien
 Summary(es):   Varios archivos básicos de configuración
@@ -9,16 +15,22 @@ Summary(ja): 
 Summary(pl):   Podstawowe pliki systemu Linux
 Summary(pt_BR):        Vários arquivos básicos de configuração
 Summary(tr):   Basit kurulum dosyalarý
-Patch0:                setup-services-callbook2sieve.patch
 Name:          setup
-Version:       2.4.4
-Release:       1.2
+Version:       2.4.9
+Release:       2
 License:       Public Domain, partially BSD-like
 Group:         Base
-Source0:       http://piorun.ds.pg.gda.pl/~blues/SOURCES/%{name}-%{version}.tar.bz2
-# Source0-md5: 74484812aa2e01e5b2fa5c4e8276969a
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+Source0:       http://mieszkancy.ds.pg.gda.pl/~blues/SOURCES/%{name}-%{version}.tar.bz2
+# Source0-md5: aa99796a603e10343edbf0720edfd6ac
+Source1:       http://www.sethwklein.net/projects/iana-etc/downloads/iana-etc-%{iana_etc_ver}.tar.bz2
+# Source1-md5: 9f769f7b2d0e519cf62dacb2b3b051d4
+# This is source of non-iana changes in services file
+#Patch0:               %{name}-services.patch
+BuildRequires: dietlibc-static
+BuildRequires: gawk
+Conflicts:     FHS < 2.3
 AutoReqProv:   no
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sbindir        /sbin
 
@@ -57,24 +69,30 @@ Bu paket, passwd, group, profile gibi 
 dosyalarýný içerir.
 
 %prep
-%setup -q 
-%patch0 -p1
+%setup -q -a1
 
 %build
+%{__make} -C iana-etc-%{iana_etc_ver}
+
 %{__make} \
-       OPT_FLAGS="%{rpmcflags}" \
-       CC=%{__cc}
+       OPT_FLAGS="%{rpmcflags} %{?with_ssp:-fno-stack-protector}" \
+       CC="diet %{__cc}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_sysconfdir}/shrc.d
+
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+install iana-etc-%{iana_etc_ver}/protocols $RPM_BUILD_ROOT/etc/protocols
+# don't overwrite files from setup tar-ball, fix it in original tar!
+#install iana-etc-%{iana_etc_ver}/services $RPM_BUILD_ROOT/etc/services
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%triggerpostun -- %{name} < %{version}-%{release}
-%{_sbindir}/joinpasswd
+%triggerpostun -p %{_sbindir}/joinpasswd -- %{name} < %{version}-%{release}
 
 %files
 %defattr(644,root,root,755)
@@ -83,6 +101,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) /etc/profile.d/*.sh
 %attr(755,root,root) /etc/profile.d/*.csh
 %dir /etc/profile.d
+%attr(644,root,root) %config(noreplace,missingok) %verify(not md5 size mtime) %{_sysconfdir}/env.d/*
+%dir %{_sysconfdir}/env.d
+%dir %{_sysconfdir}/shrc.d
 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/fstab
 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/group
 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/host.conf
This page took 0.03849 seconds and 4 git commands to generate.