]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- fix
[packages/rpm.git] / rpm.spec
index df9b1089e9dfc0ee31e4e224dacbe7b1e476e45a..f573719b801cfb90089a536dc799890a56351499 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -8,11 +8,6 @@
 #          i386 i386
 # - python(abi) cap is not provided automatically because /usr/lib*/libpython2*.so.*
 #   matches ELF first
-# - repackaging when lzma is not installed (todo: fix digest signature of header)
-#   rpmbuild computes digest when writing package to temporary file, then adds a few
-#   tags (incl. digest) and writes whole package to destination file;
-#   repackaging uses unchanged "immutable header" image from original rpm, also
-#   preserving payload format and compressor from original rpm, _not_ current settings
 # - TODO: add macros for some ppc, mipsel, alpha and sparc
 # - uppackaged list:
 #   /usr/lib/rpm/http.req
@@ -64,7 +59,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       5.1.4
-Release:       0.3
+Release:       0.6
 License:       LGPL
 Group:         Base
 Source0:       http://rpm5.org/files/rpm/rpm-5.1/%{name}-%{version}.tar.gz
@@ -121,6 +116,7 @@ Patch14:    %{name}-etc_dir.patch
 Patch16:       %{name}-php-deps.patch
 Patch17:       %{name}-macros.patch
 Patch18:       %{name}-macros-th.patch
+Patch19:       %{name}-glob.patch
 
 Patch23:       %{name}-pkgconfigdeps.patch
 
@@ -142,7 +138,6 @@ Patch52:    %{name}-morearchs.patch
 
 Patch55:       %{name}-truncate-cvslog.patch
 
-Patch58:       %{name}-repackage-wo-lzma.patch
 Patch59:       %{name}-libtool-deps.patch
 Patch60:       %{name}-mimetype.patch
 Patch61:       %{name}-sparc64.patch
@@ -155,6 +150,7 @@ BuildRequires:      bzip2-devel >= 1.0.2-17
 BuildRequires: elfutils-devel >= 0.108
 BuildRequires: gettext-autopoint >= 0.11.4-2
 BuildRequires: gettext-devel >= 0.11.4-2
+BuildRequires: lzma-devel >= 4.999.3
 BuildRequires: libmagic-devel
 %{?with_selinux:BuildRequires: libselinux-devel >= 1.18}
 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
@@ -201,6 +197,8 @@ Obsoletes:  rpm-getdeps
 Conflicts:     glibc < 2.2.92
 # db4.6 poldek needed
 Conflicts:     poldek < 0.21-0.20070703.00.3
+# segfaults with lzma 0.42.2
+Conflicts:     lzma-libs < 4.999.3
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _binary_payload         w9.gzdio
@@ -302,7 +300,6 @@ Requires:   beecrypt >= %{beecrypt_ver}
 Requires:      libmagic >= 1.15-2
 %{?with_selinux:Requires:      libselinux >= 1.18}
 Requires:      popt >= %{reqpopt_ver}
-%{?with_suggest_tags:Suggests: lzma}
 Obsoletes:     rpm-libs
 # avoid SEGV caused by mixed db versions
 Conflicts:     poldek < 0.18.1-16
@@ -426,7 +423,6 @@ Requires:   popt >= %{reqpopt_ver}
 %if %{with suggest_tags}
 Suggests:      bzip2
 Suggests:      gzip
-Suggests:      lzma
 %endif
 Conflicts:     filesystem-debuginfo < 3.0-16
 
@@ -504,7 +500,6 @@ Requires:   gcc
 Requires:      glibc-devel
 Requires:      grep
 Requires:      gzip
-Requires:      lzma
 Requires:      make
 Requires:      patch
 Requires:      sed
@@ -698,10 +693,10 @@ install %{SOURCE12} scripts/perl.prov
 # OLD COMMENTED OUT
 #%%patch52 -p1 -- morearchs (rpmrc patch) adds ppc7400, ppc7400
 %patch55 -p1
-%patch58 -p1
 %patch59 -p1
 %patch17 -p1
 %patch18 -p1
+%patch19 -p1
 %patch60 -p1
 %ifarch sparc64
 %patch61 -p1
@@ -733,7 +728,7 @@ awk -f %{SOURCE6} %{SOURCE1}
 # rpm checks for CPU type at runtime, but it looks better
 #sed -i -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' -e 's|@host_cpu@|%{_target_cpu}|' macros.in
 
-%{?with_system_lua:CPPFLAGS=-I/usr/include/lua51}
+%{?with_system_lua:CPPFLAGS="-I/usr/include/lua51 %{rpmcppflags}"}
 # pass CC and CXX too in case of building with some older configure macro
 %configure \
        CC="%{__newcc}" \
@@ -751,6 +746,7 @@ awk -f %{SOURCE6} %{SOURCE1}
        --with-zlib=external \
        --with-bzip2=external \
        --with-beecrypt=external \
+       --with-lzma=external \
        --with-neon=%{?with_neon:external}%{!?with_neon:no} \
        --with-file=external \
        --with-popt=external \
This page took 0.033317 seconds and 4 git commands to generate.