]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
This commit was manufactured by cvs2git to create tag 'auto-ac-rpm-
[packages/rpm.git] / rpm.spec
index d903870c838944c930029e30724fdb7b29e85a45..a246d1ccc30a0d2f35cef003d9fd0cdbe5a94dff 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -6,20 +6,21 @@
 # Conditional build:
 %bcond_with    static          # build static rpmi (not supported at the moment)
 %bcond_without apidocs         # don't generate documentation with doxygen
-%bcond_with    autoreqdep      # autogenerate package name deps in addition to sonames/perl(X)
+%bcond_without autoreqdep      # don't autogenerate package name deps in addition to sonames/perl(X)
 %bcond_without python          # don't build python bindings
 %bcond_without selinux         # build without selinux support
-%bcond_without system_libmagic # don't use system libmagic
+%bcond_without system_libmagic # don't use system libmagic
 %bcond_with    neon            # build with HTTP/WebDAV support (neon library)
+
 # force_cc             - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
 # force_cxx            - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
 # force_cpp            - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
 
 # versions of required libraries
-%define        reqdb_ver       4.3.27-1
+%define        reqdb_ver       4.2.52-10
 %define        reqpopt_ver     1.10.2
 %define        beecrypt_ver    2:4.1.2-4
-%define        rpm_macros_rev  1.238
+%define        rpm_macros_rev  1.239
 Summary:       RPM Package Manager
 Summary(de):   RPM Packet-Manager
 Summary(es):   Gestor de paquetes RPM
@@ -30,7 +31,7 @@ Summary(uk):  
 Name:          rpm
 %define        sover   4.4
 Version:       4.4.2
-Release:       4
+Release:       10
 License:       GPL
 Group:         Base
 Source0:       ftp://jbj.org/pub/rpm-4.4.x/%{name}-%{version}.tar.gz
@@ -73,7 +74,6 @@ Patch15:      %{name}-system_libs-more.patch
 Patch16:       %{name}-php-deps.patch
 Patch17:       %{name}-ldconfig-always.patch
 Patch18:       %{name}-perl_req.patch
-
 Patch20:       %{name}-magic-usesystem.patch
 Patch21:       %{name}-dontneedutils.patch
 Patch22:       %{name}-provides-dont-obsolete.patch
@@ -96,7 +96,7 @@ Patch37:      %{name}-doxygen_hack.patch
 Patch39:       %{name}-pythondeps.patch
 Patch40:       %{name}-print-requires.patch
 Patch41:       %{name}-reduce-stack-usage.patch
-Patch42:       %{name}-glob.patch
+Patch42:       %{name}-amd64.patch
 Patch43:       %{name}-patch-quote.patch
 Patch44:       %{name}-no-neon.patch
 Patch45:       %{name}-no-sqlite.patch
@@ -113,7 +113,7 @@ BuildRequires:      db-devel >= %{reqdb_ver}
 BuildRequires: elfutils-devel >= 0.108
 BuildRequires: findutils
 BuildRequires: gettext-devel >= 0.11.4-2
-%{?with_system_libmagic:BuildRequires: libmagic-devel}
+%{?with_system_libmagic:BuildRequires: libmagic-devel}
 %{?with_selinux:BuildRequires: libselinux-devel >= 1.18}
 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
 BuildRequires: libstdc++-devel
@@ -128,6 +128,7 @@ BuildRequires:      popt-devel >= %{reqpopt_ver}
 BuildRequires: python-modules >= 1:2.3
 BuildRequires: readline-devel
 BuildRequires: rpm-perlprov
+BuildRequires: rpm-pythonprov
 BuildRequires: zlib-devel
 %if %{with static}
 # Require static library only for static build
@@ -136,7 +137,7 @@ BuildRequires:      bzip2-static >= 1.0.2-17
 BuildRequires: db-static >= %{reqdb_ver}
 BuildRequires: glibc-static >= 2.2.94
 BuildRequires: elfutils-static
-%{with_system_libmagic:BuildRequires:  libmagic-static}
+%{with_system_libmagic:BuildRequires:  libmagic-static}
 %{?with_selinux:BuildRequires: libselinux-static >= 1.18}
 BuildRequires: popt-static >= %{reqpopt_ver}
 BuildRequires: zlib-static
@@ -159,9 +160,9 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                x8664   amd64 ia32e x86_64
 
 # stabilize new build environment
-%define                __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
-%define                __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
-%define                __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
+%define                __cc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
+%define                __cxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
+%define                __cpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
 
 %define                _rpmlibdir /usr/lib/rpm
 
@@ -221,7 +222,7 @@ Group:              Libraries
 Requires:      beecrypt >= %{beecrypt_ver}
 Requires:      db >= %{reqdb_ver}
 %{?with_selinux:Requires:      libselinux >= 1.18}
-%{?with_system_libmagic:Requires:      libmagic >= 1.15-2}
+%{?with_system_libmagic:Requires:      libmagic >= 1.15-2}
 Requires:      popt >= %{reqpopt_ver}
 Obsoletes:     rpm-libs
 # avoid SEGV caused by mixed db versions
@@ -248,7 +249,7 @@ Requires:   bzip2-devel
 Requires:      db-devel >= %{reqdb_ver}
 Requires:      elfutils-devel
 %{?with_selinux:Requires:      libselinux-devel}
-%{?with_system_libmagic:Requires:       libmagic-devel}
+%{?with_system_libmagic:Requires:      libmagic-devel}
 Requires:      popt-devel >= %{reqpopt_ver}
 Requires:      zlib-devel
 
@@ -310,7 +311,7 @@ Requires:   beecrypt-static >= %{beecrypt_ver}
 Requires:      bzip2-static
 Requires:      db-static >= %{reqdb_ver}
 Requires:      elfutils-static
-%{?with_system_libmagic:Requires:       libmagic-static}
+%{?with_system_libmagic:Requires:      libmagic-static}
 Requires:      popt-static >= %{reqpopt_ver}
 Requires:      zlib-static
 
@@ -410,7 +411,11 @@ Requires:  elfutils
 Requires:      file >= 4.14-1
 Requires:      fileutils
 Requires:      findutils
-Requires:      gcc >= 5:3.4
+%ifarch athlon
+Requires:      gcc >= 3.0.3
+%else
+Requires:      gcc
+%endif
 Requires:      glibc-devel
 Requires:      grep
 Requires:      gzip
@@ -694,9 +699,9 @@ CPPFLAGS="-Dglob=rpm_glob -Dglobfree=rpm_globfree"; export CPPFLAGS
 
 # pass CC and CXX too in case of building with some older configure macro
 %configure \
-       CC="%{__newcc}" \
-       CXX="%{__newcxx}" \
-       CPP="%{__newcpp}" \
+       CC="%{__cc}" \
+       CXX="%{__cxx}" \
+       CPP="%{__cpp}" \
        %{?with_autoreqdep:--enable-adding-packages-names-in-autogenerated-dependancies} \
        --enable-shared \
        --enable-static \
@@ -704,14 +709,10 @@ CPPFLAGS="-Dglob=rpm_glob -Dglobfree=rpm_globfree"; export CPPFLAGS
        %{?with_python:--with-python=auto} \
        %{!?with_python:--without-python} \
        %{!?with_selinux:--without-selinux} \
-       --with-glob \
        --without-db
 
 # file_LDFLAGS, debugedit_LDADD - no need to link "file" and "debugedit" statically
 %{__make} \
-       CC="%{__cc}" \
-       CXX="%{__cxx}" \
-       CPP="%{__cpp}" \
        pylibdir=%{py_libdir} \
        myLDFLAGS="%{rpmldflags}" \
        file_LDFLAGS= \
@@ -1028,6 +1029,10 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %ifarch alpha
 %{_rpmlibdir}/alpha*
 %endif
+%ifarch amd64
+%{_rpmlibdir}/amd64*
+%{_rpmlibdir}/x86_64*
+%endif
 %ifarch ia64
 %{_rpmlibdir}/ia64*
 %endif
@@ -1040,9 +1045,6 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %ifarch sparc sparc64
 %{_rpmlibdir}/sparc*
 %endif
-%ifarch %{x8664}
-%{_rpmlibdir}/x86_64*
-%endif
 # must be here for "Requires: rpm-*prov" to work
 %{_rpmlibdir}/macros.mono
 %{_rpmlibdir}/macros.perl
This page took 0.070387 seconds and 4 git commands to generate.