]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
This commit was manufactured by cvs2git to create tag 'auto-ac-rpm-
[packages/rpm.git] / rpm.spec
index 81e9032cbd39e5fe01078ad90ef9ebc408c2e073..a246d1ccc30a0d2f35cef003d9fd0cdbe5a94dff 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -2,27 +2,25 @@
 # TODO:
 # - python(abi) cap is not provided automatically (because /usr/bin/python matches
 #   ELF first; it should be provided by python-libs not binary anyway)
-# - consider using system libmagic not internal libfmagic
-#   (but internal has different method of passing output)
 # 
 # Conditional build:
 %bcond_with    static          # build static rpmi (not supported at the moment)
 %bcond_without apidocs         # don't generate documentation with doxygen
-%bcond_with    autoreqdep      # autogenerate package name deps in addition to sonames/perl(X)
-%bcond_without home_etc        # build without HOME_ETC support
+%bcond_without autoreqdep      # don't autogenerate package name deps in addition to sonames/perl(X)
 %bcond_without python          # don't build python bindings
 %bcond_without selinux         # build without selinux support
-%bcond_without system_libmagic # don't use system libmagic
+%bcond_without system_libmagic # don't use system libmagic
 %bcond_with    neon            # build with HTTP/WebDAV support (neon library)
+
 # force_cc             - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
 # force_cxx            - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
 # force_cpp            - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
 
 # versions of required libraries
-%define        reqdb_ver       4.3.27-1
+%define        reqdb_ver       4.2.52-10
 %define        reqpopt_ver     1.10.2
 %define        beecrypt_ver    2:4.1.2-4
-%define        rpm_macros_rev  1.236
+%define        rpm_macros_rev  1.239
 Summary:       RPM Package Manager
 Summary(de):   RPM Packet-Manager
 Summary(es):   Gestor de paquetes RPM
@@ -33,7 +31,7 @@ Summary(uk):  
 Name:          rpm
 %define        sover   4.4
 Version:       4.4.2
-Release:       2
+Release:       10
 License:       GPL
 Group:         Base
 Source0:       ftp://jbj.org/pub/rpm-4.4.x/%{name}-%{version}.tar.gz
@@ -76,7 +74,6 @@ Patch15:      %{name}-system_libs-more.patch
 Patch16:       %{name}-php-deps.patch
 Patch17:       %{name}-ldconfig-always.patch
 Patch18:       %{name}-perl_req.patch
-
 Patch20:       %{name}-magic-usesystem.patch
 Patch21:       %{name}-dontneedutils.patch
 Patch22:       %{name}-provides-dont-obsolete.patch
@@ -99,7 +96,7 @@ Patch37:      %{name}-doxygen_hack.patch
 Patch39:       %{name}-pythondeps.patch
 Patch40:       %{name}-print-requires.patch
 Patch41:       %{name}-reduce-stack-usage.patch
-Patch42:       %{name}-glob.patch
+Patch42:       %{name}-amd64.patch
 Patch43:       %{name}-patch-quote.patch
 Patch44:       %{name}-no-neon.patch
 Patch45:       %{name}-no-sqlite.patch
@@ -116,8 +113,7 @@ BuildRequires:      db-devel >= %{reqdb_ver}
 BuildRequires: elfutils-devel >= 0.108
 BuildRequires: findutils
 BuildRequires: gettext-devel >= 0.11.4-2
-%{?with_home_etc:BuildRequires:        home-etc-devel >= 1:1.0.9-2}
-%{?with_system_libmagic:BuildRequires: libmagic-devel}
+%{?with_system_libmagic:BuildRequires: libmagic-devel}
 %{?with_selinux:BuildRequires: libselinux-devel >= 1.18}
 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
 BuildRequires: libstdc++-devel
@@ -132,6 +128,7 @@ BuildRequires:      popt-devel >= %{reqpopt_ver}
 BuildRequires: python-modules >= 1:2.3
 BuildRequires: readline-devel
 BuildRequires: rpm-perlprov
+BuildRequires: rpm-pythonprov
 BuildRequires: zlib-devel
 %if %{with static}
 # Require static library only for static build
@@ -140,7 +137,7 @@ BuildRequires:      bzip2-static >= 1.0.2-17
 BuildRequires: db-static >= %{reqdb_ver}
 BuildRequires: glibc-static >= 2.2.94
 BuildRequires: elfutils-static
-%{with_system_libmagic:BuildRequires:  libmagic-static}
+%{with_system_libmagic:BuildRequires:  libmagic-static}
 %{?with_selinux:BuildRequires: libselinux-static >= 1.18}
 BuildRequires: popt-static >= %{reqpopt_ver}
 BuildRequires: zlib-static
@@ -163,9 +160,9 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                x8664   amd64 ia32e x86_64
 
 # stabilize new build environment
-%define                __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
-%define                __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
-%define                __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
+%define                __cc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
+%define                __cxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
+%define                __cpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
 
 %define                _rpmlibdir /usr/lib/rpm
 
@@ -225,15 +222,11 @@ Group:            Libraries
 Requires:      beecrypt >= %{beecrypt_ver}
 Requires:      db >= %{reqdb_ver}
 %{?with_selinux:Requires:      libselinux >= 1.18}
-%{?with_system_libmagic:Requires:      libmagic >= 1.15-2}
+%{?with_system_libmagic:Requires:      libmagic >= 1.15-2}
 Requires:      popt >= %{reqpopt_ver}
 Obsoletes:     rpm-libs
 # avoid SEGV caused by mixed db versions
 Conflicts:     poldek < 0.18.1-16
-%if %{with home_etc}
-# avoid linking to /usr/lib
-Conflicts:     home-etc < 1.0.9-2
-%endif
 
 %description lib
 RPMs library.
@@ -255,9 +248,8 @@ Requires:   beecrypt-devel >= %{beecrypt_ver}
 Requires:      bzip2-devel
 Requires:      db-devel >= %{reqdb_ver}
 Requires:      elfutils-devel
-%{?with_home_etc:Requires:     home-etc-devel >= 1:1.0.9-2}
 %{?with_selinux:Requires:      libselinux-devel}
-%{?with_system_libmagic:Requires:       libmagic-devel}
+%{?with_system_libmagic:Requires:      libmagic-devel}
 Requires:      popt-devel >= %{reqpopt_ver}
 Requires:      zlib-devel
 
@@ -319,7 +311,7 @@ Requires:   beecrypt-static >= %{beecrypt_ver}
 Requires:      bzip2-static
 Requires:      db-static >= %{reqdb_ver}
 Requires:      elfutils-static
-%{?with_system_libmagic:Requires:       libmagic-static}
+%{?with_system_libmagic:Requires:      libmagic-static}
 Requires:      popt-static >= %{reqpopt_ver}
 Requires:      zlib-static
 
@@ -419,7 +411,11 @@ Requires:  elfutils
 Requires:      file >= 4.14-1
 Requires:      fileutils
 Requires:      findutils
-Requires:      gcc >= 5:3.4
+%ifarch athlon
+Requires:      gcc >= 3.0.3
+%else
+Requires:      gcc
+%endif
 Requires:      glibc-devel
 Requires:      grep
 Requires:      gzip
@@ -437,6 +433,7 @@ Provides:   rpmbuild(noauto) = 3
 Conflicts:     automake < 1:1.7.9-2
 Conflicts:     libtool < 2:1.5-13
 %endif
+Obsoletes:     rpmbuild(macros) < %{rpm_macros_rev}
 
 %description build
 Scripts for building binary RPM packages.
@@ -702,25 +699,20 @@ CPPFLAGS="-Dglob=rpm_glob -Dglobfree=rpm_globfree"; export CPPFLAGS
 
 # pass CC and CXX too in case of building with some older configure macro
 %configure \
-       CC="%{__newcc}" \
-       CXX="%{__newcxx}" \
-       CPP="%{__newcpp}" \
+       CC="%{__cc}" \
+       CXX="%{__cxx}" \
+       CPP="%{__cpp}" \
        %{?with_autoreqdep:--enable-adding-packages-names-in-autogenerated-dependancies} \
        --enable-shared \
        --enable-static \
        %{?with_apidocs:--with-apidocs} \
-       %{?with_home_etc:--with-home_etc} \
        %{?with_python:--with-python=auto} \
        %{!?with_python:--without-python} \
        %{!?with_selinux:--without-selinux} \
-       --with-glob \
        --without-db
 
 # file_LDFLAGS, debugedit_LDADD - no need to link "file" and "debugedit" statically
 %{__make} \
-       CC="%{__cc}" \
-       CXX="%{__cxx}" \
-       CPP="%{__cpp}" \
        pylibdir=%{py_libdir} \
        myLDFLAGS="%{rpmldflags}" \
        file_LDFLAGS= \
@@ -852,6 +844,8 @@ cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqdep <<EOF
 ^libpsres.so
 ^libxkbfile.so
 ^libxkbui.so
+# -- fam / gamin
+^libfam.so.0
 EOF
 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc <<EOF
 # global list of file masks not to be compressed in DOCDIR
@@ -867,6 +861,13 @@ for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so ; do
        ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
 done
 
+# remove arch dependant macros which have no use on noarch
+sed -i -e '
+/{__spec_install_post_strip}/d
+/{__spec_install_post_chrpath}/d
+/{__spec_install_post_compress_modules}/d
+' $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
+
 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
 
@@ -1028,6 +1029,10 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %ifarch alpha
 %{_rpmlibdir}/alpha*
 %endif
+%ifarch amd64
+%{_rpmlibdir}/amd64*
+%{_rpmlibdir}/x86_64*
+%endif
 %ifarch ia64
 %{_rpmlibdir}/ia64*
 %endif
@@ -1040,9 +1045,6 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %ifarch sparc sparc64
 %{_rpmlibdir}/sparc*
 %endif
-%ifarch %{x8664}
-%{_rpmlibdir}/x86_64*
-%endif
 # must be here for "Requires: rpm-*prov" to work
 %{_rpmlibdir}/macros.mono
 %{_rpmlibdir}/macros.perl
This page took 0.042994 seconds and 4 git commands to generate.