]> git.pld-linux.org Git - packages/qt4.git/blobdiff - qt4.spec
quick and ugly hack for infinite loop in QMap
[packages/qt4.git] / qt4.spec
index a6b1b751e2cb727c1e7f5420ef6eb9a9df8f1929..9b703a3d390e8d7fdc14949af14e89c4d21315e3 100644 (file)
--- a/qt4.spec
+++ b/qt4.spec
@@ -63,7 +63,7 @@ Summary(pl.UTF-8):    Biblioteka Qt do tworzenia GUI
 Summary(pt_BR.UTF-8):  Estrutura para rodar aplicações GUI Qt
 Name:          qt4
 Version:       4.8.7
-Release:       32
+Release:       34
 License:       LGPL v2.1 or GPL v3.0
 Group:         X11/Libraries
 Source0:       http://download.qt-project.org/official_releases/qt/4.8/%{version}/qt-everywhere-opensource-src-%{version}.tar.gz
@@ -133,6 +133,7 @@ Patch51:    gcc9.patch
 Patch52:       gcc9-qforeach.patch
 Patch53:       cxx11.patch
 Patch54:       gcc11.patch
+Patch55:       qmap_inf_loop.patch
 URL:           http://qt-project.org/
 %{?with_ibase:BuildRequires:   Firebird-devel}
 %{?with_openvg:BuildRequires:  Mesa-libOpenVG-devel}
@@ -179,7 +180,6 @@ BuildRequires:      xorg-lib-libXrender-devel
 BuildRequires: xorg-lib-libXtst-devel
 BuildRequires: xorg-lib-libXv-devel
 BuildRequires: zlib-devel
-%{?with_system_phonon:BuildConflicts:  gstreamer0.10-devel}
 Obsoletes:     qt-extensions
 Obsoletes:     qt-utils
 Conflicts:     kdelibs <= 8:3.2-0.030602.1
@@ -188,11 +188,7 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _noautoreqdep   libGL.so.1 libGLU.so.1
 %define                _noautostrip    '.*_debug\\.so*'
 
-%ifarch %{ix86}
-%define                specflags       -fno-strict-aliasing -O0
-%else
-%define                specflags       -fno-strict-aliasing
-%endif
+%define                specflags       -fno-strict-aliasing -Wno-deprecated
 
 %define                _qtdir          %{_libdir}/qt4
 
@@ -1579,6 +1575,7 @@ Programas exemplo para o Qt versão.
 %patch52 -p1
 %patch53 -p1
 %patch54 -p1
+%patch55 -p1
 
 %{__sed} -i -e 's,usr/X11R6/,usr/g,' mkspecs/linux-g++-64/qmake.conf \
        mkspecs/common/linux.conf
@@ -1609,6 +1606,9 @@ Programas exemplo para o Qt versão.
        s|^QMAKE_STRIP.*=.*|QMAKE_STRIP             =|;
        ' mkspecs/common/linux.conf
 
+# disable gstreamer-0.10 based multimedia
+%{__sed} -i -e 's/gstreamer-0.10/&-disabled/' src/3rdparty/webkit/Source/WebCore/features.pri
+
 # disable webkit tests, broken build
 %{__rm} -r src/3rdparty/webkit/Source/WebKit/qt/tests
 
This page took 0.031556 seconds and 4 git commands to generate.