]> git.pld-linux.org Git - packages/qt4.git/blobdiff - qt4.spec
quick and ugly hack for infinite loop in QMap
[packages/qt4.git] / qt4.spec
index 7a124bc0e4ac2ef149b324f0cf743c255000a714..9b703a3d390e8d7fdc14949af14e89c4d21315e3 100644 (file)
--- a/qt4.spec
+++ b/qt4.spec
 %bcond_with    sse42           # use SSE4.2 instructions (the same)
 %bcond_with    avx             # use AVX instructions (future Intel x86 CPUs only)
 
-%ifnarch %{ix86} %{x8664} sparc sparcv9 alpha ppc
+%ifnarch %{ix86} %{x8664} x32 sparc sparcv9 alpha ppc
 %undefine      with_ibase
 %endif
 %ifarch        athlon
 %define                with_3dnow      1
 %endif
-%ifarch athlon pentium3 pentium4 %{x8664}
+%ifarch athlon pentium3 pentium4 %{x8664} x32
 %define                with_mmx        1
 %endif
-%ifarch pentium3 pentium4 %{x8664}
+%ifarch pentium3 pentium4 %{x8664} x32
 %define                with_sse        1
 %endif
-%ifarch pentium4 %{x8664}
+%ifarch pentium4 %{x8664} x32
 %define                with_sse2       1
 %endif
 # any SQL
 %define                _withsql        1
 %{!?with_sqlite3:%{!?with_sqlite:%{!?with_ibase:%{!?with_mysql:%{!?with_pgsql:%{!?with_odbc:%{!?with_oci:%undefine _withsql}}}}}}}
 
-%define                icu_abi         64
+%define                icu_abi         69
 %define                next_icu_abi    %(echo $((%{icu_abi} + 1)))
 
 Summary:       The Qt GUI application framework
@@ -63,7 +63,7 @@ Summary(pl.UTF-8):    Biblioteka Qt do tworzenia GUI
 Summary(pt_BR.UTF-8):  Estrutura para rodar aplicações GUI Qt
 Name:          qt4
 Version:       4.8.7
-Release:       24
+Release:       34
 License:       LGPL v2.1 or GPL v3.0
 Group:         X11/Libraries
 Source0:       http://download.qt-project.org/official_releases/qt/4.8/%{version}/qt-everywhere-opensource-src-%{version}.tar.gz
@@ -132,6 +132,8 @@ Patch50:    mysql-link.patch
 Patch51:       gcc9.patch
 Patch52:       gcc9-qforeach.patch
 Patch53:       cxx11.patch
+Patch54:       gcc11.patch
+Patch55:       qmap_inf_loop.patch
 URL:           http://qt-project.org/
 %{?with_ibase:BuildRequires:   Firebird-devel}
 %{?with_openvg:BuildRequires:  Mesa-libOpenVG-devel}
@@ -145,7 +147,7 @@ BuildRequires:      freetds-devel
 BuildRequires: freetype-devel >= 2.1.3
 %{?with_pch:BuildRequires:     gcc >= 5:4.0}
 BuildRequires: glib2-devel >= 2.0.0
-BuildRequires: gstreamer0.10-plugins-base-devel
+%{!?with_system_phonon:BuildRequires:  gstreamer0.10-plugins-base-devel}
 %{?with_gtk:BuildRequires:     gtk+2-devel >= 2:2.10}
 # see dependency on libicu version below
 BuildRequires: libicu-devel >= %{icu_abi}
@@ -186,7 +188,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _noautoreqdep   libGL.so.1 libGLU.so.1
 %define                _noautostrip    '.*_debug\\.so*'
 
-%define                specflags       -fno-strict-aliasing
+%define                specflags       -fno-strict-aliasing -Wno-deprecated
 
 %define                _qtdir          %{_libdir}/qt4
 
@@ -1493,9 +1495,7 @@ Summary:  Qt Documentation in HTML format
 Summary(pl.UTF-8):     Dokumentacja Qt w formacie HTML
 Group:         X11/Development/Libraries
 Suggests:      %{name}-assistant = %{version}-%{release}
-%if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
-%endif
 
 %description doc
 Qt documentation in HTML format.
@@ -1573,7 +1573,9 @@ Programas exemplo para o Qt versão.
 %patch50 -p1
 %patch51 -p1
 %patch52 -p1
-#%patch53 -p1
+%patch53 -p1
+%patch54 -p1
+%patch55 -p1
 
 %{__sed} -i -e 's,usr/X11R6/,usr/g,' mkspecs/linux-g++-64/qmake.conf \
        mkspecs/common/linux.conf
@@ -1585,9 +1587,9 @@ Programas exemplo para o Qt versão.
        s|QMAKE_LINK.*=.*g++|QMAKE_LINK\t\t= %{__cxx}|;
        s|QMAKE_LINK_SHLIB.*=.*g++|QMAKE_LINK_SHLIB\t= %{__cxx}|;
        s|QMAKE_CFLAGS_RELEASE.*|QMAKE_CFLAGS_RELEASE\t+= %{rpmcppflags} %{rpmcflags}|;
-       s|QMAKE_CXXFLAGS_RELEASE.*|QMAKE_CXXFLAGS_RELEASE\t+= %{rpmcppflags} %{rpmcxxflags} -std=gnu++98|;
+       s|QMAKE_CXXFLAGS_RELEASE.*|QMAKE_CXXFLAGS_RELEASE\t+= %{rpmcppflags} %{rpmcxxflags}|;
        s|QMAKE_CFLAGS_DEBUG.*|QMAKE_CFLAGS_DEBUG\t+= %{debugcflags}|;
-       s|QMAKE_CXXFLAGS_DEBUG.*|QMAKE_CXXFLAGS_DEBUG\t+= %{debugcflags} -std=gnu++98|;
+       s|QMAKE_CXXFLAGS_DEBUG.*|QMAKE_CXXFLAGS_DEBUG\t+= %{debugcflags}|;
        ' mkspecs/common/g++-base.conf
 
 %{__sed} -i -e '
@@ -1604,6 +1606,9 @@ Programas exemplo para o Qt versão.
        s|^QMAKE_STRIP.*=.*|QMAKE_STRIP             =|;
        ' mkspecs/common/linux.conf
 
+# disable gstreamer-0.10 based multimedia
+%{__sed} -i -e 's/gstreamer-0.10/&-disabled/' src/3rdparty/webkit/Source/WebCore/features.pri
+
 # disable webkit tests, broken build
 %{__rm} -r src/3rdparty/webkit/Source/WebKit/qt/tests
 
@@ -1647,6 +1652,7 @@ COMMONOPT=" \
        %{!?with_sse41:-no-sse4.1} \
        %{!?with_sse42:-no-sse4.2} \
        %{!?with_avx:-no-avx} \
+       %{?with_system_phonon:-no-phonon} \
        -qdbus \
        -dbus-linked \
        -reduce-relocations \
@@ -1748,9 +1754,6 @@ echo '#QT_GRAPHICSSYSTEM=raster' > $RPM_BUILD_ROOT/etc/env.d/QT_GRAPHICSSYSTEM
 %{__make} install \
        INSTALL_ROOT=$RPM_BUILD_ROOT
 
-# this is only needed to build the library itself and breaks other build that use it
-%{__sed} -i -e 's|-std=gnu++98||g' $RPM_BUILD_ROOT%{_datadir}/qt4/mkspecs/common/g++-base.conf
-
 # for qt-creator sth is messed up in the Makefile, nothing for make install
 install bin/qdoc3 $RPM_BUILD_ROOT%{_qtdir}/bin/qdoc3
 
@@ -1763,7 +1766,7 @@ install bin/qdoc3 $RPM_BUILD_ROOT%{_qtdir}/bin/qdoc3
        ' $RPM_BUILD_ROOT%{_pkgconfigdir}/*.pc
 
 # kill -std=XYZ, so qmake won't pass it over to other projects
-%{__sed} -i -e 's#^\(.*\) -std=[a-z0-9\+]\+ \(.*\)#\1 \2#g' $RPM_BUILD_ROOT%{_datadir}/qt4/mkspecs/common/g++-base.conf
+#%{__sed} -i -e s#^\(.*\) -std=[a-z0-9+]\+\( .*\|$\)#\1 \2#g' $RPM_BUILD_ROOT%{_datadir}/qt4/mkspecs/common/g++-base.conf
 
 # libQtWebKit.la contains '-ljscore' and '-lwebcore', they come
 # from src/3rdparty/webkit/{JavaScriptCore,WebCore}} but those libs aren't installed
@@ -1952,7 +1955,7 @@ mkdevfl QtCLucene
 mkdevfl QtXml
 mkdevfl QtXmlPatterns
 mkdevfl Qt3Support
-mkdevfl phonon
+%{!?with_system_phonon:mkdevfl phonon}
 
 # without *.la *.pc etc.
 mkdevfl QtDesigner || /bin/true
@@ -1978,17 +1981,6 @@ for f in `find $RPM_BUILD_ROOT%{_examplesdir}/qt4-demos -printf "%%P "`; do
        ifecho demos %{_examplesdir}/qt4-demos/$f
 done
 
-%if %{with system_phonon}
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/libphonon.so* \
-       $RPM_BUILD_ROOT%{_libdir}/libphonon.{la,prl} \
-       $RPM_BUILD_ROOT%{_libdir}/qt4/plugins/phonon_backend/libphonon_gstreamer.so \
-       $RPM_BUILD_ROOT%{_pkgconfigdir}/phonon.pc
-%{__rm} -r $RPM_BUILD_ROOT%{_includedir}/qt4/phonon
-%if %{with static_libs}
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/libphonon.a
-%endif
-%endif
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
This page took 0.121134 seconds and 4 git commands to generate.