]> git.pld-linux.org Git - packages/qt4.git/blobdiff - qt4.spec
quick and ugly hack for infinite loop in QMap
[packages/qt4.git] / qt4.spec
index 63d59e3e70410da3fbd97832247613e9df6a08a9..9b703a3d390e8d7fdc14949af14e89c4d21315e3 100644 (file)
--- a/qt4.spec
+++ b/qt4.spec
@@ -1,22 +1,30 @@
 #
 # TODO:
+#      - fix moc failures, see e.g. https://bugzilla.redhat.com/show_bug.cgi?id=1396755
+#        at least add some macros to QTBUG-22829 patch (BOOST_PREDEF_VERSION_NUMBER_H, _SYS_SYSMACROS_H_OUTER...)
 #      - more cleanups
 #      - check if translations are available
 #      - check Qt ui tool
 #
 # Conditional build:
-%bcond_with    nas             # enable NAS audio support
 %bcond_without static_libs     # don't build static libraries
-%bcond_without cups            # disable CUPS support
-%bcond_without mysql           # don't build MySQL plugin
-%bcond_without odbc            # don't build unixODBC plugin
-%bcond_without pgsql           # don't build PostgreSQL plugin
-%bcond_without sqlite3         # don't build SQLite3 plugin
-%bcond_without sqlite          # don't build SQLite2 plugin
-%bcond_without ibase           # don't build ibase (InterBase/Firebird) plugin
-%bcond_without pch             # disable pch in qmake
-%bcond_without gtk             # don't build GTK theme integration
-%bcond_without system_phonon   # don't build phonon libraries
+# -- features
+%bcond_without cups            # CUPS printing support
+%bcond_with    nas             # NAS audio support
+%bcond_without gtk             # GTK+ theme integration
+%bcond_without pch             # pch (pre-compiled headers) in qmake
+%bcond_without system_phonon   # phonon libraries from phonon.spec intead of qt4.spec
+%bcond_with    wkhtml          # WKHTMLTOPDF patch (affects QtGui ABI)
+%bcond_with    openvg          # OpenVG support
+# -- databases
+%bcond_without ibase           # ibase (InterBase/Firebird) plugin
+%bcond_without mysql           # MySQL plugin
+%bcond_with    oci             # OCI (Oracle) support
+%bcond_without odbc            # unixODBC plugin
+%bcond_without pgsql           # PostgreSQL plugin
+%bcond_without sqlite3         # SQLite3 plugin
+%bcond_without sqlite          # SQLite2 plugin
+# -- SIMD CPU instructions
 %bcond_with    mmx             # use MMX instructions
 %bcond_with    3dnow           # use 3Dnow instructions
 %bcond_with    sse             # use SSE instructions in gui/painting module
 %bcond_with    sse41           # use SSE4.1 instructions (Intel since middle Core2)
 %bcond_with    sse42           # use SSE4.2 instructions (the same)
 %bcond_with    avx             # use AVX instructions (future Intel x86 CPUs only)
-#
-%ifnarch %{ix86} %{x8664} sparc sparcv9 alpha ppc
+
+%ifnarch %{ix86} %{x8664} x32 sparc sparcv9 alpha ppc
 %undefine      with_ibase
 %endif
 %ifarch        athlon
 %define                with_3dnow      1
 %endif
-%ifarch athlon pentium3 pentium4 %{x8664}
+%ifarch athlon pentium3 pentium4 %{x8664} x32
 %define                with_mmx        1
 %endif
-%ifarch pentium3 pentium4 %{x8664}
+%ifarch pentium3 pentium4 %{x8664} x32
 %define                with_sse        1
 %endif
-%ifarch pentium4 %{x8664}
+%ifarch pentium4 %{x8664} x32
 %define                with_sse2       1
 %endif
 # any SQL
 %define                _withsql        1
-%{!?with_sqlite3:%{!?with_sqlite:%{!?with_ibase:%{!?with_mysql:%{!?with_pgsql:%{!?with_odbc:%undefine _withsql}}}}}}
-#
+%{!?with_sqlite3:%{!?with_sqlite:%{!?with_ibase:%{!?with_mysql:%{!?with_pgsql:%{!?with_odbc:%{!?with_oci:%undefine _withsql}}}}}}}
+
+%define                icu_abi         69
+%define                next_icu_abi    %(echo $((%{icu_abi} + 1)))
+
 Summary:       The Qt GUI application framework
 Summary(es.UTF-8):     Biblioteca para ejecutar aplicaciones GUI Qt
 Summary(pl.UTF-8):     Biblioteka Qt do tworzenia GUI
 Summary(pt_BR.UTF-8):  Estrutura para rodar aplicações GUI Qt
 Name:          qt4
-Version:       4.8.4
-Release:       1
+Version:       4.8.7
+Release:       34
 License:       LGPL v2.1 or GPL v3.0
 Group:         X11/Libraries
-Source0:       http://releases.qt-project.org/qt4/source/qt-everywhere-opensource-src-%{version}.tar.gz
-# Source0-md5: 89c5ecba180cae74c66260ac732dc5cb
+Source0:       http://download.qt-project.org/official_releases/qt/4.8/%{version}/qt-everywhere-opensource-src-%{version}.tar.gz
+# Source0-md5: d990ee66bf7ab0c785589776f35ba6ad
 Source2:       %{name}-qtconfig.desktop
 Source3:       %{name}-designer.desktop
 Source4:       %{name}-assistant.desktop
@@ -77,40 +88,83 @@ Patch7:             %{name}-x11_fonts.patch
 Patch8:                %{name}-ibase.patch
 Patch9:                qt-x11-opensource-src-4.5.1-enable_ft_lcdfilter.patch
 Patch10:       webkit-no_Werror.patch
-Patch11:       moc-boost148.patch
-Patch12:       fix-crash-in-assistant.patch
-Patch13:       improve-cups-support.patch
-
+Patch11:       %{name}-wkhtml.patch
+Patch12:       openssl.patch
+Patch13:       qt-asm-volatile.patch
+Patch14:       x32.patch
+# backported from Qt5 (essentially)
+# http://bugzilla.redhat.com/702493
+# https://bugreports.qt-project.org/browse/QTBUG-5545
+Patch15:       qt-everywhere-opensource-src-4.8.4-qgtkstyle_disable_gtk_theme_check.patch
 Patch16:       qt-everywhere-opensource-src-4.8.3-QTBUG-4862.patch
-URL:           http://qt.nokia.com/
+Patch17:       %{name}-oracle-instantclient.patch
+# from Debian
+Patch18:       add-lxde-support.patch
+Patch19:       Better-handling-of-invalid-font-tables.patch
+Patch20:       xmlpatterns_stack_overflow_fix.diff
+Patch21:       no_libicu_message.diff
+Patch22:       add-mate-support.patch
+
+# from FC
+Patch28:       qt-x11-opensource-src-4.5.0-fix-qatomic-inline-asm.patch
+Patch29:       qt-everywhere-opensource-src-4.8.6-QTBUG-38585.patch
+Patch30:       qt-everywhere-opensource-src-4.8.6-QTBUG-37380.patch
+Patch31:       qt-everywhere-opensource-src-4.8.6-QTBUG-34614.patch
+Patch32:       qt-everywhere-opensource-src-4.8.5-QTBUG-35459.patch
+Patch33:       qt-everywhere-opensource-src-4.8.5-QTBUG-4862.patch
+Patch34:       qt-everywhere-opensource-src-4.8.5-QTBUG-21900.patch
+Patch35:       qt-4.8-poll.patch
+Patch36:       qt-cupsEnumDests.patch
+Patch37:       qt-everywhere-opensource-src-4.8.4-qmake_pkgconfig_requires_private.patch
+Patch38:       qt-everywhere-opensource-src-4.8.5-QTBUG-14467.patch
+Patch39:       qt-everywhere-opensource-src-4.8.5-tds_no_strict_aliasing.patch
+Patch40:       qt-everywhere-opensource-src-4.8.6-QTBUG-22829.patch
+Patch41:       qt-everywhere-opensource-src-4.8.7-alsa-1.1.patch
+Patch42:       qt-everywhere-opensource-src-4.8.7-gcc6.patch
+Patch43:       qt-everywhere-opensource-src-4.6.2-cups.patch
+Patch44:       qt-everywhere-opensource-src-4.8.0-tp-qtreeview-kpackagekit-crash.patch
+Patch45:       qt-everywhere-opensource-src-4.6.3-glib_eventloop_nullcheck.patch
+Patch46:       qt-everywhere-opensource-src-4.8.3-qdbusconnection_no_debug.patch
+Patch47:       qt-everywhere-opensource-src-4.8.2--assistant-crash.patch
+Patch48:       qt-everywhere-opensource-src-4.8.0-QTBUG-22037.patch
+Patch49:       icu59.patch
+Patch50:       mysql-link.patch
+Patch51:       gcc9.patch
+Patch52:       gcc9-qforeach.patch
+Patch53:       cxx11.patch
+Patch54:       gcc11.patch
+Patch55:       qmap_inf_loop.patch
+URL:           http://qt-project.org/
 %{?with_ibase:BuildRequires:   Firebird-devel}
-BuildRequires: Mesa-libOpenVG-devel
-BuildRequires: OpenGL-devel
+%{?with_openvg:BuildRequires:  Mesa-libOpenVG-devel}
 BuildRequires: OpenGL-GLU-devel
+BuildRequires: OpenGL-devel
 BuildRequires: alsa-lib-devel
 %{?with_cups:BuildRequires:    cups-devel}
 BuildRequires: dbus-devel >= 0.93
 BuildRequires: fontconfig-devel
 BuildRequires: freetds-devel
-BuildRequires: freetype-devel >= 1:2.0.0
+BuildRequires: freetype-devel >= 2.1.3
 %{?with_pch:BuildRequires:     gcc >= 5:4.0}
 BuildRequires: glib2-devel >= 2.0.0
-BuildRequires: gstreamer0.10-plugins-base-devel
+%{!?with_system_phonon:BuildRequires:  gstreamer0.10-plugins-base-devel}
 %{?with_gtk:BuildRequires:     gtk+2-devel >= 2:2.10}
 # see dependency on libicu version below
-BuildRequires: libicu-devel >= 49
-BuildRequires: libicu-devel < 50
+BuildRequires: libicu-devel >= %{icu_abi}
+BuildRequires: libicu-devel < %{next_icu_abi}
 BuildRequires: libjpeg-devel
 BuildRequires: libmng-devel >= 1.0.0
 BuildRequires: libpng-devel >= 2:1.0.8
 BuildRequires: libstdc++-devel
 %{?with_mysql:BuildRequires:   mysql-devel}
 %{?with_nas:BuildRequires:     nas-devel}
+%{?with_oci:BuildRequires:     oracle-instantclient-devel}
 BuildRequires: pkgconfig
 %{?with_pgsql:BuildRequires:   postgresql-backend-devel}
 %{?with_pgsql:BuildRequires:   postgresql-devel}
 BuildRequires: pulseaudio-devel >= 0.9.10
-BuildRequires: rpmbuild(macros) >= 1.602
+BuildRequires: rpmbuild(macros) >= 1.654
+BuildRequires: rsync
 BuildRequires: sed >= 4.0
 %{?with_sqlite:BuildRequires:  sqlite-devel}
 %{?with_sqlite3:BuildRequires: sqlite3-devel}
@@ -134,7 +188,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _noautoreqdep   libGL.so.1 libGLU.so.1
 %define                _noautostrip    '.*_debug\\.so*'
 
-%define                specflags       -fno-strict-aliasing
+%define                specflags       -fno-strict-aliasing -Wno-deprecated
 
 %define                _qtdir          %{_libdir}/qt4
 
@@ -257,13 +311,16 @@ biblioteka statyczna.
 Summary:       Qt core classes used by other modules
 Summary(pl.UTF-8):     Podstawowe klasy Qt używane przez inne moduły
 Group:         X11/Libraries
-%requires_eq   libicu
+%requires_eq_to        libicu libicu-devel
 # be sure to depend on proper arch.
-%ifarch %{ix86}
-Requires:      libicui18n.so.49
+%ifarch %{x8664} ppc64 sparc64 s390x
+Requires:      libicui18n.so.%{icu_abi}()(64bit)
+%else
+%ifarch x32
+Requires:      libicui18n.so.%{icu_abi}()(x32bit)
+%else
+Requires:      libicui18n.so.%{icu_abi}
 %endif
-%ifarch %{x8664}
-Requires:      libicui18n.so.49()(64bit)
 %endif
 Obsoletes:     QtAssistant
 
@@ -476,7 +533,7 @@ Group:              X11/Development/Libraries
 Requires:      QtCore-devel = %{version}-%{release}
 Requires:      QtGui = %{version}-%{release}
 Requires:      fontconfig-devel
-Requires:      freetype-devel >= 1:2.0.0
+Requires:      freetype-devel >= 2.1.3
 Requires:      libpng-devel >= 2:1.0.8
 Requires:      xorg-lib-libSM-devel
 Requires:      xorg-lib-libXcursor-devel
@@ -607,6 +664,7 @@ Requires:   QtCore = %{version}-%{release}
 # the rest for qnmbearer plugin
 Requires:      QtDBus = %{version}-%{release}
 Requires:      QtXml = %{version}-%{release}
+%requires_ge_to        openssl openssl-devel
 
 %description -n QtNetwork
 Qt classes for network programming.
@@ -881,6 +939,20 @@ danych MySQL poprzez klasy QSql.
 %description -n QtSql-mysql -l pt_BR.UTF-8
 Plugin de suporte a MySQL para Qt.
 
+%package -n QtSql-oci
+Summary:       Qt Sql driver for Oracle database (using OCI interface)
+Summary(pl.UTF-8):     Sterownik Qt Sql dla bazy danych Oracle (wykorzystujący interfejs OCI)
+Group:         Libraries
+Requires:      QtSql = %{version}-%{release}
+Provides:      QtSql-backend = %{version}-%{release}
+
+%description -n QtSql-oci
+Qt Sql driver for Oracle database (using OCI interface).
+
+%description -n QtSql-oci -l pl.UTF-8
+Sterownik Qt Sql dla bazy danych Oracle (wykorzystujący interfejs
+OCI).
+
 %package -n QtSql-odbc
 Summary:       Database plugin for ODBC Qt support
 Summary(pl.UTF-8):     Wtyczka ODBC do Qt
@@ -1288,6 +1360,17 @@ An advanced tool used for GUI designing with Qt library.
 Zaawansowane narzędzie służące do projektowania interfejsu graficznego
 za pomocą biblioteki Qt.
 
+%package devel-private
+Summary:       Private Qt headers files
+Group:         X11/Development/Libraries
+Requires:      QtCore-devel = %{version}-%{release}
+Requires:      QtDeclarative-devel = %{version}-%{release}
+Requires:      QtGui-devel = %{version}-%{release}
+Requires:      QtScript-devel = %{version}-%{release}
+
+%description devel-private
+Private Qt headers files - for calibre
+
 %package linguist
 Summary:       Translation helper for Qt
 Summary(pl.UTF-8):     Aplikacja ułatwiająca tłumaczenie aplikacji opartych o Qt
@@ -1412,6 +1495,7 @@ Summary:  Qt Documentation in HTML format
 Summary(pl.UTF-8):     Dokumentacja Qt w formacie HTML
 Group:         X11/Development/Libraries
 Suggests:      %{name}-assistant = %{version}-%{release}
+BuildArch:     noarch
 
 %description doc
 Qt documentation in HTML format.
@@ -1450,11 +1534,48 @@ Programas exemplo para o Qt versão.
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
-%patch11 -p1
+%{?with_wkhtml:%patch11 -p1}
 %patch12 -p1
 %patch13 -p1
-
+%patch14 -p1
+%patch15 -p1
 %patch16 -p1
+%patch17 -p1
+
+%patch18 -p1
+%patch19 -p1
+%patch20 -p1
+%patch21 -p1
+%patch22 -p1
+
+%patch28 -p1
+%patch29 -p0
+%patch30 -p1
+%patch31 -p0
+%patch32 -p1
+%patch33 -p1
+%patch34 -p1
+%patch35 -p1
+%patch36 -p1
+%patch37 -p1
+%patch38 -p1
+%patch39 -p1
+%patch40 -p1
+%patch41 -p1
+%patch42 -p1
+%patch43 -p1
+%patch44 -p1
+%patch45 -p1
+%patch46 -p1
+%patch47 -p1
+%patch48 -p1
+%patch49 -p1
+%patch50 -p1
+%patch51 -p1
+%patch52 -p1
+%patch53 -p1
+%patch54 -p1
+%patch55 -p1
 
 %{__sed} -i -e 's,usr/X11R6/,usr/g,' mkspecs/linux-g++-64/qmake.conf \
        mkspecs/common/linux.conf
@@ -1485,8 +1606,11 @@ Programas exemplo para o Qt versão.
        s|^QMAKE_STRIP.*=.*|QMAKE_STRIP             =|;
        ' mkspecs/common/linux.conf
 
+# disable gstreamer-0.10 based multimedia
+%{__sed} -i -e 's/gstreamer-0.10/&-disabled/' src/3rdparty/webkit/Source/WebCore/features.pri
+
 # disable webkit tests, broken build
-rm -r src/3rdparty/webkit/Source/WebKit/qt/tests
+%{__rm} -r src/3rdparty/webkit/Source/WebKit/qt/tests
 
 %build
 # pass OPTFLAGS to build qmake itself with optimization
@@ -1528,6 +1652,7 @@ COMMONOPT=" \
        %{!?with_sse41:-no-sse4.1} \
        %{!?with_sse42:-no-sse4.2} \
        %{!?with_avx:-no-avx} \
+       %{?with_system_phonon:-no-phonon} \
        -qdbus \
        -dbus-linked \
        -reduce-relocations \
@@ -1545,6 +1670,7 @@ COMMONOPT=" \
        %{?with_nas:-system-nas-sound} \
        %{?debug:-debug} \
        %{!?debug:-release} \
+       -%{!?with_openvg:no-}openvg \
        -qt3support \
        -fontconfig \
        -largefile \
@@ -1571,12 +1697,13 @@ COMMONOPT=" \
 
 %if %{with static_libs}
 OPT=" \
+       -%{!?with_ibase:no}%{?with_ibase:qt}-sql-ibase \
        -%{!?with_mysql:no}%{?with_mysql:qt}-sql-mysql \
        -%{!?with_odbc:no}%{?with_odbc:qt}-sql-odbc \
+       -%{!?with_oci:no}%{?with_oci:qt}-sql-oci \
        -%{!?with_pgsql:no}%{?with_pgsql:qt}-sql-psql \
        -%{!?with_sqlite3:no}%{?with_sqlite3:qt}-sql-sqlite \
        -%{!?with_sqlite:no}%{?with_sqlite:qt}-sql-sqlite2 \
-       -%{!?with_ibase:no}%{?with_ibase:qt}-sql-ibase \
        -static"
 
 ./configure $COMMONOPT $OPT
@@ -1596,12 +1723,13 @@ fi
 ##################################
 
 OPT=" \
+       -%{!?with_ibase:no}%{?with_ibase:plugin}-sql-ibase \
        -%{!?with_mysql:no}%{?with_mysql:plugin}-sql-mysql \
        -%{!?with_odbc:no}%{?with_odbc:plugin}-sql-odbc \
+       -%{!?with_oci:no}%{?with_oci:plugin}-sql-oci \
        -%{!?with_pgsql:no}%{?with_pgsql:plugin}-sql-psql \
        -%{!?with_sqlite3:no}%{?with_sqlite3:plugin}-sql-sqlite \
        -%{!?with_sqlite:no}%{?with_sqlite:plugin}-sql-sqlite2 \
-       -%{!?with_ibase:no}%{?with_ibase:plugin}-sql-ibase \
        -shared"
 
 ./configure $COMMONOPT $OPT
@@ -1614,8 +1742,12 @@ OPT=" \
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{/etc/env.d,%{_bindir},%{_desktopdir},%{_pixmapsdir},%{_pkgconfigdir}}
+install -d $RPM_BUILD_ROOT{/etc/{env.d,qt4},%{_bindir},%{_desktopdir},%{_pixmapsdir},%{_pkgconfigdir}}
 install -d $RPM_BUILD_ROOT%{_qtdir}/plugins/{crypto,network}
+install -d $RPM_BUILD_ROOT%{_qtdir}/imports/org
+
+# for QtSolutions (qtlockedfile, qtsingleapplication, etc)
+install -d $RPM_BUILD_ROOT%{_includedir}/qt4/QtSolutions
 
 echo '#QT_GRAPHICSSYSTEM=raster' > $RPM_BUILD_ROOT/etc/env.d/QT_GRAPHICSSYSTEM
 
@@ -1633,6 +1765,9 @@ install bin/qdoc3 $RPM_BUILD_ROOT%{_qtdir}/bin/qdoc3
        s|uic_location=.*|uic_location=%{_bindir}/uic-qt4|;
        ' $RPM_BUILD_ROOT%{_pkgconfigdir}/*.pc
 
+# kill -std=XYZ, so qmake won't pass it over to other projects
+#%{__sed} -i -e s#^\(.*\) -std=[a-z0-9+]\+\( .*\|$\)#\1 \2#g' $RPM_BUILD_ROOT%{_datadir}/qt4/mkspecs/common/g++-base.conf
+
 # libQtWebKit.la contains '-ljscore' and '-lwebcore', they come
 # from src/3rdparty/webkit/{JavaScriptCore,WebCore}} but those libs aren't installed
 %{__sed} -i -e "s,-lwebcore,,g;s,-ljscore,,g;" $RPM_BUILD_ROOT%{_libdir}/libQtWebKit.la
@@ -1669,7 +1804,7 @@ ln -sf ../%{_lib}/qt4/bin/xmlpatternsvalidator .
 cd -
 
 # multilib
-mv $RPM_BUILD_ROOT%{_qtdir}/bin/{qdbus,qdbusviewer} $RPM_BUILD_ROOT%{_bindir}
+%{__mv} $RPM_BUILD_ROOT%{_qtdir}/bin/{qdbus,qdbusviewer} $RPM_BUILD_ROOT%{_bindir}
 ln -sf %{_bindir}/qdbus $RPM_BUILD_ROOT%{_qtdir}/bin/qdbus
 ln -sf %{_bindir}/qdbusviewer $RPM_BUILD_ROOT%{_qtdir}/bin/qdbusviewer
 
@@ -1730,7 +1865,6 @@ done
 cd -
 
 # Ship doc & qmake stuff
-ln -s %{_docdir}/%{name}-doc $RPM_BUILD_ROOT%{_qtdir}/doc
 ln -s %{_datadir}/qt4/mkspecs $RPM_BUILD_ROOT%{_qtdir}/mkspecs
 
 for f in $RPM_BUILD_ROOT%{_pkgconfigdir}/*.pc; do
@@ -1749,6 +1883,20 @@ for f in $RPM_BUILD_ROOT%{_pkgconfigdir}/*.pc; do
        sed -i -e "s:-DQT_SHARED:-DQT_SHARED $DEFS:" $f
 done
 
+# Ship private headers - ugly hack to build calibre
+install -d $RPM_BUILD_ROOT%{_includedir}/qt4/private
+rsync -aR include/QtCore/private \
+         include/QtDeclarative/private \
+         include/QtGui/private \
+         include/QtScript/private \
+         $RPM_BUILD_ROOT%{_includedir}/qt4/private
+rsync -aR src/corelib/*/*_p.h \
+          src/declarative/*/*_p.h \
+          src/gui/*/*_p.h \
+          src/script/*/*_p.h \
+         $RPM_BUILD_ROOT%{_includedir}/qt4/private
+
+
 # Prepare some files list
 ifecho() {
        RESULT=`echo $RPM_BUILD_ROOT$2 2>/dev/null`
@@ -1795,7 +1943,7 @@ mkdevfl QtGui
 mkdevfl QtMultimedia
 mkdevfl QtNetwork
 mkdevfl QtOpenGL
-mkdevfl QtOpenVG
+%{?with_openvg:mkdevfl QtOpenVG}
 mkdevfl QtScript
 mkdevfl QtScriptTools
 mkdevfl QtSql
@@ -1807,7 +1955,7 @@ mkdevfl QtCLucene
 mkdevfl QtXml
 mkdevfl QtXmlPatterns
 mkdevfl Qt3Support
-mkdevfl phonon
+%{!?with_system_phonon:mkdevfl phonon}
 
 # without *.la *.pc etc.
 mkdevfl QtDesigner || /bin/true
@@ -1833,17 +1981,6 @@ for f in `find $RPM_BUILD_ROOT%{_examplesdir}/qt4-demos -printf "%%P "`; do
        ifecho demos %{_examplesdir}/qt4-demos/$f
 done
 
-%if %{with system_phonon}
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/libphonon.so* \
-       $RPM_BUILD_ROOT%{_libdir}/libphonon.{la,prl} \
-       $RPM_BUILD_ROOT%{_libdir}/qt4/plugins/phonon_backend/libphonon_gstreamer.so \
-       $RPM_BUILD_ROOT%{_pkgconfigdir}/phonon.pc
-%{__rm} -r $RPM_BUILD_ROOT%{_includedir}/qt4/phonon
-%if %{with static_libs}
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/libphonon.a
-%endif
-%endif
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -1943,6 +2080,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libQtCore.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libQtCore.so.4
+%dir /etc/qt4
 %dir %{_qtdir}
 %dir %{_qtdir}/bin
 %dir %{_qtdir}/plugins
@@ -1957,6 +2095,7 @@ rm -rf $RPM_BUILD_ROOT
 %lang(da) %{_localedir}/da/LC_MESSAGES/qt4.qm
 %lang(de) %{_localedir}/de/LC_MESSAGES/qt4.qm
 %lang(es) %{_localedir}/es/LC_MESSAGES/qt4.qm
+%lang(eu) %{_localedir}/eu/LC_MESSAGES/qt4.qm
 %lang(fa) %{_localedir}/fa/LC_MESSAGES/qt4.qm
 %lang(fr) %{_localedir}/fr/LC_MESSAGES/qt4.qm
 %lang(gl) %{_localedir}/gl/LC_MESSAGES/qt4.qm
@@ -2006,6 +2145,7 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_qtdir}/imports/QtWebKit
 %attr(755,root,root) %{_qtdir}/imports/QtWebKit/*.so
 %{_qtdir}/imports/QtWebKit/qmldir
+%dir %{_qtdir}/imports/org
 %dir %{_qtdir}/plugins/qmltooling
 %attr(755,root,root) %{_qtdir}/plugins/qmltooling/libqmldbg_tcp.so
 %attr(755,root,root) %{_qtdir}/plugins/qmltooling/libqmldbg_inspector.so
@@ -2050,6 +2190,7 @@ rm -rf $RPM_BUILD_ROOT
 %lang(cs) %{_localedir}/cs/LC_MESSAGES/qt4-qt_help.qm
 %lang(da) %{_localedir}/da/LC_MESSAGES/qt4-qt_help.qm
 %lang(de) %{_localedir}/de/LC_MESSAGES/qt4-qt_help.qm
+%lang(eu) %{_localedir}/eu/LC_MESSAGES/qt4-qt_help.qm
 %lang(fr) %{_localedir}/fr/LC_MESSAGES/qt4-qt_help.qm
 %lang(gl) %{_localedir}/gl/LC_MESSAGES/qt4-qt_help.qm
 %lang(hu) %{_localedir}/hu/LC_MESSAGES/qt4-qt_help.qm
@@ -2080,16 +2221,19 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %ghost %{_libdir}/libQtOpenGL.so.4
 %attr(755,root,root) %{_qtdir}/plugins/graphicssystems/libqglgraphicssystem.so
 
+%if %{with openvg}
 %files -n QtOpenVG
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libQtOpenVG.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libQtOpenVG.so.4
+%endif
 
 %files -n QtScript
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libQtScript.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libQtScript.so.4
 %dir %{_qtdir}/plugins/script
+%lang(eu) %{_localedir}/eu/LC_MESSAGES/qt4-qtscript.qm
 
 %files -n QtScriptTools
 %defattr(644,root,root,755)
@@ -2102,12 +2246,30 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %ghost %{_libdir}/libQtSql.so.4
 %dir %{_qtdir}/plugins/sqldrivers
 
+%if %{with ibase}
+%files -n QtSql-ibase
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqlibase.so
+%endif
+
 %if %{with mysql}
 %files -n QtSql-mysql
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqlmysql.so
 %endif
 
+%if %{with oci}
+%files -n QtSql-oci
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqloci.so
+%endif
+
+%if %{with odbc}
+%files -n QtSql-odbc
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqlodbc.so
+%endif
+
 %if %{with pgsql}
 %files -n QtSql-pgsql
 %defattr(644,root,root,755)
@@ -2126,18 +2288,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqlite.so
 %endif
 
-%if %{with ibase}
-%files -n QtSql-ibase
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqlibase.so
-%endif
-
-%if %{with odbc}
-%files -n QtSql-odbc
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqlodbc.so
-%endif
-
 %files -n QtSql-tds
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqltds.so
@@ -2188,6 +2338,7 @@ rm -rf $RPM_BUILD_ROOT
 %lang(cs) %{_localedir}/cs/LC_MESSAGES/qt4-assistant.qm
 %lang(da) %{_localedir}/da/LC_MESSAGES/qt4-assistant.qm
 %lang(de) %{_localedir}/de/LC_MESSAGES/qt4-assistant.qm
+%lang(eu) %{_localedir}/eu/LC_MESSAGES/qt4-assistant.qm
 %lang(fr) %{_localedir}/fr/LC_MESSAGES/qt4-assistant.qm
 %lang(hu) %{_localedir}/hu/LC_MESSAGES/qt4-assistant.qm
 %lang(ja) %{_localedir}/ja/LC_MESSAGES/qt4-assistant.qm
@@ -2237,6 +2388,10 @@ rm -rf $RPM_BUILD_ROOT
 %{_desktopdir}/designer-qt4.desktop
 %{_pixmapsdir}/designer-qt4.png
 
+%files devel-private
+%defattr(644,root,root,755)
+%{_includedir}/qt4/private
+
 %files linguist
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/findtr-qt4
@@ -2250,7 +2405,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_qtdir}/bin/lupdate
 %lang(cs) %{_localedir}/cs/LC_MESSAGES/qt4-linguist.qm
 %lang(de) %{_localedir}/de/LC_MESSAGES/qt4-linguist.qm
+%lang(eu) %{_localedir}/eu/LC_MESSAGES/qt4-linguist.qm
 %lang(fr) %{_localedir}/fr/LC_MESSAGES/qt4-linguist.qm
+%lang(he) %{_localedir}/he/LC_MESSAGES/qt4-linguist.qm
 %lang(hu) %{_localedir}/hu/LC_MESSAGES/qt4-linguist.qm
 %lang(ja) %{_localedir}/ja/LC_MESSAGES/qt4-linguist.qm
 %lang(ko) %{_localedir}/ko/LC_MESSAGES/qt4-linguist.qm
@@ -2284,6 +2441,8 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qtconfig-qt4
 %attr(755,root,root) %{_qtdir}/bin/qtconfig
+%lang(eu) %{_localedir}/eu/LC_MESSAGES/qt4-qtconfig.qm
+%lang(he) %{_localedir}/he/LC_MESSAGES/qt4-qtconfig.qm
 %lang(hu) %{_localedir}/hu/LC_MESSAGES/qt4-qtconfig.qm
 %lang(ja) %{_localedir}/ja/LC_MESSAGES/qt4-qtconfig.qm
 %lang(ko) %{_localedir}/ko/LC_MESSAGES/qt4-qtconfig.qm
@@ -2300,6 +2459,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qvfb
 %attr(755,root,root) %{_qtdir}/bin/qvfb
+%lang(eu) %{_localedir}/eu/LC_MESSAGES/qt4-qvfb.qm
 %lang(hu) %{_localedir}/hu/LC_MESSAGES/qt4-qvfb.qm
 %lang(ja) %{_localedir}/ja/LC_MESSAGES/qt4-qvfb.qm
 %lang(ko) %{_localedir}/ko/LC_MESSAGES/qt4-qvfb.qm
@@ -2313,7 +2473,6 @@ rm -rf $RPM_BUILD_ROOT
 %files doc
 %defattr(644,root,root,755)
 %{_docdir}/%{name}-doc
-%{_qtdir}/doc
 
 %files -n QtCLucene-devel -f QtCLucene-devel.files
 %defattr(644,root,root,755)
@@ -2325,6 +2484,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n QtCore-devel -f QtCore-devel.files
 %defattr(644,root,root,755)
+%dir %{_includedir}/qt4/QtSolutions
 
 %files -n QtDBus-devel -f QtDBus-devel.files
 %defattr(644,root,root,755)
@@ -2350,8 +2510,10 @@ rm -rf $RPM_BUILD_ROOT
 %files -n QtOpenGL-devel -f QtOpenGL-devel.files
 %defattr(644,root,root,755)
 
+%if %{with openvg}
 %files -n QtOpenVG-devel -f QtOpenVG-devel.files
 %defattr(644,root,root,755)
+%endif
 
 %files -n QtScript-devel -f QtScript-devel.files
 %defattr(644,root,root,755)
@@ -2427,9 +2589,11 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/libQtOpenGL.a
 
+%if %{with openvg}
 %files -n QtOpenVG-static
 %defattr(644,root,root,755)
 %{_libdir}/libQtOpenVG.a
+%endif
 
 %files -n QtScript-static
 %defattr(644,root,root,755)
This page took 0.102374 seconds and 4 git commands to generate.