]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
- kqemu kernel module build procedure updated
[packages/qemu.git] / qemu.spec
index b476e81e917299b05c96057df391d339d7a742e5..92ed82a2ef2bc7c3698659403f60a5f016d6b85f 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -6,6 +6,7 @@
 %bcond_with    kqemu                   # with QEMU accelerator module
 %bcond_with    cflags_passing          # with passing rpmcflags to Makefiles
 %bcond_with    nosdlgui                # do not use SDL gui (use X11 instead)
+%bcond_with    gcc4                    # use gcc4 patches (broke build on gcc33)
 %bcond_without dist_kernel             # without distribution kernel
 %bcond_without kernel                  # don't build kernel modules
 %bcond_without smp                     # don't build SMP module
@@ -17,7 +18,7 @@ Summary:      QEMU CPU Emulator
 Summary(pl):   QEMU - emulator procesora
 Name:          qemu
 Version:       0.8.0
-%define                _rel    1
+%define                _rel    1.1
 Release:       %{_rel}%{?with_kqemu:k}
 License:       GPL
 Group:         Applications/Emulators
@@ -40,9 +41,11 @@ Patch7:              %{name}-parallel.patch
 Patch8:                %{name}-nosdlgui.patch
 Patch9:                %{name}-ifup.patch
 Patch10:       %{name}-gcc33.patch
+Patch11:       %{name}-slirp_throttle.patch
 URL:           http://fabrice.bellard.free.fr/qemu/
 BuildRequires: SDL-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
+%{!?with_gcc4:BuildRequires:   gcc < 5:4.0}
 %if %{with kqemu} && %{with dist_kernel}
 BuildRequires: kernel-module-build >= 2.6.7
 %endif
@@ -131,13 +134,16 @@ kqemu - modu
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%if %{with gcc4}
 %patch5 -p0
 %patch6 -p1
+%endif
 # probably not needed
 # %patch7 -p1
 %{?with_nosdlgui:%patch8 -p1}
 %patch9 -p1
 %patch10 -p1
+%patch11 -p0
 
 %{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
 %{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
@@ -158,21 +164,21 @@ for cfg in %{?with_dist_kernel:%{?with_smp:smp} up}%{!?with_dist_kernel:nondist}
        if [ ! -r "%{_kernelsrcdir}/config-$cfg" ]; then
                exit 1
        fi
-       rm -rf include
-       install -d include/{linux,config}
-       ln -sf %{_kernelsrcdir}/config-$cfg .config
-       ln -sf %{_kernelsrcdir}/include/linux/autoconf-$cfg.h include/linux/autoconf.h
-       ln -sf %{_kernelsrcdir}/include/asm-%{_target_base_arch} include/asm
-       ln -sf %{_kernelsrcdir}/Module.symvers-$cfg Module.symvers
+       install -d o/include/{linux,config}
+       ln -sf %{_kernelsrcdir}/config-$cfg o/.config
+       ln -sf %{_kernelsrcdir}/include/linux/autoconf-$cfg.h o/include/linux/autoconf.h
+       ln -sf %{_kernelsrcdir}/Module.symvers-$cfg o/Module.symvers
 %if %{without dist_kernel}
-       ln -sf %{_kernelsrcdir}/scripts
+       %{__make} -C %{_kernelsrcdir} O=$PWD/o prepare scripts
+%else
+       ln -sf %{_kernelsrcdir}/scripts o/scripts
+       touch o/include/config/MARKER
 %endif
-       touch include/config/MARKER
        %{__make} -C %{_kernelsrcdir} clean \
                RCS_FIND_IGNORE="-name 'kqemu-mod-*.*' -o" \
-               M=$PWD O=$PWD
+               M=$PWD O=$PWD/o
        %{__make} -C %{_kernelsrcdir} modules \
-               M=$PWD O=$PWD
+               M=$PWD O=$PWD/o
        mv kqemu.ko kqemu-mod-$cfg.ko
 done
 cd -
@@ -184,9 +190,11 @@ cd -
 ./configure \
        --prefix=%{_prefix} \
        --cc="%{__cc}" \
-       --enable-alsa \
+       %{?with_gcc4:--disable-gcc-check} \
        %{!?with_kqemu:--disable-kqemu} \
-       --make="%{__make}"
+       --enable-alsa \
+       --make="%{__make}" \
+       --interp-prefix=%{_libdir}/%{name}
 %{__make}
 %endif
 
This page took 0.072749 seconds and 4 git commands to generate.