]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
- rel 55 (kernel 2.6.16.55)
[packages/qemu.git] / qemu.spec
index d568b027c7835e62d5e2aea3b958de84f4064f17..7f12c8882449a518b1765cd75ef5e73e9a557226 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -5,16 +5,23 @@
 # Conditional build:
 %bcond_without kqemu                   # disable KQEMU ACCELERATOR support in QEMU
 %bcond_with    cflags_passing          # with passing rpmcflags to Makefiles
+%bcond_with    dosguest                # add special patch when use with DOS as guest os
 %bcond_with    nosdlgui                # do not use SDL gui (use X11 instead)
 # Note that gcc4 build is very problematic and not supported by qemu team
 %bcond_with    gcc4                    # use gcc4 patches (broke build on gcc33)
 %bcond_without dist_kernel             # without distribution kernel
 %bcond_without kernel                  # build kqemu KERNEL MODULES
+%bcond_without up                      # don't build up module
 %bcond_without smp                     # don't build SMP module
 %bcond_without userspace               # don't build userspace utilities
 #
+# no kernel kqemu module for ppc
+%ifarch ppc
+%undefine      with_kqemu
+%undefine      with_kernel
+%endif
 %define        _kqemu_version  1.3.0pre11
-%define                _rel    1
+%define                _rel    55
 Summary:       QEMU CPU Emulator
 Summary(pl):   QEMU - emulator procesora
 Name:          qemu
@@ -40,6 +47,10 @@ Patch8:              %{name}-kde_virtual_workspaces_hack.patch
 Patch9:                %{name}-0.8.0-gcc4-hacks.patch
 Patch11:       %{name}-0.7.2-gcc4-opts.patch
 #Patch12:      %{name}-0.7.2-dyngen-check-stack-clobbers.patch
+Patch13:       %{name}-dosguest.patch
+# Fix crash when using qemu instances with NICs connected via socket
+# This patch will be obsolete in versions after 0.9.0
+Patch14:       %{name}-0.9.0-remove-iohandlers.patch
 URL:           http://fabrice.bellard.free.fr/qemu/
 %if %{with kernel} && %{with dist_kernel}
 BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
@@ -127,6 +138,13 @@ kqemu - SMP kernel module.
 kqemu - modu³ j±dra SMP.
 
 %prep
+%if %{with kernel}
+%if %{with dist_kernel} && %{without up} && %{without smp}
+%{error:%{name}: If building kernel module You need to enable at least one of up or smp}
+exit 1
+%endif
+%endif
+
 %setup -q %{?with_kernel:-a1}
 %patch0 -p1
 %patch1 -p1
@@ -141,6 +159,7 @@ kqemu - modu
 %{?with_nosdlgui:%patch6 -p1}
 %patch7 -p1
 #%patch8 -p1
+%patch14 -p1
 
 %{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
 %{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
@@ -167,12 +186,25 @@ KERNEL=="kqemu", NAME="%k", MODE="0666"
 EOF
 %endif
 
+%if %{with dosguest}
+%patch13 -p1
+%endif
+
 %build
 %if %{with kernel}
 cd kqemu-%{_kqemu_version}
 
-mv -f kqemu-mod-i386.o{,.bin}
+%{__sed} -i 's#include ../config-host.mak##' ./common/Makefile
+%ifarch %{x8664}
+%{__sed} -i 's/^#ARCH=x86_64/ARCH=x86_64/' ./common/Makefile
+%{__make} -C common
 mv -f kqemu-mod-x86_64.o{,.bin}
+%else
+%{__sed} -i 's/^#ARCH=i386/ARCH=i386/' ./common/Makefile
+%{__make} -C common
+mv -f kqemu-mod-i386.o{,.bin}
+%endif
+
 mv -f kqemu-linux.c{,.orig}
 cat > Makefile <<'EOF'
 obj-m := kqemu.o
This page took 0.063758 seconds and 4 git commands to generate.