]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
- rel 55 (kernel 2.6.16.55)
[packages/qemu.git] / qemu.spec
index 2d39cf2f7fdc75697ecf08d484cb5f77faa11e80..7f12c8882449a518b1765cd75ef5e73e9a557226 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,66 +1,76 @@
 #
 # TODO:
 # - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
-# - kqemu could be distributable if somebody bothers to contact qemu
-#   author http://fabrice.bellard.free.fr/qemu/qemu-accel.html
 #
 # Conditional build:
-%bcond_with    kqemu                   # with QEMU accelerator module
+%bcond_without kqemu                   # disable KQEMU ACCELERATOR support in QEMU
 %bcond_with    cflags_passing          # with passing rpmcflags to Makefiles
+%bcond_with    dosguest                # add special patch when use with DOS as guest os
 %bcond_with    nosdlgui                # do not use SDL gui (use X11 instead)
+# Note that gcc4 build is very problematic and not supported by qemu team
 %bcond_with    gcc4                    # use gcc4 patches (broke build on gcc33)
 %bcond_without dist_kernel             # without distribution kernel
-%bcond_without kernel                  # don't build kernel modules
+%bcond_without kernel                  # build kqemu KERNEL MODULES
+%bcond_without up                      # don't build up module
 %bcond_without smp                     # don't build SMP module
 %bcond_without userspace               # don't build userspace utilities
 #
-%if %{without kqemu}
-%undefine      with_kernel
+# no kernel kqemu module for ppc
+%ifarch ppc
+%undefine      with_kqemu
+%undefine      with_kernel
 %endif
-#
-%define        _kqemu_version  1.3.0pre7
-%define                _rel    0.2
+%define        _kqemu_version  1.3.0pre11
+%define                _rel    55
 Summary:       QEMU CPU Emulator
 Summary(pl):   QEMU - emulator procesora
 Name:          qemu
-Version:       0.8.1
+Version:       0.9.0
 Release:       %{_rel}%{?with_kqemu:k}
 License:       GPL
 Group:         Applications/Emulators
 #Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
 Source0:       http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
-# Source0-md5: 67d924324a5ab79d017bd97a1e767285
+# Source0-md5: ab11a03ba30cf4a70641f0f170473d69
 Source1:       http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
-# NoSource1-md5:       3b77edbada790f924456aa4675edd0be
-NoSource:      1
+# Source1-md5: 970521874ef8b1ba4598925ace5936c3
 Patch0:                %{name}-nostatic.patch
 Patch1:                %{name}-cc.patch
-Patch2:                %{name}-longjmp.patch
 Patch3:                %{name}-dot.patch
-
-Patch5:                %{name}-gcc4_x86.patch
-Patch6:                %{name}-gcc4_ppc.patch
-Patch7:                %{name}-parallel.patch
-Patch8:                %{name}-nosdlgui.patch
-Patch9:                %{name}-ifup.patch
-Patch10:       %{name}-gcc33.patch
-
+Patch4:                %{name}-gcc4_x86.patch
+Patch5:                %{name}-gcc4_ppc.patch
+Patch6:                %{name}-nosdlgui.patch
+Patch7:                %{name}-ifup.patch
+# Proof of concept, for reference, do not remove
+Patch8:                %{name}-kde_virtual_workspaces_hack.patch
+# http://gwenole.beauchesne.info/en/projects/qemu
+Patch9:                %{name}-0.8.0-gcc4-hacks.patch
+Patch11:       %{name}-0.7.2-gcc4-opts.patch
+#Patch12:      %{name}-0.7.2-dyngen-check-stack-clobbers.patch
+Patch13:       %{name}-dosguest.patch
+# Fix crash when using qemu instances with NICs connected via socket
+# This patch will be obsolete in versions after 0.9.0
+Patch14:       %{name}-0.9.0-remove-iohandlers.patch
 URL:           http://fabrice.bellard.free.fr/qemu/
+%if %{with kernel} && %{with dist_kernel}
+BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
+BuildRequires: rpmbuild(macros) >= 1.330
+%endif
+%if %{with userspace}
 BuildRequires: SDL-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
 %{!?with_gcc4:BuildRequires:   gcc < 5:4.0}
-%if %{with kqemu} && %{with dist_kernel}
-BuildRequires: kernel-module-build >= 3:2.6.7
-%endif
-BuildRequires: rpmbuild(macros) >= 1.217
+BuildRequires: perl-tools-pod
+BuildRequires: tetex
 BuildRequires: sed >= 4.0
+%endif
 Requires:      SDL >= 1.2.1
 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
 ExclusiveArch: %{ix86} %{x8664} %{!?with_kqemu:ppc}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # some SPARC boot image in ELF format
-%define                _noautostrip    .*%{_datadir}/qemu/proll.elf
+%define                _noautostrip    .*%{_datadir}/qemu/openbios-sparc32
 
 %description
 QEMU is a FAST! processor emulator. By using dynamic translation it
@@ -93,56 +103,63 @@ aby dzia
   u¿ywane do wirtualnego hostowania kilku wirtualnych pecetów na
   pojedynczym serwerze.
 
-%package -n kernel-misc-kqemu
+%package -n kernel%{_alt_kernel}-misc-kqemu
 Summary:       kqemu - kernel module
 Summary(pl):   kqemu - modu³ j±dra
 Version:       %{_kqemu_version}
 Release:       %{_rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
 %{?with_dist_kernel:%requires_releq_kernel_up}
-License:       Free to use, non-distributable
+License:       GPL v2
 Requires(post,postun): /sbin/depmod
 Requires:      module-init-tools >= 3.2.2-2
 
-%description -n kernel-misc-kqemu
+%description -n kernel%{_alt_kernel}-misc-kqemu
 kqemu - kernel module.
 
-%description -n kernel-misc-kqemu -l pl
+%description -n kernel%{_alt_kernel}-misc-kqemu -l pl
 kqemu - modu³ j±dra.
 
-%package -n kernel-smp-misc-kqemu
+%package -n kernel%{_alt_kernel}-smp-misc-kqemu
 Summary:       kqemu - SMP kernel module
 Summary(pl):   kqemu - modu³ j±dra SMP
 Version:       %{_kqemu_version}
 Release:       %{_rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
-%{?with_dist_kernel:%requires_releq_kernel_up}
-License:       Free to use, non-distributable
+%{?with_dist_kernel:%requires_releq_kernel_smp}
+License:       GPL v2
 Requires(post,postun): /sbin/depmod
 Requires:      module-init-tools >= 3.2.2-2
 
-%description -n kernel-smp-misc-kqemu
+%description -n kernel%{_alt_kernel}-smp-misc-kqemu
 kqemu - SMP kernel module.
 
-%description -n kernel-smp-misc-kqemu -l pl
+%description -n kernel%{_alt_kernel}-smp-misc-kqemu -l pl
 kqemu - modu³ j±dra SMP.
 
 %prep
-%setup -q %{?with_kqemu:-a1}
+%if %{with kernel}
+%if %{with dist_kernel} && %{without up} && %{without smp}
+%{error:%{name}: If building kernel module You need to enable at least one of up or smp}
+exit 1
+%endif
+%endif
+
+%setup -q %{?with_kernel:-a1}
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 %patch3 -p1
-
 %if %{with gcc4}
-%patch5 -p0
-%patch6 -p1
-%endif
-# probably not needed
-# %patch7 -p1
-%{?with_nosdlgui:%patch8 -p1}
 %patch9 -p1
-%patch10 -p1
+%patch11 -p1
+#%patch12 -p1
+#%patch4 -p0
+%patch5 -p1
+%endif
+%{?with_nosdlgui:%patch6 -p1}
+%patch7 -p1
+#%patch8 -p1
+%patch14 -p1
 
 %{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
 %{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
@@ -154,7 +171,7 @@ kqemu - modu
 %{__sed} -i 's/-Wall -O2 -g/-Wall -O2/' Makefile Makefile.target
 %endif
 
-%if %{with kqemu}
+%if %{with kernel}
 echo -n > kqemu-%{_kqemu_version}/install.sh
 
 cat <<'EOF' > modprobe.conf
@@ -169,38 +186,42 @@ KERNEL=="kqemu", NAME="%k", MODE="0666"
 EOF
 %endif
 
+%if %{with dosguest}
+%patch13 -p1
+%endif
+
 %build
 %if %{with kernel}
 cd kqemu-%{_kqemu_version}
-mv -f kqemu-linux.c{,.orig}
-for cfg in %{?with_dist_kernel:%{?with_smp:smp} up}%{!?with_dist_kernel:nondist}; do
-       if [ ! -r "%{_kernelsrcdir}/config-$cfg" ]; then
-               exit 1
-       fi
-       install -d o/include/linux
-       ln -sf %{_kernelsrcdir}/config-$cfg o/.config
-       ln -sf %{_kernelsrcdir}/Module.symvers-$cfg o/Module.symvers
-       ln -sf %{_kernelsrcdir}/include/linux/autoconf-$cfg.h o/include/linux/autoconf.h
-%if %{with dist_kernel}
-       %{__make} -C %{_kernelsrcdir} O=$PWD/o prepare scripts
+
+%{__sed} -i 's#include ../config-host.mak##' ./common/Makefile
+%ifarch %{x8664}
+%{__sed} -i 's/^#ARCH=x86_64/ARCH=x86_64/' ./common/Makefile
+%{__make} -C common
+mv -f kqemu-mod-x86_64.o{,.bin}
 %else
-       install -d o/include/config
-       touch o/include/config/MARKER
-       ln -sf %{_kernelsrcdir}/scripts o/scripts
+%{__sed} -i 's/^#ARCH=i386/ARCH=i386/' ./common/Makefile
+%{__make} -C common
+mv -f kqemu-mod-i386.o{,.bin}
 %endif
-       if grep -q "^CONFIG_PREEMPT_RT=y$" o/.config; then
-               sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
-                       kqemu-linux.c.orig > kqemu-linux.c
-       else
-               cat kqemu-linux.c.orig > kqemu-linux.c
-       fi
-
-       %{__make} -C %{_kernelsrcdir} modules \
-               CC="%{__cc}" CPP="%{__cpp}" \
-               M=$PWD O=$PWD/o \
-               %{?with_verbose:V=1}
-       mv kqemu.ko kqemu-mod-$cfg.ko
-done
+
+mv -f kqemu-linux.c{,.orig}
+cat > Makefile <<'EOF'
+obj-m := kqemu.o
+kqemu-objs:= kqemu-linux.o kqemu-mod.o
+
+$(obj)/kqemu-mod.o: $(src)/kqemu-mod-$(ARCH).o.bin
+       cp $< $@
+EOF
+
+%build_kernel_modules -m kqemu <<'EOF'
+if grep -q "CONFIG_PREEMPT_RT" o/.config; then
+       sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
+               kqemu-linux.c.orig > kqemu-linux.c
+else
+       cat kqemu-linux.c.orig > kqemu-linux.c
+fi
+EOF
 cd -
 %endif
 
@@ -212,8 +233,12 @@ cd -
        --cc="%{__cc}" \
        --host-cc="%{__cc}" \
        --make="%{__make}" \
+%if %{with kqemu}
+       --kernel-path=%{_kernelsrcdir} \
+%else
+       --disable-kqemu \
+%endif
        %{?with_gcc4:--disable-gcc-check} \
-       %{!?with_kqemu:--disable-kqemu} \
        --enable-alsa \
        --interp-prefix=%{_libdir}/%{name}
 %{__make}
@@ -238,12 +263,10 @@ EOF
 %endif
 
 %if %{with kernel}
-install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/misc
+%install_kernel_modules -m kqemu-%{_kqemu_version}/kqemu -d misc
 install -d $RPM_BUILD_ROOT/etc/{modprobe.d/%{_kernel_ver}{,smp},udev/rules.d}
-install kqemu-%{_kqemu_version}/kqemu-mod-up.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/kqemu.ko
 install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}/kqemu.conf
 %if %{with smp} && %{with dist_kernel}
-install kqemu-%{_kqemu_version}/kqemu-mod-smp.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/misc/kqemu.ko
 install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}smp/kqemu.conf
 %endif
 install udev.conf $RPM_BUILD_ROOT/etc/udev/rules.d/kqemu.rules
@@ -255,7 +278,7 @@ rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%if %{with kqemu}
+%if %{with kernel}
 %post
 %banner %{name} -e <<EOF
 To enable qemu accelerator (kqemu), the kqemu kernel module must be loaded:
@@ -263,16 +286,16 @@ modprobe kqemu
 EOF
 %endif
 
-%post  -n kernel-misc-kqemu
+%post  -n kernel%{_alt_kernel}-misc-kqemu
 %depmod %{_kernel_ver}
 
-%postun -n kernel-misc-kqemu
+%postun -n kernel%{_alt_kernel}-misc-kqemu
 %depmod %{_kernel_ver}
 
-%post  -n kernel-smp-misc-kqemu
+%post  -n kernel%{_alt_kernel}-smp-misc-kqemu
 %depmod %{_kernel_ver}smp
 
-%postun -n kernel-smp-misc-kqemu
+%postun -n kernel%{_alt_kernel}-smp-misc-kqemu
 %depmod %{_kernel_ver}smp
 
 %if %{with userspace}
@@ -284,14 +307,10 @@ EOF
 %{_datadir}/qemu
 %{_mandir}/man1/qemu.1*
 %{_mandir}/man1/qemu-img.1*
-# FIXME: maybe better moved this into dev.spec
-%if %{with kqemu}
-%dev(c,250,0) %attr(666,root,root) /dev/kqemu
-%endif
 %endif
 
 %if %{with kernel}
-%files -n kernel-misc-kqemu
+%files -n kernel%{_alt_kernel}-misc-kqemu
 %defattr(644,root,root,755)
 %doc kqemu-%{_kqemu_version}/LICENSE
 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
@@ -299,7 +318,7 @@ EOF
 /lib/modules/%{_kernel_ver}/misc/kqemu.ko*
 
 %if %{with smp} && %{with dist_kernel}
-%files -n kernel-smp-misc-kqemu
+%files -n kernel%{_alt_kernel}-smp-misc-kqemu
 %defattr(644,root,root,755)
 %doc kqemu-%{_kqemu_version}/LICENSE
 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
This page took 0.543357 seconds and 4 git commands to generate.