]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
- rel 55 (kernel 2.6.16.55)
[packages/qemu.git] / qemu.spec
index 1ef5697b03219dd56983d6ffe50a76987328031d..7f12c8882449a518b1765cd75ef5e73e9a557226 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,36 +1,41 @@
 #
 # TODO:
 # - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
-# - kqemu module could be distributable if somebody bothers to contact qemu
-#   author http://fabrice.bellard.free.fr/qemu/qemu-accel.html
 #
 # Conditional build:
-%bcond_without kqemu                   # disable QEMU accelerator support
+%bcond_without kqemu                   # disable KQEMU ACCELERATOR support in QEMU
 %bcond_with    cflags_passing          # with passing rpmcflags to Makefiles
+%bcond_with    dosguest                # add special patch when use with DOS as guest os
 %bcond_with    nosdlgui                # do not use SDL gui (use X11 instead)
-%bcond_without gcc4                    # use gcc4 patches (broke build on gcc33)
+# Note that gcc4 build is very problematic and not supported by qemu team
+%bcond_with    gcc4                    # use gcc4 patches (broke build on gcc33)
 %bcond_without dist_kernel             # without distribution kernel
-%bcond_with    kernel                  # build kqemu kernel modules (see License)
+%bcond_without kernel                  # build kqemu KERNEL MODULES
+%bcond_without up                      # don't build up module
 %bcond_without smp                     # don't build SMP module
 %bcond_without userspace               # don't build userspace utilities
 #
-%define        _kqemu_version  1.3.0pre9
-%define                _rel    1
+# no kernel kqemu module for ppc
+%ifarch ppc
+%undefine      with_kqemu
+%undefine      with_kernel
+%endif
+%define        _kqemu_version  1.3.0pre11
+%define                _rel    55
 Summary:       QEMU CPU Emulator
 Summary(pl):   QEMU - emulator procesora
 Name:          qemu
-Version:       0.8.2
+Version:       0.9.0
 Release:       %{_rel}%{?with_kqemu:k}
 License:       GPL
 Group:         Applications/Emulators
 #Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
 Source0:       http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
-# Source0-md5: 5b3a89eb2f256a8a6f3bb07f7b3f1b07
+# Source0-md5: ab11a03ba30cf4a70641f0f170473d69
 Source1:       http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
-# Source1-md5: 27888c3220844ad360a6a23345fa1bcb
+# Source1-md5: 970521874ef8b1ba4598925ace5936c3
 Patch0:                %{name}-nostatic.patch
 Patch1:                %{name}-cc.patch
-Patch2:                %{name}-longjmp.patch
 Patch3:                %{name}-dot.patch
 Patch4:                %{name}-gcc4_x86.patch
 Patch5:                %{name}-gcc4_ppc.patch
@@ -40,19 +45,22 @@ Patch7:             %{name}-ifup.patch
 Patch8:                %{name}-kde_virtual_workspaces_hack.patch
 # http://gwenole.beauchesne.info/en/projects/qemu
 Patch9:                %{name}-0.8.0-gcc4-hacks.patch
-Patch10:       %{name}-0.7.0-gcc4.patch
 Patch11:       %{name}-0.7.2-gcc4-opts.patch
-Patch12:       %{name}-0.7.2-dyngen-check-stack-clobbers.patch
+#Patch12:      %{name}-0.7.2-dyngen-check-stack-clobbers.patch
+Patch13:       %{name}-dosguest.patch
+# Fix crash when using qemu instances with NICs connected via socket
+# This patch will be obsolete in versions after 0.9.0
+Patch14:       %{name}-0.9.0-remove-iohandlers.patch
 URL:           http://fabrice.bellard.free.fr/qemu/
 %if %{with kernel} && %{with dist_kernel}
 BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
+BuildRequires: rpmbuild(macros) >= 1.330
 %endif
 %if %{with userspace}
 BuildRequires: SDL-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
 %{!?with_gcc4:BuildRequires:   gcc < 5:4.0}
 BuildRequires: perl-tools-pod
-BuildRequires: rpmbuild(macros) >= 1.330
 BuildRequires: tetex
 BuildRequires: sed >= 4.0
 %endif
@@ -102,7 +110,7 @@ Version:    %{_kqemu_version}
 Release:       %{_rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
 %{?with_dist_kernel:%requires_releq_kernel_up}
-License:       Free to use, non-distributable
+License:       GPL v2
 Requires(post,postun): /sbin/depmod
 Requires:      module-init-tools >= 3.2.2-2
 
@@ -119,7 +127,7 @@ Version:    %{_kqemu_version}
 Release:       %{_rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
 %{?with_dist_kernel:%requires_releq_kernel_smp}
-License:       Free to use, non-distributable
+License:       GPL v2
 Requires(post,postun): /sbin/depmod
 Requires:      module-init-tools >= 3.2.2-2
 
@@ -130,22 +138,28 @@ kqemu - SMP kernel module.
 kqemu - modu³ j±dra SMP.
 
 %prep
+%if %{with kernel}
+%if %{with dist_kernel} && %{without up} && %{without smp}
+%{error:%{name}: If building kernel module You need to enable at least one of up or smp}
+exit 1
+%endif
+%endif
+
 %setup -q %{?with_kernel:-a1}
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 %patch3 -p1
 %if %{with gcc4}
 %patch9 -p1
-%patch10 -p1
 %patch11 -p1
-%patch12 -p1
+#%patch12 -p1
 #%patch4 -p0
 %patch5 -p1
 %endif
 %{?with_nosdlgui:%patch6 -p1}
 %patch7 -p1
 #%patch8 -p1
+%patch14 -p1
 
 %{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
 %{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
@@ -172,12 +186,25 @@ KERNEL=="kqemu", NAME="%k", MODE="0666"
 EOF
 %endif
 
+%if %{with dosguest}
+%patch13 -p1
+%endif
+
 %build
 %if %{with kernel}
 cd kqemu-%{_kqemu_version}
 
-mv -f kqemu-mod-i386.o{,.bin}
+%{__sed} -i 's#include ../config-host.mak##' ./common/Makefile
+%ifarch %{x8664}
+%{__sed} -i 's/^#ARCH=x86_64/ARCH=x86_64/' ./common/Makefile
+%{__make} -C common
 mv -f kqemu-mod-x86_64.o{,.bin}
+%else
+%{__sed} -i 's/^#ARCH=i386/ARCH=i386/' ./common/Makefile
+%{__make} -C common
+mv -f kqemu-mod-i386.o{,.bin}
+%endif
+
 mv -f kqemu-linux.c{,.orig}
 cat > Makefile <<'EOF'
 obj-m := kqemu.o
This page took 0.071111 seconds and 4 git commands to generate.