]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
- gcc4 disables by default on AC-branch
[packages/qemu.git] / qemu.spec
index fec5c882b6da4facb6ce6d19a05147f1668eb064..3d8abc848b9436bd10942ac58c6caa7297f36057 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -3,20 +3,23 @@
 # - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
 #
 # Conditional build:
-%bcond_without kqemu                   # disable QEMU ACCELERATOR support
+%bcond_without kqemu                   # disable KQEMU ACCELERATOR support in QEMU
 %bcond_with    cflags_passing          # with passing rpmcflags to Makefiles
+%bcond_with    dosguest                # add special patch when use with DOS as guest os
 %bcond_with    nosdlgui                # do not use SDL gui (use X11 instead)
 # Note that gcc4 build is very problematic and not supported by qemu team
 %bcond_with    gcc4                    # use gcc4 patches (broke build on gcc33)
 %bcond_without dist_kernel             # without distribution kernel
 %bcond_without kernel                  # build kqemu KERNEL MODULES
+%bcond_without up                      # don't build up module
 %bcond_without smp                     # don't build SMP module
 %bcond_without userspace               # don't build userspace utilities
 #
+
 %define        _kqemu_version  1.3.0pre11
 %define                _rel    1
 Summary:       QEMU CPU Emulator
-Summary(pl):   QEMU - emulator procesora
+Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
 Version:       0.9.0
 Release:       %{_rel}%{?with_kqemu:k}
@@ -40,6 +43,7 @@ Patch8:               %{name}-kde_virtual_workspaces_hack.patch
 Patch9:                %{name}-0.8.0-gcc4-hacks.patch
 Patch11:       %{name}-0.7.2-gcc4-opts.patch
 #Patch12:      %{name}-0.7.2-dyngen-check-stack-clobbers.patch
+Patch13:       %{name}-dosguest.patch
 URL:           http://fabrice.bellard.free.fr/qemu/
 %if %{with kernel} && %{with dist_kernel}
 BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
@@ -75,58 +79,65 @@ CPUs. QEMU has two operating modes:
   including a processor and various peripherials. It can also be used to
   provide virtual hosting of several virtual PC on a single server.
 
-%description -l pl
-QEMU to szybki(!) emulator procesora. Poprzez u¿ycie dynamicznego
-t³umaczenia osi±ga rozs±dn± szybko¶æ i jest ³atwy do przeportowania,
-aby dzia³a³ na kolejnych procesorach. QEMU ma dwa tryby pracy:
+%description -l pl.UTF-8
+QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
+tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
+aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
 
-- Emulacja trybu u¿ytkownika. W tym trybie QEMU mo¿e uruchamiaæ
+- Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
   procesy linuksowe skompilowane dla jednego procesora na innym
-  procesorze. Linuksowe wywo³ania systemowe s± t³umaczone ze wzglêdu na
-  niezgodno¶æ kolejno¶ci bajtów w s³owie i 32/64-bitowego rozmiaru
-  s³owa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to g³ówne
+  procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
+  niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
+  słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
   cele QEMU.
 
-- Pe³na emulacja systemu. W tym trybie QEMU emuluje ca³y system,
-  w³±czaj±c w to procesor i ró¿ne urz±dzenia peryferyjne. Mo¿e byæ tak¿e
-  u¿ywane do wirtualnego hostowania kilku wirtualnych pecetów na
+- Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
+  włączając w to procesor i różne urządzenia peryferyjne. Może być także
+  używane do wirtualnego hostowania kilku wirtualnych pecetów na
   pojedynczym serwerze.
 
 %package -n kernel%{_alt_kernel}-misc-kqemu
 Summary:       kqemu - kernel module
-Summary(pl):   kqemu - modu³ j±dra
+Summary(pl.UTF-8):     kqemu - moduł jądra
 Version:       %{_kqemu_version}
 Release:       %{_rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
 %{?with_dist_kernel:%requires_releq_kernel_up}
-License:       Free to use, non-distributable
+License:       GPL v2
 Requires(post,postun): /sbin/depmod
 Requires:      module-init-tools >= 3.2.2-2
 
 %description -n kernel%{_alt_kernel}-misc-kqemu
 kqemu - kernel module.
 
-%description -n kernel%{_alt_kernel}-misc-kqemu -l pl
-kqemu - modu³ j±dra.
+%description -n kernel%{_alt_kernel}-misc-kqemu -l pl.UTF-8
+kqemu - moduł jądra.
 
 %package -n kernel%{_alt_kernel}-smp-misc-kqemu
 Summary:       kqemu - SMP kernel module
-Summary(pl):   kqemu - modu³ j±dra SMP
+Summary(pl.UTF-8):     kqemu - moduł jądra SMP
 Version:       %{_kqemu_version}
 Release:       %{_rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
 %{?with_dist_kernel:%requires_releq_kernel_smp}
-License:       Free to use, non-distributable
+License:       GPL v2
 Requires(post,postun): /sbin/depmod
 Requires:      module-init-tools >= 3.2.2-2
 
 %description -n kernel%{_alt_kernel}-smp-misc-kqemu
 kqemu - SMP kernel module.
 
-%description -n kernel%{_alt_kernel}-smp-misc-kqemu -l pl
-kqemu - modu³ j±dra SMP.
+%description -n kernel%{_alt_kernel}-smp-misc-kqemu -l pl.UTF-8
+kqemu - moduł jądra SMP.
 
 %prep
+%if %{with kernel}
+%if %{with dist_kernel} && %{without up} && %{without smp}
+%{error:%{name}: If building kernel module You need to enable at least one of up or smp}
+exit 1
+%endif
+%endif
+
 %setup -q %{?with_kernel:-a1}
 %patch0 -p1
 %patch1 -p1
@@ -167,12 +178,25 @@ KERNEL=="kqemu", NAME="%k", MODE="0666"
 EOF
 %endif
 
+%if %{with dosguest}
+%patch13 -p1
+%endif
+
 %build
 %if %{with kernel}
 cd kqemu-%{_kqemu_version}
 
-mv -f kqemu-mod-i386.o{,.bin}
+%{__sed} -i 's#include ../config-host.mak##' ./common/Makefile
+%ifarch %{x8664}
+%{__sed} -i 's/^#ARCH=x86_64/ARCH=x86_64/' ./common/Makefile
+%{__make} -C common
 mv -f kqemu-mod-x86_64.o{,.bin}
+%else
+%{__sed} -i 's/^#ARCH=i386/ARCH=i386/' ./common/Makefile
+%{__make} -C common
+mv -f kqemu-mod-i386.o{,.bin}
+%endif
+
 mv -f kqemu-linux.c{,.orig}
 cat > Makefile <<'EOF'
 obj-m := kqemu.o
This page took 0.119404 seconds and 4 git commands to generate.