]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
- gcc4 disables by default on AC-branch
[packages/qemu.git] / qemu.spec
index f14defd3d9589400716ae18213af2c270551d25b..3d8abc848b9436bd10942ac58c6caa7297f36057 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -5,14 +5,17 @@
 # Conditional build:
 %bcond_without kqemu                   # disable KQEMU ACCELERATOR support in QEMU
 %bcond_with    cflags_passing          # with passing rpmcflags to Makefiles
+%bcond_with    dosguest                # add special patch when use with DOS as guest os
 %bcond_with    nosdlgui                # do not use SDL gui (use X11 instead)
 # Note that gcc4 build is very problematic and not supported by qemu team
 %bcond_with    gcc4                    # use gcc4 patches (broke build on gcc33)
 %bcond_without dist_kernel             # without distribution kernel
 %bcond_without kernel                  # build kqemu KERNEL MODULES
+%bcond_without up                      # don't build up module
 %bcond_without smp                     # don't build SMP module
 %bcond_without userspace               # don't build userspace utilities
 #
+
 %define        _kqemu_version  1.3.0pre11
 %define                _rel    1
 Summary:       QEMU CPU Emulator
@@ -40,6 +43,7 @@ Patch8:               %{name}-kde_virtual_workspaces_hack.patch
 Patch9:                %{name}-0.8.0-gcc4-hacks.patch
 Patch11:       %{name}-0.7.2-gcc4-opts.patch
 #Patch12:      %{name}-0.7.2-dyngen-check-stack-clobbers.patch
+Patch13:       %{name}-dosguest.patch
 URL:           http://fabrice.bellard.free.fr/qemu/
 %if %{with kernel} && %{with dist_kernel}
 BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
@@ -127,6 +131,13 @@ kqemu - SMP kernel module.
 kqemu - moduł jądra SMP.
 
 %prep
+%if %{with kernel}
+%if %{with dist_kernel} && %{without up} && %{without smp}
+%{error:%{name}: If building kernel module You need to enable at least one of up or smp}
+exit 1
+%endif
+%endif
+
 %setup -q %{?with_kernel:-a1}
 %patch0 -p1
 %patch1 -p1
@@ -167,6 +178,10 @@ KERNEL=="kqemu", NAME="%k", MODE="0666"
 EOF
 %endif
 
+%if %{with dosguest}
+%patch13 -p1
+%endif
+
 %build
 %if %{with kernel}
 cd kqemu-%{_kqemu_version}
This page took 0.060019 seconds and 4 git commands to generate.