]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
update qemu.binfmnt from fedora
[packages/qemu.git] / qemu.spec
index 3c0e959af9957275e73977c405a754b8093c9134..0adb0dd488ec400cbb6bf11aab863b04fb221fff 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,10 +1,11 @@
-# TODO: archipelago (libxseg) on bcond (GPL v3 vs v2-only conflict)
 #
 # Conditional build:
 %bcond_without sdl             # SDL UI and audio support
+%bcond_without gl              # Don't require gl deps
 %bcond_without ceph            # Ceph/RBD support
 %bcond_without glusterfs       # GlusterFS backend
 %bcond_without rdma            # RDMA-based migration support
+%bcond_with    xseg            # Archipelago backend [non-distributable: GPLv3+ vs GPLv2-only]
 %bcond_with    gtk2            # GTK+ 2.x instead of 3.x
 %bcond_without gtk3            # Do not build GTK+ UI
 %bcond_without vte             # VTE support in GTK+ UI
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       2.4.0
+Version:       2.7.0
 Release:       1
 License:       GPL v2
 Group:         Applications/Emulators
 Source0:       http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
-# Source0-md5: 186ee8194140a484a455f8e3c74589f4
+# Source0-md5: 08d4d06d1cb598efecd796137f4844ab
 Source2:       %{name}.binfmt
 # Loads kvm kernel modules at boot
 Source3:       kvm-modules-load.conf
@@ -59,15 +60,13 @@ Source12:   99-%{name}-guest-agent.rules
 Patch0:                %{name}-cflags.patch
 Patch1:                vgabios-widescreens.patch
 Patch2:                %{name}-whitelist.patch
-Patch3:                %{name}-system-libcacard.patch
+
 Patch4:                %{name}-xattr.patch
 Patch5:                libjpeg-boolean.patch
 Patch6:                x32.patch
-# Proof of concept, for reference, do not remove
-Patch400:      %{name}-kde_virtual_workspaces_hack.patch
 URL:           http://www.qemu-project.org/
-BuildRequires: OpenGL-devel
-BuildRequires: OpenGL-GLX-devel
+%{?with_gl:BuildRequires:      OpenGL-GLX-devel}
+%{?with_gl:BuildRequires:      OpenGL-devel}
 %{?with_sdl:BuildRequires:     SDL2-devel >= 2.0}
 BuildRequires: alsa-lib-devel
 BuildRequires: bcc >= 0.16.21-2
@@ -85,7 +84,7 @@ BuildRequires:        libaio-devel
 %{?with_smartcard:BuildRequires:       libcacard-devel}
 BuildRequires: libcap-devel
 BuildRequires: libcap-ng-devel
-BuildRequires: libepoxy-devel
+%{?with_gl:BuildRequires:      libepoxy-devel}
 BuildRequires: libfdt-devel
 %{?with_rdma:BuildRequires:    libibverbs-devel}
 %{?with_iscsi:BuildRequires:   libiscsi-devel >= 1.9.0}
@@ -97,10 +96,11 @@ BuildRequires:      libpng-devel
 BuildRequires: libssh2-devel >= 1.2.8
 BuildRequires: libusb-devel >= 1.0.13
 BuildRequires: libuuid-devel
+%{?with_xseg:BuildRequires:    libxseg-devel}
 %{?with_lttng:BuildRequires:   lttng-ust-devel}
 BuildRequires: lzo-devel >= 2
 BuildRequires: ncurses-devel
-%{?with_smartcard:BuildRequires:       nss-devel >= 3.12.8}
+%{?with_smartcard:BuildRequires:       nss-devel >= 1:3.12.8}
 BuildRequires: numactl-devel
 BuildRequires: perl-Encode
 BuildRequires: perl-tools-pod
@@ -667,6 +667,18 @@ systemach-gościach, komunikującego się kanałem virtio-serial o nazwie
 
 Ten pakiet nie musi być zainstalowany w systemie hosta.
 
+%package module-block-archipelago
+Summary:       QEMU module for Archipelago block devices
+Summary(pl.UTF-8):     Moduł QEMU dla urządeń blokowych Archipelago
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description module-block-archipelago
+Archipelago block device support for QEMU.
+
+%description module-block-archipelago -l pl.UTF-8
+Moduł QEMU dla urządeń blokowych Archipelago.
+
 %package module-block-curl
 Summary:       QEMU module for 'curl' block devices
 Summary(pl.UTF-8):     Moduł QEMU dla urządeń blokowych typu 'curl'
@@ -734,13 +746,11 @@ Moduł QEMU dla urządeń blokowych typu 'ssh'.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p0
-%patch3 -p1
+
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
 
-%{__mv} libcacard libcacard-use-system-lib
-
 # workaround for conflict with alsa/error.h
 ln -s ../error.h qapi/error.h
 
@@ -755,6 +765,7 @@ ln -s ../error.h qapi/error.h
        --cc="%{__cc}" \
        --host-cc="%{__cc}" \
        --disable-strip \
+       %{__enable_disable xseg archipelago} \
        --enable-attr \
        %{__enable_disable bluetooth bluez} \
        %{__enable_disable brlapi} \
@@ -771,7 +782,7 @@ ln -s ../error.h qapi/error.h
        --with-sdlabi=2.0 \
        %{__enable_disable seccomp} \
        %{__enable_disable spice} \
-       %{__enable_disable smartcard smartcard-nss} \
+       %{__enable_disable smartcard smartcard} \
        --enable-tpm \
        --enable-trace-backends="nop%{?with_systemtap:,dtrace}%{?with_lttng:,ust}" \
        %{__enable_disable usbredir usb-redir} \
@@ -781,7 +792,6 @@ ln -s ../error.h qapi/error.h
        --enable-vnc-jpeg \
        --enable-vnc-png \
        --enable-vnc-sasl \
-       --enable-vnc-tls \
        %{!?with_vte:--disable-vte} \
        --enable-kvm \
        %{__enable_disable xen} \
@@ -810,13 +820,15 @@ ln -s ../error.h qapi/error.h
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{systemdunitdir},/usr/lib/binfmt.d} \
-       $RPM_BUILD_ROOT/etc/{sysconfig,udev/rules.d,modules-load.d} \
+       $RPM_BUILD_ROOT/etc/{qemu,sysconfig,udev/rules.d,modules-load.d} \
        $RPM_BUILD_ROOT{%{_sysconfdir}/sasl,%{_sbindir}}
 
 %{__make} install \
        %{!?with_smartcard:CONFIG_USB_SMARTCARD=n} \
        DESTDIR=$RPM_BUILD_ROOT
 
+echo "#allow br0" > $RPM_BUILD_ROOT/etc/qemu/bridge.conf
+
 install -d $RPM_BUILD_ROOT%{_sysconfdir}
 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
 #!/bin/sh
@@ -826,7 +838,6 @@ EOF
 install -p qemu.sasl $RPM_BUILD_ROOT%{_sysconfdir}/sasl/qemu.conf
 
 %ifarch %{ix86} %{x8664} x32
-install -p scripts/kvm/kvm_stat $RPM_BUILD_ROOT%{_bindir}
 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/modules-load.d/kvm.conf
 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
 %endif
@@ -844,22 +855,48 @@ install -p %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/ksmtuned.conf
 install -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
 
+# Install binfmt
 for i in dummy \
 %ifnarch %{ix86} %{x8664} x32
        qemu-i386 \
 %endif
-%ifnarch arm
+%ifnarch alpha
+       qemu-alpha \
+%endif
+%ifnarch %{arm}
        qemu-arm \
 %endif
-%ifnarch ppc ppc64
-       qemu-ppc \
+       qemu-armeb \
+       qemu-cris \
+       qemu-microblaze qemu-microblazeel \
+%ifnarch mips64
+       qemu-mips64 \
+%ifnarch mips
+       qemu-mips \
+%endif
+%endif
+%ifnarch mips64el
+       qemu-mips64el \
+%ifnarch mipsel
+       qemu-mipsel \
+%endif
+%endif
+%ifnarch m68k
+       qemu-m68k \
+%endif
+%ifnarch ppc ppc64 ppc64le
+       qemu-ppc qemu-ppc64abi32 qemu-ppc64 \
 %endif
 %ifnarch sparc sparc64
-       qemu-sparc \
+       qemu-sparc qemu-sparc32plus qemu-sparc64 \
+%endif
+%ifnarch s390 s390x
+       qemu-s390x \
 %endif
 %ifnarch sh4
        qemu-sh4 \
 %endif
+       qemu-sh4eb \
 ; do
        test $i = dummy && continue
        grep /$i:\$ %{SOURCE2} > $RPM_BUILD_ROOT/usr/lib/binfmt.d/$i.conf
@@ -944,10 +981,15 @@ fi
 %config(noreplace) %verify(not md5 mtime size) /etc/ksmtuned.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/sasl/qemu.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ksm
+%dir /etc/qemu
+%attr(640,root,qemu) %config(noreplace) %verify(not md5 mtime size) /etc/qemu/bridge.conf
 %{systemdunitdir}/ksm.service
 %{systemdunitdir}/ksmtuned.service
+%attr(755,root,root) %{_bindir}/ivshmem-client
+%attr(755,root,root) %{_bindir}/ivshmem-server
 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
 %attr(755,root,root) %{_bindir}/qemu-nbd
+%attr(755,root,root) %{_bindir}/qemu-tilegx
 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
 %attr(755,root,root) %{_sbindir}/ksmctl
 %attr(755,root,root) %{_sbindir}/ksmtuned
@@ -958,21 +1000,22 @@ fi
 %dir %{_datadir}/qemu
 %{_datadir}/%{name}/keymaps
 %{_datadir}/%{name}/qemu-icon.bmp
-%{_datadir}/%{name}/trace-events
+%{_datadir}/%{name}/trace-events-all
 
 # various bios images
 # all should be probably moved to the right system subpackage
-%{_datadir}/%{name}/QEMU,cgthree.bin
-%{_datadir}/%{name}/QEMU,tcx.bin
 %{_datadir}/%{name}/bamboo.dtb
+%{_datadir}/%{name}/efi-e1000e.rom
 %{_datadir}/%{name}/efi-e1000.rom
 %{_datadir}/%{name}/efi-eepro100.rom
 %{_datadir}/%{name}/efi-ne2k_pci.rom
 %{_datadir}/%{name}/efi-pcnet.rom
 %{_datadir}/%{name}/efi-rtl8139.rom
 %{_datadir}/%{name}/efi-virtio.rom
+%{_datadir}/%{name}/efi-vmxnet3.rom
 %{_datadir}/%{name}/kvmvapic.bin
 %{_datadir}/%{name}/linuxboot.bin
+%{_datadir}/%{name}/linuxboot_dma.bin
 %{_datadir}/%{name}/multiboot.bin
 %{_datadir}/%{name}/openbios-ppc
 %{_datadir}/%{name}/openbios-sparc*
@@ -986,18 +1029,19 @@ fi
 %{_datadir}/%{name}/pxe-pcnet.rom
 %{_datadir}/%{name}/pxe-rtl8139.rom
 %{_datadir}/%{name}/pxe-virtio.rom
+%{_datadir}/%{name}/QEMU,cgthree.bin
 %{_datadir}/%{name}/qemu_logo_no_text.svg
+%{_datadir}/%{name}/QEMU,tcx.bin
 %{_datadir}/%{name}/s390-ccw.img
-%{_datadir}/%{name}/s390-zipl.rom
 %{_datadir}/%{name}/sgabios.bin
 %{_datadir}/%{name}/slof.bin
 %{_datadir}/%{name}/spapr-rtas.bin
+%{_datadir}/%{name}/vgabios.bin
 %{_datadir}/%{name}/vgabios-cirrus.bin
 %{_datadir}/%{name}/vgabios-qxl.bin
 %{_datadir}/%{name}/vgabios-stdvga.bin
 %{_datadir}/%{name}/vgabios-virtio.bin
 %{_datadir}/%{name}/vgabios-vmware.bin
-%{_datadir}/%{name}/vgabios.bin
 
 %dir %{_libdir}/%{name}
 
@@ -1123,12 +1167,10 @@ fi
 %ifarch %{ix86} %{x8664} x32
 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/kvm.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/80-kvm.rules
-%attr(755,root,root) %{_bindir}/kvm_stat
 %endif
 %{_datadir}/%{name}/bios.bin
 %{_datadir}/%{name}/bios-256k.bin
 %{_datadir}/%{name}/acpi-dsdt.aml
-%{_datadir}/%{name}/q35-acpi-dsdt.aml
 
 %files system-xtensa
 %defattr(644,root,root,755)
@@ -1140,6 +1182,13 @@ fi
 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/99-qemu-guest-agent.rules
 %{systemdunitdir}/qemu-guest-agent.service
 %attr(755,root,root) %{_bindir}/qemu-ga
+%{_mandir}/man8/qemu-ga.8*
+
+%if %{with xseg}
+%files module-block-archipelago
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/block-archipelago.so
+%endif
 
 %files module-block-curl
 %defattr(644,root,root,755)
This page took 0.206402 seconds and 4 git commands to generate.