]> git.pld-linux.org Git - packages/python3.git/blobdiff - python3.spec
- release 4 (by relup.sh)
[packages/python3.git] / python3.spec
index d5250893822f67e051fa97a915c3a801d508d33d..c3bf6d6daf696b751905ce9d2e9e11f93b8aa34e 100644 (file)
@@ -1,3 +1,4 @@
+# NOTE: tests require processes limit >128 (256 is sufficient)
 #
 # Conditional build:
 %bcond_with    info                    # info pages (requires emacs)
@@ -5,7 +6,7 @@
 %bcond_without tkinter                 # disables tkinter module building
 %bcond_without tests                   # disables Python testing
 %bcond_with    verbose_tests           # runs tests in verbose mode
-%bcond_without optimizations           # optimitations
+%bcond_without optimizations           # expensive, stable optimizations (PGO etc.) + LTO
 #
 # tests which will not work on 64-bit platforms
 %define                no64bit_tests   test_audioop test_rgbimg test_imageop
@@ -41,7 +42,7 @@ Summary(tr.UTF-8):    X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
 Summary(uk.UTF-8):     Мова програмування дуже високого рівня з X-інтерфейсом
 Name:          python3
 Version:       %{py_ver}.0
-Release:       2
+Release:       4
 Epoch:         1
 License:       PSF
 Group:         Development/Languages/Python
@@ -61,7 +62,9 @@ Patch10:      %{name}-bdist_rpm.patch
 Patch11:       %{name}-installcompile.patch
 # https://bugs.python.org/file21896/nonexistent_user.patch
 Patch12:        nonexistent_user.patch
-Patch13:       python3-no-randomize-tests.patch
+Patch13:       %{name}-no-randomize-tests.patch
+# https://github.com/python/cpython/commit/c919252a28f4e9dd326dc2c703b4eee6e247be83.patch
+Patch14:       %{name}-redundant_declaration.patch
 URL:           https://www.python.org/
 BuildRequires: autoconf >= 2.65
 BuildRequires: automake
@@ -72,6 +75,9 @@ BuildRequires:        db-devel >= 4
 BuildRequires: expat-devel >= 1:1.95.7
 BuildRequires: file
 BuildRequires: gdbm-devel >= 1.8.3
+%if %(locale -a | grep -q '^C\.utf8$'; echo $?)
+BuildRequires: glibc-localedb-all
+%endif
 BuildRequires: gmp-devel >= 4.0
 BuildRequires: libffi-devel
 BuildRequires: libstdc++-devel
@@ -490,6 +496,7 @@ Moduły testowe dla Pythona.
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
+%patch14 -p1
 
 %{__rm} -r Modules/expat
 
This page took 0.030618 seconds and 4 git commands to generate.