]> git.pld-linux.org Git - packages/python3.git/blobdiff - python3.spec
- release 2
[packages/python3.git] / python3.spec
index 51a0382311107da247a6444767e1e1c81c6d57cf..3ec45010d81f9a12f5f8a31a3299acec91f0c049 100644 (file)
@@ -14,7 +14,7 @@
 # tests which may fail because of builder environment limitations (no /proc or /dev/pts)
 %define                nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
 # tests which fail because of some unknown/unresolved reason (this list should be empty)
-%define                broken_tests test_httpservers test_distutils test_cmd_line test_pydoc test_telnetlib
+%define                broken_tests test_httpservers test_distutils test_cmd_line test_pydoc test_telnetlib test_zlib
 
 %define        beta            %{nil}
 
@@ -34,13 +34,13 @@ Summary(ru.UTF-8):  Язык программирования очень высо
 Summary(tr.UTF-8):     X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
 Summary(uk.UTF-8):     Мова програмування дуже високого рівня з X-інтерфейсом
 Name:          python3
-Version:       %{py_ver}.1
-Release:       1
+Version:       %{py_ver}.2
+Release:       2
 Epoch:         1
 License:       PSF
 Group:         Applications
 Source0:       http://www.python.org/ftp/python/%{version}/Python-%{version}%{beta}.tar.bz2
-# Source0-md5: d1ddd9f16e3c6a51c7208f33518cd674
+# Source0-md5: 45350b51b58a46b029fb06c61257e350
 Patch0:                %{name}-pythonpath.patch
 Patch1:                %{name}-ac_fixes.patch
 Patch2:                %{name}-lib64.patch
@@ -492,7 +492,7 @@ sed -i -e 's=@EXENAME@=%{_bindir}/python3=' Misc/python-config.in
 %build
 sed -i -e 's#-ltermcap#-ltinfo#g' configure*
 %{__autoconf}
-CPPFLAGS="-I/usr/include/ncursesw"; export CPPFLAGS
+CPPFLAGS="-I/usr/include/ncursesw %{rpmcppflags}"; export CPPFLAGS
 %configure \
        --with-cxx-main="%{__cxx}" \
        --enable-shared \
@@ -589,6 +589,9 @@ sed 's/=/ /' \
 # pygettext.py is provided for compatibility
 install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext%{py_ver}
 
+# rename file conflicting with python 2.*
+mv $RPM_BUILD_ROOT%{_bindir}/2to3{,-%{py_ver}}
+
 # just to cut the noise, as they are not packaged (now)
 # first tests
 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/test
@@ -600,6 +603,7 @@ rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/sqlite3/test
 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/json/tests
 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/lib2to3/tests
 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/importlib/test
+rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/tkinter/test
 
 # other files
 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/plat-*/regen
@@ -891,7 +895,6 @@ rm -rf $RPM_BUILD_ROOT
 %{py_scriptdir}/importlib/*.py
 %{py_scriptdir}/json/*.py
 %{py_scriptdir}/lib2to3/*.py
-%{py_scriptdir}/lib2to3/fixes/*.py
 %{py_scriptdir}/lib2to3/pgen2/*.py
 %{py_scriptdir}/logging/*.py
 %{py_scriptdir}/multiprocessing/*.py
@@ -921,12 +924,13 @@ rm -rf $RPM_BUILD_ROOT
 %{py_scriptdir}/timeit.py[co]
 
 %files 2to3
-%attr(755,root,root) %{_bindir}/2to3
+%attr(755,root,root) %{_bindir}/2to3-%{py_ver}
 %dir %{py_scriptdir}/lib2to3
 %{py_scriptdir}/lib2to3/*.txt
 %{py_scriptdir}/lib2to3/*.pickle
 %{py_scriptdir}/lib2to3/*.py[co]
 %dir %{py_scriptdir}/lib2to3/fixes
+%{py_scriptdir}/lib2to3/fixes/*.py
 %{py_scriptdir}/lib2to3/fixes/*.py[co]
 %dir %{py_scriptdir}/lib2to3/pgen2
 %{py_scriptdir}/lib2to3/pgen2/*.py[co]
This page took 0.072279 seconds and 4 git commands to generate.