]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - python.spec
- use explicit PYTEST_PLUGINS lists for reliable tests (not failing if some conflicti...
[projects/template-specs.git] / python.spec
index 6139837bbda368ab1e1c494a9f00f4e41241eb64..894f4858abf6944e5b8f49122312ec07ddb1551f 100644 (file)
@@ -1,44 +1,59 @@
 #
+# This is template for pure python2/python3 modules (noarch)
+# use template-specs/python3.spec for python3 only noarch packages
+# use template-specs/python-ext.spec for binary python packages
+#
+#
 # Conditional build:
-%bcond_without doc             # don't build doc
-%bcond_without tests   # do not perform "make test"
+%bcond_without doc     # Sphinx documentation
+%bcond_without tests   # unit tests
 %bcond_without python2 # CPython 2.x module
 %bcond_without python3 # CPython 3.x module
 
-%define        module  template
+# NOTES:
+# - 'module' should match the Python import path (first component?)
+# - 'egg_name' should equal to Python egg name
+# - 'pypi_name' must match the Python Package Index name
+%define                module          crispy_forms
+%define                egg_name        django_crispy_forms
+%define                pypi_name       django-crispy-forms
 Summary:       -
 Summary(pl.UTF-8):     -
-# Name must match the python module/package name (as in 'import' statement)
 Name:          python-%{module}
 Version:       _
 Release:       0.1
 License:       - (enter GPL/GPL v2/GPL v3/LGPL/BSD/BSD-like/other license name here)
 Group:         Libraries/Python
-Source0:       %{name}-%{version}.tar.gz
+# if pypi:
+#Source0Download: https://pypi.org/simple/PYPI_NAME/
+Source0:       https://files.pythonhosted.org/packages/source/P/PYPI_NAME/%{pypi_name}-%{version}.tar.gz
 # Source0-md5: -
+#URL:          https://pypi.org/project/PYPI_NAME/
 URL:           -
-# remove BR: python-devel for 'noarch' packages.
-BuildRequires: rpm-pythonprov
-# if py_postclean is used
-BuildRequires: rpmbuild(macros) >= 1.219
-# if py3* macros are used
-BuildRequires: rpmbuild(macros) >= 1.612
-# when using /usr/bin/env or other in-place substitutions
-#BuildRequires:        sed >= 4.0
-# when python3 present
 %if %{with python2}
-BuildRequires: python-devel
+BuildRequires: python-modules >= 1:2.5
 BuildRequires: python-setuptools
+%if %{with tests}
+#BuildRequires:        python-
+%endif
 %endif
 %if %{with python3}
-BuildRequires: python3-devel
-BuildRequires: python3-modules
+BuildRequires: python3-modules >= 1:3.2
 BuildRequires: python3-setuptools
+%if %{with tests}
+#BuildRequires:        python3-
+%endif
 %endif
-# Below Rs only work for main package (python2)
-#Requires:             python-libs
-Requires:      python-modules
-#BuildArch:    noarch
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.714
+# when using /usr/bin/env or other in-place substitutions
+#BuildRequires:        sed >= 4.0
+%if %{with doc}
+BuildRequires: sphinx-pdg # -2 or -3
+%endif
+# replace with other requires if defined in setup.py
+Requires:      python-modules >= 1:2.5
+BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -49,80 +64,88 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Summary:       -
 Summary(pl.UTF-8):     -
 Group:         Libraries/Python
-Requires:      python3-modules
+Requires:      python3-modules >= 1:3.2
 
 %description -n python3-%{module}
 
 %description -n python3-%{module} -l pl.UTF-8
 
 %package apidocs
-Summary:       %{module} API documentation
-Summary(pl.UTF-8):     Dokumentacja API %{module}
+Summary:       API documentation for Python %{module} module
+Summary(pl.UTF-8):     Dokumentacja API modułu Pythona %{module}
 Group:         Documentation
 
 %description apidocs
-API documentation for %{module}.
+API documentation for Python %{module} module.
 
 %description apidocs -l pl.UTF-8
-Dokumentacja API %{module}.
+Dokumentacja API modułu Pythona %{module}.
 
 %prep
-%setup -q -n %{module}-%{version}
+%setup -q -n %{pypi_name}-%{version}
 
 # fix #!/usr/bin/env python -> #!/usr/bin/python:
 #%{__sed} -i -e '1s,^#!.*python,#!%{__python},' %{name}.py
 
-# setup copy of source in py3 dir
-set -- *
-install -d py3
-cp -a "$@" py3
-
 %build
 %if %{with python2}
-# CC/CFLAGS is only for arch packages - remove on noarch packages
-CC="%{__cc}" \
-CFLAGS="%{rpmcppflags} %{rpmcflags}" \
-%{__python} setup.py build --build-base build-2 %{?with_tests:test}
+%py_build
+# deprecated target, but sometimes still used: %{?with_tests:test}
+
+%if %{with tests}
+# use explicit plugins list for reliable builds (delete PYTEST_PLUGINS if empty)
+PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
+PYTEST_PLUGINS= \
+%{__python} -m pytest ...
+%endif
 %endif
 
 %if %{with python3}
-# CC/CFLAGS is only for arch packages - remove on noarch packages
-CC="%{__cc}" \
-CFLAGS="%{rpmcppflags} %{rpmcflags}" \
-%{__python3} setup.py build --build-base build-3 %{?with_tests:test}
+%py3_build
+# deprecated target, but sometimes still used: %{?with_tests:test}
+
+%if %{with tests}
+# use explicit plugins list for reliable builds (delete PYTEST_PLUGINS if empty)
+PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
+PYTEST_PLUGINS= \
+%{__python3} -m pytest ...
+%endif
 %endif
 
 %if %{with doc}
-cd docs
-%{__make} -j1 html
-rm -rf _build/html/_sources
+%{__make} -C docs html
+# if particular python version required - append:
+#      SPHINXBUILD=sphinx-build-3
+rm -rf docs/_build/html/_sources
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
-%{__python} setup.py \
-       build --build-base build-2 \
-       install --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py_install
+
+%if %{with enable_if_package_uses_non_standard_setup_py}
+# when files are installed in other way that standard 'setup.py
+# they need to be (re-)compiled
+# change %{py_sitedir} to %{py_sitescriptdir} for 'noarch' packages!
+%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
+%py_comp $RPM_BUILD_ROOT%{py_sitedir}
+%endif
 
 %py_postclean
 %endif
 
 %if %{with python3}
-%{__python3} setup.py \
-       build --build-base build-3 \
-       install --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py3_install
 %endif
 
-# in case there are examples provided
+%if %{with enable_if_there_are_examples_provided_in_package}
 %if %{with python2}
-install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
-cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+install -d $RPM_BUILD_ROOT%{_examplesdir}/python-%{module}-%{version}
+cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python-%{module}-%{version}
+find $RPM_BUILD_ROOT%{_examplesdir}/python-%{module}-%{version} -name '*.py' \
+       | xargs sed -i '1s|^#!.*python\b|#!%{__python}|'
 %endif
 %if %{with python3}
 install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
@@ -130,13 +153,7 @@ cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
 find $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version} -name '*.py' \
        | xargs sed -i '1s|^#!.*python\b|#!%{__python3}|'
 %endif
-
-# when files are installed in other way that standard 'setup.py
-# they need to be (re-)compiled
-## change %{py_sitedir} to %{py_sitescriptdir} for 'noarch' packages!
-#%%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
-#%%py_comp $RPM_BUILD_ROOT%{py_sitedir}
-#%%py_postclean
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -145,21 +162,17 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
-# change %{py_sitedir} to %{py_sitescriptdir} for 'noarch' packages!
-%{py_sitedir}/*.py[co]
-%attr(755,root,root) %{py_sitedir}/*.so
-%if "%{py_ver}" > "2.4"
-%{py_sitedir}/%{module}-%{version}-py*.egg-info
-%endif
-%{_examplesdir}/%{name}-%{version}
+%{py_sitescriptdir}/%{module}
+%{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
+%{_examplesdir}/python-%{module}-%{version}
 %endif
 
 %if %{with python3}
 %files -n python3-%{module}
 %defattr(644,root,root,755)
-%doc AUTHORS CHANGES LICENSE
+# copy %doc from python2 package here
 %{py3_sitescriptdir}/%{module}
-%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
+%{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
 %{_examplesdir}/python3-%{module}-%{version}
 %endif
 
This page took 0.133406 seconds and 4 git commands to generate.