]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - python.spec
- use explicit PYTEST_PLUGINS lists for reliable tests (not failing if some conflicti...
[projects/template-specs.git] / python.spec
index 2aeed084b1654da741901773f8a4963800f8e361..894f4858abf6944e5b8f49122312ec07ddb1551f 100644 (file)
@@ -1,5 +1,6 @@
 #
-# This is template for pure python modules (noarch)
+# This is template for pure python2/python3 modules (noarch)
+# use template-specs/python3.spec for python3 only noarch packages
 # use template-specs/python-ext.spec for binary python packages
 #
 #
@@ -29,20 +30,29 @@ Source0:    https://files.pythonhosted.org/packages/source/P/PYPI_NAME/%{pypi_name}
 # Source0-md5: -
 #URL:          https://pypi.org/project/PYPI_NAME/
 URL:           -
-BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.714
 %if %{with python2}
-BuildRequires: python-modules
+BuildRequires: python-modules >= 1:2.5
 BuildRequires: python-setuptools
+%if %{with tests}
+#BuildRequires:        python-
+%endif
 %endif
 %if %{with python3}
-BuildRequires: python3-modules
+BuildRequires: python3-modules >= 1:3.2
 BuildRequires: python3-setuptools
+%if %{with tests}
+#BuildRequires:        python3-
 %endif
+%endif
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.714
 # when using /usr/bin/env or other in-place substitutions
 #BuildRequires:        sed >= 4.0
+%if %{with doc}
+BuildRequires: sphinx-pdg # -2 or -3
+%endif
 # replace with other requires if defined in setup.py
-Requires:      python-modules
+Requires:      python-modules >= 1:2.5
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -54,7 +64,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Summary:       -
 Summary(pl.UTF-8):     -
 Group:         Libraries/Python
-Requires:      python3-modules
+Requires:      python3-modules >= 1:3.2
 
 %description -n python3-%{module}
 
@@ -79,17 +89,34 @@ Dokumentacja API moduĊ‚u Pythona %{module}.
 
 %build
 %if %{with python2}
-%py_build %{?with_tests:test}
+%py_build
+# deprecated target, but sometimes still used: %{?with_tests:test}
+
+%if %{with tests}
+# use explicit plugins list for reliable builds (delete PYTEST_PLUGINS if empty)
+PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
+PYTEST_PLUGINS= \
+%{__python} -m pytest ...
+%endif
 %endif
 
 %if %{with python3}
-%py3_build %{?with_tests:test}
+%py3_build
+# deprecated target, but sometimes still used: %{?with_tests:test}
+
+%if %{with tests}
+# use explicit plugins list for reliable builds (delete PYTEST_PLUGINS if empty)
+PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
+PYTEST_PLUGINS= \
+%{__python3} -m pytest ...
+%endif
 %endif
 
 %if %{with doc}
-cd docs
-%{__make} -j1 html
-rm -rf _build/html/_sources
+%{__make} -C docs html
+# if particular python version required - append:
+#      SPHINXBUILD=sphinx-build-3
+rm -rf docs/_build/html/_sources
 %endif
 
 %install
@@ -98,11 +125,13 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %py_install
 
+%if %{with enable_if_package_uses_non_standard_setup_py}
 # when files are installed in other way that standard 'setup.py
 # they need to be (re-)compiled
 # change %{py_sitedir} to %{py_sitescriptdir} for 'noarch' packages!
 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
+%endif
 
 %py_postclean
 %endif
@@ -111,7 +140,7 @@ rm -rf $RPM_BUILD_ROOT
 %py3_install
 %endif
 
-# in case there are examples provided
+%if %{with enable_if_there_are_examples_provided_in_package}
 %if %{with python2}
 install -d $RPM_BUILD_ROOT%{_examplesdir}/python-%{module}-%{version}
 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python-%{module}-%{version}
@@ -124,6 +153,7 @@ cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
 find $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version} -name '*.py' \
        | xargs sed -i '1s|^#!.*python\b|#!%{__python3}|'
 %endif
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -140,7 +170,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python3}
 %files -n python3-%{module}
 %defattr(644,root,root,755)
-%doc AUTHORS CHANGES LICENSE
+# copy %doc from python2 package here
 %{py3_sitescriptdir}/%{module}
 %{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
 %{_examplesdir}/python3-%{module}-%{version}
This page took 0.0642 seconds and 4 git commands to generate.