]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - python.spec
examples
[projects/template-specs.git] / python.spec
index ddc9dd6a2f0e64efd85a386cde01c2ce751a108a..32fea52122c2be2cb5dd7e3e9d215918417de45b 100644 (file)
@@ -1,5 +1,10 @@
 #
+# This is template for pure python modules (noarch)
+# use template-specs/python-ext.spec for binary python packages
+#
+#
 # Conditional build:
+%bcond_without doc     # don't build doc
 %bcond_without tests   # do not perform "make test"
 %bcond_without python2 # CPython 2.x module
 %bcond_without python3 # CPython 3.x module
 %define        module  template
 Summary:       -
 Summary(pl.UTF-8):     -
-# Name must match the python module/package name (as in 'import' statement)
+# Name must match the python module/package name (as on pypi or in 'import' statement)
 Name:          python-%{module}
 Version:       _
 Release:       0.1
 License:       - (enter GPL/GPL v2/GPL v3/LGPL/BSD/BSD-like/other license name here)
 Group:         Libraries/Python
-Source0:       %{name}-%{version}.tar.gz
+Source0:       https://pypi.python.org/packages/source/M/MODULE/%{module}-%{version}.tar.gz
 # Source0-md5: -
+#URL:          https://pypi.python.org/pypi/MODULE
 URL:           -
-# remove BR: python-devel for 'noarch' packages.
 BuildRequires: rpm-pythonprov
-# if py_postclean is used
-BuildRequires: rpmbuild(macros) >= 1.219
-# when using /usr/bin/env or other in-place substitutions
-#BuildRequires:        sed >= 4.0
+# for the py_build, py_install macros
+BuildRequires: rpmbuild(macros) >= 1.714
 %if %{with python2}
-BuildRequires: python-devel
-BuildRequires: python-distribute
+BuildRequires: python-modules
+#BuildRequires:        python-setuptools
 %endif
 %if %{with python3}
-BuildRequires: python3-devel
-BuildRequires: python3-distribute
 BuildRequires: python3-modules
+#BuildRequires:        python3-setuptools
 %endif
-#Requires:             python-libs
-Requires:              python-modules
-#BuildArch:    noarch
+# when using /usr/bin/env or other in-place substitutions
+#BuildRequires:        sed >= 4.0
+# replace with other requires if defined in setup.py
+Requires:      python-modules
+BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -44,6 +48,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Summary:       -
 Summary(pl.UTF-8):     -
 Group:         Libraries/Python
+Requires:      python3-modules
 
 %description -n python3-%{module}
 
@@ -68,17 +73,11 @@ Dokumentacja API %{module}.
 
 %build
 %if %{with python2}
-# CC/CFLAGS is only for arch packages - remove on noarch packages
-CC="%{__cc}" \
-CFLAGS="%{rpmcflags}" \
-%{__python} setup.py build --build-base build-2 %{?with_tests:test}
+%py_build %{?with_tests:test}
 %endif
 
 %if %{with python3}
-# CC/CFLAGS is only for arch packages - remove on noarch packages
-CC="%{__cc}" \
-CFLAGS="%{rpmcflags}" \
-%{__python3} setup.py build --build-base build-3 %{?with_tests:test}
+%py3_build %{?with_tests:test}
 %endif
 
 %if %{with doc}
@@ -91,21 +90,13 @@ rm -rf _build/html/_sources
 rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
-%{__python} setup.py \
-       build --build-base build-2 \
-       install --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py_install
 
 %py_postclean
 %endif
 
 %if %{with python3}
-%{__python3} setup.py \
-       build --build-base build-3 \
-       install --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py3_install
 %endif
 
 # in case there are examples provided
@@ -120,13 +111,6 @@ find $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version} -name '*.py' \
        | xargs sed -i '1s|^#!.*python\b|#!%{__python3}|'
 %endif
 
-# when files are installed in other way that standard 'setup.py
-# they need to be (re-)compiled
-## change %{py_sitedir} to %{py_sitescriptdir} for 'noarch' packages!
-#%%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
-#%%py_comp $RPM_BUILD_ROOT%{py_sitedir}
-#%%py_postclean
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -134,11 +118,9 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
-# change %{py_sitedir} to %{py_sitescriptdir} for 'noarch' packages!
-%{py_sitedir}/*.py[co]
-%attr(755,root,root) %{py_sitedir}/*.so
+%{py_sitescriptdir}/%{module}
 %if "%{py_ver}" > "2.4"
-%{py_sitedir}/TEMPLATE-*.egg-info
+%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
 %endif
 %{_examplesdir}/%{name}-%{version}
 %endif
This page took 0.065756 seconds and 4 git commands to generate.