]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - python.spec
better arch selection for ocaml_opt bcond
[projects/template-specs.git] / python.spec
index ba54006e29cfcef8613f1b3ecdb0d11932a0ee01..09fa6184067d5fb2f64a757b59329150e7e9b752 100644 (file)
@@ -1,6 +1,8 @@
 #
 # Conditional build:
+%bcond_without doc             # don't build doc
 %bcond_without tests   # do not perform "make test"
+%bcond_without python2 # CPython 2.x module
 %bcond_without python3 # CPython 3.x module
 
 %define        module  template
@@ -16,20 +18,24 @@ Source0:    %{name}-%{version}.tar.gz
 # Source0-md5: -
 URL:           -
 # remove BR: python-devel for 'noarch' packages.
-BuildRequires: python-devel
-BuildRequires: python-distribute
 BuildRequires: rpm-pythonprov
 # if py_postclean is used
 BuildRequires: rpmbuild(macros) >= 1.219
+# when using /usr/bin/env or other in-place substitutions
+#BuildRequires:        sed >= 4.0
 # when python3 present
-BuildRequires: sed >= 4.0
+%if %{with python2}
+BuildRequires: python-devel
+BuildRequires: python-setuptools
+%endif
 %if %{with python3}
 BuildRequires: python3-devel
-BuildRequires: python3-distribute
 BuildRequires: python3-modules
+BuildRequires: python3-setuptools
 %endif
+# Below Rs only work for main package (python2)
 #Requires:             python-libs
-Requires:              python-modules
+Requires:      python-modules
 #BuildArch:    noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -37,15 +43,25 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description -l pl.UTF-8
 
-%package apidoc
+%package -n python3-%{module}
+Summary:       -
+Summary(pl.UTF-8):     -
+Group:         Libraries/Python
+Requires:      python3-modules
+
+%description -n python3-%{module}
+
+%description -n python3-%{module} -l pl.UTF-8
+
+%package apidocs
 Summary:       %{module} API documentation
 Summary(pl.UTF-8):     Dokumentacja API %{module}
 Group:         Documentation
 
-%description apidoc
+%description apidocs
 API documentation for %{module}.
 
-%description apidoc -l pl.UTF-8
+%description apidocs -l pl.UTF-8
 Dokumentacja API %{module}.
 
 %prep
@@ -54,38 +70,24 @@ Dokumentacja API %{module}.
 # fix #!/usr/bin/env python -> #!/usr/bin/python:
 #%{__sed} -i -e '1s,^#!.*python,#!%{__python},' %{name}.py
 
-%if %{with python3}
-rm -rf build-3
+# setup copy of source in py3 dir
 set -- *
-install -d build-3
-cp -a "$@" build-3
-find build-3 -name '*.py' | xargs sed -i '1s|^#!python|#!%{__python3}|'
-%endif
+install -d py3
+cp -a "$@" py3
 
 %build
 %if %{with python2}
-%{__python} setup.py build --build-base build-2
-%endif
-%if %{with python3}
-%{__python3} setup.py build --build-base build-3
-%endif
-
 # CC/CFLAGS is only for arch packages - remove on noarch packages
 CC="%{__cc}" \
-CFLAGS="%{rpmcflags}" \
-%{__python} setup.py build
-%{__python} setup.py \
-       build -b build-2
-
-%{?with_tests:%{__python} setup.py test}
+CFLAGS="%{rpmcppflags} %{rpmcflags}" \
+%{__python} setup.py build --build-base build-2 %{?with_tests:test}
+%endif
 
 %if %{with python3}
-%{__python3} setup.py \
-       build -b build-3
-
-%if %{with tests}
-%{__python3} setup.py test
-%endif
+# CC/CFLAGS is only for arch packages - remove on noarch packages
+CC="%{__cc}" \
+CFLAGS="%{rpmcppflags} %{rpmcflags}" \
+%{__python3} setup.py build --build-base build-3 %{?with_tests:test}
 %endif
 
 %if %{with doc}
@@ -96,52 +98,48 @@ rm -rf _build/html/_sources
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__python} setup.py install \
-       --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
-
-%{__python} -- setup.py \
-       build -b build-2 \
-       install \
-       --root=$RPM_BUILD_ROOT \
-       --optimize=2
 
 %if %{with python2}
 %{__python} setup.py \
        build --build-base build-2 \
-       install \
-       --root=$RPM_BUILD_ROOT \
-       --optimize=2
+       install --skip-build \
+       --optimize=2 \
+       --root=$RPM_BUILD_ROOT
 
 %py_postclean
 %endif
 
-%{__python3} -- setup.py \
-       build -b build-3 \
-       install \
-       --root=$RPM_BUILD_ROOT \
-       --optimize=2
-
 %if %{with python3}
 %{__python3} setup.py \
        build --build-base build-3 \
-       install \
-       --root=$RPM_BUILD_ROOT \
-       --optimize=2
+       install --skip-build \
+       --optimize=2 \
+       --root=$RPM_BUILD_ROOT
 %endif
 
+# in case there are examples provided
+%if %{with python2}
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+%endif
+%if %{with python3}
+install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
+cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
+find $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version} -name '*.py' \
+       | xargs sed -i '1s|^#!.*python\b|#!%{__python3}|'
+%endif
 
-# change %{py_sitedir} to %{py_sitescriptdir} for 'noarch' packages!
-%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
-%py_comp $RPM_BUILD_ROOT%{py_sitedir}
-%py_postclean
+# when files are installed in other way that standard 'setup.py
+# they need to be (re-)compiled
+## change %{py_sitedir} to %{py_sitescriptdir} for 'noarch' packages!
+#%%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
+#%%py_comp $RPM_BUILD_ROOT%{py_sitedir}
+#%%py_postclean
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%if %{with python2}
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
@@ -149,16 +147,9 @@ rm -rf $RPM_BUILD_ROOT
 %{py_sitedir}/*.py[co]
 %attr(755,root,root) %{py_sitedir}/*.so
 %if "%{py_ver}" > "2.4"
-%{py_sitedir}/TEMPLATE-*.egg-info
+%{py_sitedir}/%{module}-%{version}-py*.egg-info
 %endif
 %{_examplesdir}/%{name}-%{version}
-
-%if %{with python2}
-%files
-%defattr(644,root,root,755)
-%doc AUTHORS CHANGES LICENSE
-%{py_sitescriptdir}/%{module}
-%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
 %endif
 
 %if %{with python3}
@@ -167,10 +158,11 @@ rm -rf $RPM_BUILD_ROOT
 %doc AUTHORS CHANGES LICENSE
 %{py3_sitescriptdir}/%{module}
 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
+%{_examplesdir}/python3-%{module}-%{version}
 %endif
 
 %if %{with doc}
-%files apidoc
+%files apidocs
 %defattr(644,root,root,755)
 %doc docs/_build/html/*
 %endif
This page took 0.038124 seconds and 4 git commands to generate.