]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - python.spec
better arch selection for ocaml_opt bcond
[projects/template-specs.git] / python.spec
index 7936c5d57e12c084b45e749cc16963d30d6c521a..09fa6184067d5fb2f64a757b59329150e7e9b752 100644 (file)
@@ -26,16 +26,16 @@ BuildRequires:      rpmbuild(macros) >= 1.219
 # when python3 present
 %if %{with python2}
 BuildRequires: python-devel
-BuildRequires: python-setuptools > 7.0
+BuildRequires: python-setuptools
 %endif
 %if %{with python3}
 BuildRequires: python3-devel
-BuildRequires: python3-setuptools > 7.0
 BuildRequires: python3-modules
+BuildRequires: python3-setuptools
 %endif
 # Below Rs only work for main package (python2)
 #Requires:             python-libs
-Requires:              python-modules
+Requires:      python-modules
 #BuildArch:    noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -47,7 +47,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Summary:       -
 Summary(pl.UTF-8):     -
 Group:         Libraries/Python
-Requires:              python3-modules
+Requires:      python3-modules
 
 %description -n python3-%{module}
 
@@ -70,6 +70,11 @@ Dokumentacja API %{module}.
 # fix #!/usr/bin/env python -> #!/usr/bin/python:
 #%{__sed} -i -e '1s,^#!.*python,#!%{__python},' %{name}.py
 
+# setup copy of source in py3 dir
+set -- *
+install -d py3
+cp -a "$@" py3
+
 %build
 %if %{with python2}
 # CC/CFLAGS is only for arch packages - remove on noarch packages
This page took 0.052208 seconds and 4 git commands to generate.