]> git.pld-linux.org Git - packages/python-pyudev.git/blobdiff - python-pyudev.spec
BR: rpmbuild(macros) >= 1.710
[packages/python-pyudev.git] / python-pyudev.spec
index ac20ae9f830cddb3533073d4eba0d69defc18d43..9823b6721bf9b5cff5498fb3b50f85eca700767c 100644 (file)
@@ -1,20 +1,20 @@
 #
 # Conditional build:
-%bcond_without doc     # HTML documentation build
-%bcond_without tests   # do not perform "make test"
-%bcond_without  python2         # Python 2.x module
-%bcond_without  python3         # Python 3.x module
+%bcond_without doc             # HTML documentation build
+%bcond_without tests           # do not perform "make test"
+%bcond_without python2         # Python 2.x module
+%bcond_without python3         # Python 3.x module
 #
 %define        module  pyudev
 Summary:       Pure Python binding for libudev
 Summary(pl.UTF-8):     Czysto pythonowe wiązanie do libudev
 Name:          python-%{module}
-Version:       0.16.1
-Release:       4
+Version:       0.17
+Release:       2
 License:       LGPL v2.1+
 Group:         Development/Languages/Python
 Source0:       http://pypi.python.org/packages/source/p/pyudev/%{module}-%{version}.tar.gz
-# Source0-md5: 4034de584b6d9efcbfc590a047c63285
+# Source0-md5: 0450afde50383538a987d16450853fb1
 #Source1:      http://docs.python.org/2/objects.inv#/python-objects.inv
 Source1:       python-objects.inv
 # Source1-md5: ad9c579afde0743e007b472cff7f1364
@@ -26,8 +26,15 @@ Source3:     pyside-objects.inv
 # Source3-md5: 8cc5c1ff0bb5ef9f4e9968c9b4a01984
 Patch0:                %{name}-offline.patch
 URL:           http://pyudev.readthedocs.org/
+BuildRequires: rpmbuild(macros) >= 1.710
+%if %{with python2}
 BuildRequires: python-devel >= 1:2.6
-BuildRequires: python-distribute
+BuildRequires: python-setuptools
+%endif
+%if %{with python3}
+BuildRequires: python3-devel >= 1:3.2
+BuildRequires: python3-setuptools
+%endif
 BuildRequires: rpm-pythonprov
 %if %{with doc}
 # for tests 1.0b1 is required, but for docs generation 0.8 is sufficient
@@ -62,6 +69,7 @@ użyciem wątków albo wewnątrz pętli zdarzeń Qt, GLiba czy wxPythona.
 Summary:       Pure Python binding for libudev
 Summary(pl.UTF-8):     Czysto pythonowe wiązanie do libudev
 Group:         Development/Languages/Python
+Requires:      python3-modules
 
 %description -n python3-%{module}
 pyudev is a LGPL licensed, pure Python binding for libudev, the device
@@ -79,7 +87,6 @@ urządzenia, odpytywać o właściwości i atrybuty urządzeń oraz
 monitorować urządzenia, włącznie z asynchronicznym monitorowaniem z
 użyciem wątków albo wewnątrz pętli zdarzeń Qt, GLiba czy wxPythona.
 
-
 %prep
 %setup -q -n %{module}-%{version}
 %patch0 -p1
@@ -88,32 +95,28 @@ cp -p %{SOURCE1} %{SOURCE2} %{SOURCE3} doc
 
 %build
 %if %{with python2}
-%{__python} setup.py build --build-base build-2 %{?with_tests:test}
+%py_build %{?with_tests:test}
 %endif
 
 %if %{with python3}
-%{__python3} setup.py build --build-base build-3 %{?with_tests:test}
+%py3_build %{?with_tests:test}
 %endif
 
 %if %{with doc}
-sphinx-build -W -b html -d doc/_doctrees doc doc/html
+sphinx-build -b html -d doc/_doctrees doc doc/html
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
-%{__python} setup.py \
-       build --build-base build-2 \
-       install --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py_install
+
+%{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/tests
 %endif
 %if %{with python3}
-%{__python3} setup.py \
-       build --build-base build-3 \
-       install --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py3_install
+
+%{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/tests
 %endif
 
 %clean
This page took 0.064088 seconds and 4 git commands to generate.