]> git.pld-linux.org Git - packages/python-psycopg2.git/blobdiff - python-psycopg2.spec
- up to 2.0.8
[packages/python-psycopg2.git] / python-psycopg2.spec
index 0492dc258fec1af1d568c00b502d0cdecff95fae..abb0e3f322cbfc9cba88672198d094194f01b09c 100644 (file)
@@ -1,31 +1,41 @@
 #
+# Conditional build:
+%bcond_with mx # build with egenix mx datetime support
+#
 # todo:
 # - zope adapter
 # - lib64 patch
 #
+# WARNING! Please note, that mx.DateTime is optional. You can use
+# mx.DateTime with your apps, but other see datetime datatype more
+# suitable for date and time as it is standard in Python.
 
 %define        module  psycopg2
 
 Summary:       psycopg is a PostgreSQL database adapter for Python
-Summary(pl):   psycopg jest przeznaczonym dla Pythona interfejsem do bazy PostgreSQL
+Summary(pl.UTF-8):     psycopg jest przeznaczonym dla Pythona interfejsem do bazy PostgreSQL
 Name:          python-%{module}
-Version:       2.0.5.1
-Release:       4
+Version:       2.0.8
+Release:       1
 License:       GPL
 Group:         Libraries/Python
 Source0:       http://initd.org/pub/software/psycopg/%{module}-%{version}.tar.gz
-# Source0-md5: 052e4b97dab47708fdcdc36ffb25af66
+# Source0-md5: 2c31827878d436b0c89e777989ff55af
 #Patch0:               %{name}-lib64.patch
 URL:           http://www.initd.org/software/psycopg/
 BuildRequires: autoconf
 BuildRequires: postgresql-backend-devel
 BuildRequires: postgresql-devel
 BuildRequires: python-devel
-BuildRequires: python-mx-DateTime-devel
 BuildRequires: rpm-pythonprov
+%if %{with mx}
+BuildRequires: python-mx-DateTime-devel
+Requires:      python-mx-DateTime
+%else
+BuildConflicts:        python-mx-DateTime
+%endif
 Requires:      postgresql-libs
 %pyrequires_eq python-modules
-Requires:      python-mx-DateTime
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define zope_subname ZPsycopgDA
@@ -37,16 +47,16 @@ with the aim of being very small and fast, and stable as a rock. The
 main advantages of psycopg are that it supports the full Python
 DBAPI-2.0 and being thread safe at level 2.
 
-%description -l pl
+%description -l pl.UTF-8
 psycopg jest przeznaczonym dla Pythona interfejsem do bazy danych
-PostgreSQL (tak jak pygresql i popy). Zosta³ zakodowany od pocz±tku
-z za³o¿eniem ¿e ma byæ bardzo ma³y, szybki i stabilny. G³ówna zalet±
-psycopg jest, ¿e w jest pe³ni zgodny z standardem DBAPI-2.0 i jest
+PostgreSQL (tak jak pygresql i popy). Został zakodowany od początku
+z założeniem że ma być bardzo mały, szybki i stabilny. Główna zaletą
+psycopg jest, że w jest pełni zgodny z standardem DBAPI-2.0 i jest
 'thread safe' na poziomie 2.
 
 %package -n Zope-%{zope_subname}
 Summary:       Zope PostgreSQL database adapter
-Summary(pl):   Interfejs bazy danych PostgreSQL do Zope
+Summary(pl.UTF-8):     Interfejs bazy danych PostgreSQL do Zope
 Group:         Development/Languages/Python
 Requires:      %{name} = %{version}-%{release}
 Requires:      Zope
@@ -54,7 +64,7 @@ Requires:     Zope
 %description -n Zope-%{zope_subname}
 Zope PostgreSQL database adapter.
 
-%description -n Zope-%{zope_subname} -l pl
+%description -n Zope-%{zope_subname} -l pl.UTF-8
 Interfejs bazy danych PostgreSQL do Zope.
 
 %prep
@@ -103,6 +113,7 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{py_sitedir}/%{module}
 %attr(755,root,root) %{py_sitedir}/%{module}/*.so
 %{py_sitedir}/%{module}/*.py[co]
+%{py_sitedir}/*.egg-info
 
 #%files -n Zope-%{zope_subname}
 #%defattr(644,root,root,755)
This page took 0.079618 seconds and 4 git commands to generate.