]> git.pld-linux.org Git - packages/python-fuse.git/blobdiff - python-fuse.spec
BR: rpmbuild(macros) >= 1.710
[packages/python-fuse.git] / python-fuse.spec
index f6cc7b928abd4fc47d262ee58541d07530e2ff10..34832671bd3d178d826d91c2cd743bb677193e07 100644 (file)
@@ -1,23 +1,20 @@
 %define        module  fuse
-
-# lacking a proper versioning scheme, we use the latest changelog entry date
-%define                _snap   20070119
-
 Summary:       Python interface to FUSE (Filesystem in USErspace)
 Summary(pl.UTF-8):     Pythonowy interfejs do FUSE (systemu plików w przestrzeni użytkownika)
 Name:          python-%{module}
-Version:       0.1
-Release:       0.%{_snap}.1
-License:       GPL
+Version:       0.2.1
+Release:       3
+License:       LGPL v2.1
 Group:         Development/Languages/Python
-Source0:       http://richard.jones.name/google-hacks/gmail-filesystem/%{module}-python.tar.gz
-# Source0-md5: 7d2d48b10d7e3ec3b1d04b3efbd6c955
-URL:           http://richard.jones.name/google-hacks/gmail-filesystem/gmail-filesystem.html
-BuildRequires: python-devel
+Source0:       http://downloads.sourceforge.net/fuse/fuse-python-%{version}.tar.gz
+# Source0-md5: 9d9c5c2311ac04291ce822dfece108f8
+URL:           http://sourceforge.net/apps/mediawiki/fuse/index.php?title=FusePython
 BuildRequires: libfuse-devel
-BuildRequires: rpmbuild(macros) >= 1.219
-%pyrequires_eq python-modules
-BuildArch:     noarch
+BuildRequires: pkgconfig
+BuildRequires: python-devel >= 1:2.5
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.710
+Requires:      python-modules
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -28,20 +25,17 @@ Pythonowy interfejs do FUSE (Filesystem in USErspace - systemu plików
 w przestrzeni użytkownika).
 
 %prep
-%setup -q -n %{module}-python
+%setup -q -n fuse-python-%{version}
 
 %build
-python setup.py build
+%py_build
 
 %install
 rm -rf $RPM_BUILD_ROOT
+%py_install
 
-python setup.py install \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
-
-%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
-%py_comp $RPM_BUILD_ROOT%{py_sitedir}
+install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}-%{release}
+cp -p example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}-%{release}
 %py_postclean
 
 %clean
@@ -49,6 +43,10 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog README
-%{py_sitedir}/*.py[co]
-%attr(755,root,root) %{py_sitedir}/*.so
+%doc AUTHORS Changelog FAQ README*
+%{py_sitedir}/fuse.py[co]
+%dir %{py_sitedir}/fuseparts
+%{py_sitedir}/fuseparts/*.py[co]
+%attr(755,root,root) %{py_sitedir}/fuseparts/*.so
+%{py_sitedir}/fuse_python-%{version}-py*.egg-info
+%{_examplesdir}/%{name}-%{version}-%{release}
This page took 0.057482 seconds and 4 git commands to generate.