]> git.pld-linux.org Git - packages/python-fuse.git/blobdiff - python-fuse.spec
BR: rpmbuild(macros) >= 1.710
[packages/python-fuse.git] / python-fuse.spec
index 53a57533bfe176d76c8613914f391bdc39811705..34832671bd3d178d826d91c2cd743bb677193e07 100644 (file)
@@ -1,51 +1,52 @@
 %define        module  fuse
-
 Summary:       Python interface to FUSE (Filesystem in USErspace)
-Summary(pl):   Pythonowy interfejs do FUSE (systemu plików w przestrzeni u¿ytkownika)
+Summary(pl.UTF-8):     Pythonowy interfejs do FUSE (systemu plików w przestrzeni użytkownika)
 Name:          python-%{module}
-Version:       0.1
-Release:       0.1
-License:       GPL
+Version:       0.2.1
+Release:       3
+License:       LGPL v2.1
 Group:         Development/Languages/Python
-Source0:       http://richard.jones.name/google-hacks/gmail-filesystem/%{module}-python.tar.gz
-# Source0-md5: 932cd7f1997187245206385515865ffd
-# Source0-size:        14064
-URL:           http://richard.jones.name/google-hacks/gmail-filesystem/gmail-filesystem.html
-BuildRequires: python-devel
+Source0:       http://downloads.sourceforge.net/fuse/fuse-python-%{version}.tar.gz
+# Source0-md5: 9d9c5c2311ac04291ce822dfece108f8
+URL:           http://sourceforge.net/apps/mediawiki/fuse/index.php?title=FusePython
 BuildRequires: libfuse-devel
-%pyrequires_eq python-modules
-Requires:      libfuse
-Requires:      fusermount
-BuildArch:     noarch
+BuildRequires: pkgconfig
+BuildRequires: python-devel >= 1:2.5
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.710
+Requires:      python-modules
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 Python interface to FUSE (Filesystem in USErspace).
 
-%description -l pl
-Pythonowy interfejs do FUSE (Filesystem in USErspace - systemu plików
-w przestrzeni u¿ytkownika).
+%description -l pl.UTF-8
+Pythonowy interfejs do FUSE (Filesystem in USErspace - systemu plików
+w przestrzeni użytkownika).
 
 %prep
-%setup -q -n %{module}-python
+%setup -q -n fuse-python-%{version}
 
 %build
-%{py_comp} .
-%{py_ocomp} .
-%{__make}
+%py_build
 
 %install
 rm -rf $RPM_BUILD_ROOT
+%py_install
 
-install -d $RPM_BUILD_ROOT{%{py_sitedir},%{py_sitedir}}
-install fuse.py[co] $RPM_BUILD_ROOT%{py_sitedir}
-install _fusemodule.so $RPM_BUILD_ROOT%{py_sitedir}/_fusemodule.so
+install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}-%{release}
+cp -p example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}-%{release}
+%py_postclean
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README
-%{py_sitedir}/*.py[co]
-%attr(755,root,root) %{py_sitedir}/_fusemodule.so
+%doc AUTHORS Changelog FAQ README*
+%{py_sitedir}/fuse.py[co]
+%dir %{py_sitedir}/fuseparts
+%{py_sitedir}/fuseparts/*.py[co]
+%attr(755,root,root) %{py_sitedir}/fuseparts/*.so
+%{py_sitedir}/fuse_python-%{version}-py*.egg-info
+%{_examplesdir}/%{name}-%{version}-%{release}
This page took 0.054147 seconds and 4 git commands to generate.