]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - python-ext.spec
Add .tar.xz deps
[projects/template-specs.git] / python-ext.spec
index ea175793fe19042553f46000687afac33959d4cd..b85c697012d5e31da762f1304995fa2edee6da1e 100644 (file)
@@ -1,10 +1,11 @@
 #
-# This is template for python extension modules (including compiled C code)
+# This is template for python2/python3 extension modules (including compiled C code)
 # use template-specs/python.spec for pure python packages
+# use template-specs/python3-ext.spec for python3 only packages
 #
 # Conditional build:
-%bcond_without doc     # don't build doc
-%bcond_without tests   # do not perform "make test"
+%bcond_without doc     # API documentation
+%bcond_without tests   # unit tests
 %bcond_without python2 # CPython 2.x module
 %bcond_without python3 # CPython 3.x module
 
@@ -23,21 +24,32 @@ Source0:    https://files.pythonhosted.org/packages/source/M/MODULE/%{module}-%{ver
 # Source0-md5: -
 #URL:          https://pypi.org/project/MODULE/
 URL:           -
-BuildRequires: rpm-pythonprov
-# for the py_build, py_install macros
-BuildRequires: rpmbuild(macros) >= 1.714
 %if %{with python2}
-BuildRequires: python-devel
+BuildRequires: python-devel >= 1:2.5
 #BuildRequires:        python-setuptools
+%if %{with tests}
+#BuildRequires:        python-
+%endif
 %endif
 %if %{with python3}
-BuildRequires: python3-devel
+BuildRequires: python3-devel >= 1:3.2
 #BuildRequires:        python3-setuptools
+%if %{with tests}
+#BuildRequires:        python3-
 %endif
+%endif
+# if using noarch subpackage:
+#BuildRequires:        rpm-build >= 4.6
+BuildRequires: rpm-pythonprov
+# for the py_build, py_install macros
+BuildRequires: rpmbuild(macros) >= 1.714
 # when using /usr/bin/env or other in-place substitutions
 #BuildRequires:        sed >= 4.0
+%if %{with doc}
+BuildRequires: sphinx-pdg # -2 or -3
+%endif
 # replace with other requires if defined in setup.py
-Requires:      python-modules
+Requires:      python-modules >= 1:2.5
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -48,25 +60,23 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Summary:       -
 Summary(pl.UTF-8):     -
 Group:         Libraries/Python
-Requires:      python3-modules
+Requires:      python3-modules >= 1:3.2
 
 %description -n python3-%{module}
 
 %description -n python3-%{module} -l pl.UTF-8
 
 %package apidocs
-Summary:       %{module} API documentation
-Summary(pl.UTF-8):     Dokumentacja API %{module}
+Summary:       API documentation for Python %{module} module
+Summary(pl.UTF-8):     Dokumentacja API modułu Pythona %{module}
 Group:         Documentation
-%if "%{_rpmversion}" >= "4.6"
 BuildArch:     noarch
-%endif
 
 %description apidocs
-API documentation for %{module}.
+API documentation for Python %{module} module.
 
 %description apidocs -l pl.UTF-8
-Dokumentacja API %{module}.
+Dokumentacja API modułu Pythona %{module}.
 
 %prep
 %setup -q -n %{module}-%{version}
@@ -76,17 +86,28 @@ Dokumentacja API %{module}.
 
 %build
 %if %{with python2}
-%py_build %{?with_tests:test}
+%py_build
+# deprecated target, but sometimes still used: %{?with_tests:test}
+
+%if %{with tests}
+%{__python} -m pytest ...
+%endif
 %endif
 
 %if %{with python3}
-%py3_build %{?with_tests:test}
+%py3_build
+# deprecated target, but sometimes still used: %{?with_tests:test}
+
+%if %{with tests}
+%{__python3} -m pytest ...
+%endif
 %endif
 
 %if %{with doc}
-cd docs
-%{__make} -j1 html
-rm -rf _build/html/_sources
+%{__make} -C docs html
+# if particular python version required - append:
+#      SPHINXBUILD=sphinx-build-3
+rm -rf docs/_build/html/_sources
 %endif
 
 %install
@@ -102,6 +123,7 @@ rm -rf $RPM_BUILD_ROOT
 %py3_install
 %endif
 
+%if %{with enable_if_there_are_examples_provided_in_package}
 %if %{with python2}
 install -d $RPM_BUILD_ROOT%{_examplesdir}/python-%{module}-%{version}
 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python-%{module}-%{version}
@@ -114,6 +136,7 @@ cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
 find $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version} -name '*.py' \
        | xargs sed -i '1s|^#!.*python\b|#!%{__python3}|'
 %endif
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
This page took 0.070899 seconds and 4 git commands to generate.