]> git.pld-linux.org Git - packages/python-ethtool.git/blobdiff - python-ethtool.spec
- release 2 (by relup.sh)
[packages/python-ethtool.git] / python-ethtool.spec
index 492c5a8176afa6c438c044cbc07f9819da5d1d5c..0f4ad0777d7fa21c82851207d6646a06c53f3377 100644 (file)
@@ -1,28 +1,31 @@
 #
 # Conditional build:
 %bcond_without python2 # CPython 2.x module
-%bcond_with    python3 # CPython 3.x module (enable when useful - now scripts use python2 shebang)
+%bcond_without python3 # CPython 3.x module
 
 Summary:       Python 2 bindings to Ethernet settings
 Summary(pl.UTF-8):     Wiązania Pythona 2 do ustawień sieci Ethernet
 Name:          python-ethtool
-Version:       0.11
+Version:       0.14
 Release:       2
 License:       GPL v2
 Group:         Libraries/Python
-Source0:       https://fedorahosted.org/releases/p/y/python-ethtool/%{name}-%{version}.tar.bz2
-# Source0-md5: b505501d928debf69664b72fafa9d0c3
-URL:           https://fedorahosted.org/python-ethtool/
+Source0:       https://github.com/fedora-python/python-ethtool/archive/v%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: eaf26f7aedbb1c6e3f7e0b00787b552e
+URL:           https://github.com/fedora-python/python-ethtool
 BuildRequires: asciidoc
 BuildRequires: libnl-devel >= 3.2
+BuildRequires: pkgconfig
+%if %{with python2}
 BuildRequires: python-devel >= 2
 BuildRequires: python-modules >= 2
-BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.612
+%endif
 %if %{with python3}
 BuildRequires: python3-devel >= 1:3.2
 BuildRequires: python3-modules >= 1:3.2
 %endif
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.714
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -67,36 +70,42 @@ a2x -d manpage -f manpage man/pifconfig.8.asciidoc
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_sbindir}
+install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8}
 
 %if %{with python2}
 %py_install
 
-cp -p pethtool.py $RPM_BUILD_ROOT%{_sbindir}/pethtool
-cp -p pifconfig.py $RPM_BUILD_ROOT%{_sbindir}/pifconfig
+%{__mv} $RPM_BUILD_ROOT{%{_bindir}/pethtool,%{_sbindir}/pethtool2}
+%{__mv} $RPM_BUILD_ROOT{%{_bindir}/pifconfig,%{_sbindir}/pifconfig2}
 %endif
 
 %if %{with python3}
 %py3_install
+%{__mv} $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/pethtool
+%{__mv} $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/pifconfig
 %endif
 
+cp -p man/{pethtool,pifconfig}.8 $RPM_BUILD_ROOT%{_mandir}/man8
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_sbindir}/pethtool
-%attr(755,root,root) %{_sbindir}/pifconfig
-%attr(755,root,root) %{py_sitedir}/ethtool.so
-%if "%{py_ver}" > "2.4"
+%attr(755,root,root) %{_sbindir}/pethtool2
+%attr(755,root,root) %{_sbindir}/pifconfig2
 %{py_sitedir}/ethtool-%{version}-py*.egg-info
-%endif
+%attr(755,root,root) %{py_sitedir}/ethtool.so
 %endif
 
 %if %{with python3}
 %files -n python3-ethtool
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_sbindir}/pethtool
+%attr(755,root,root) %{_sbindir}/pifconfig
 %attr(755,root,root) %{py3_sitedir}/ethtool.cpython-*.so
 %{py3_sitedir}/ethtool-%{version}-py*.egg-info
+%{_mandir}/man8/pethtool.8*
+%{_mandir}/man8/pifconfig.8*
 %endif
This page took 0.069174 seconds and 4 git commands to generate.