]> git.pld-linux.org Git - packages/python-egenix-mx-base.git/blobdiff - python-egenix-mx-base.spec
- fixed descriptions and summaries of mx-DateTime-devel subpackage
[packages/python-egenix-mx-base.git] / python-egenix-mx-base.spec
index 4223e0daa87e8166f36d8bcdaf923e22e89ab899..f8e12e08efd0e009b2044cc25db2811b2c233b3e 100644 (file)
@@ -1,25 +1,21 @@
 %include       /usr/lib/rpm/macros.python
 
-%define module egenix-mx-base
-%define mxdir %{py_sitedir}/mx
+%define                module egenix-mx-base
+%define                mxdir %{py_sitedir}/mx
 
 Summary:       eGenix mx-Extensions for Python
 Summary(pl):   eGenix mx-Extensions dla jêzyka Python
 Name:          python-%{module}
-Version:       2.0.3
+Version:       2.0.4
 Release:       1
 License:       distributable
-Group:         Development/Languages/Python
-Group(de):     Entwicklung/Sprachen/Python
-Group(es):     Desarrollo/Lenguages/Python
-Group(fr):     Development/Langues/Python
-Group(pl):     Programowanie/Jêzyki/Python
+Group:         Libraries/Python
 Source0:       http://www.lemburg.com/python/%{module}-%{version}.tar.gz
 URL:           http://www.lemburg.com/python/eGenix-mx-Extensions.html
-BuildRequires: python-devel >= 2.2
-BuildRequires: python-modules >= 2.2
+BuildRequires: python-devel >= 2.2.1
+BuildRequires: python-modules >= 2.2.1
 BuildRequires: rpm-pythonprov
-%requires_eq   python
+%pyrequires_eq python
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -40,12 +36,8 @@ Ten pakiet zawiera podstawowe modu
 %package -n python-mx-DateTime
 Summary:       Date and time Python extension
 Summary(pl):   Obiekty daty i czasu dla jêzyka Python
-Group:         Development/Languages/Python
-Group(de):     Entwicklung/Sprachen/Python
-Group(es):     Desarrollo/Lenguages/Python
-Group(fr):     Development/Langues/Python
-Group(pl):     Programowanie/Jêzyki/Python
-%requires_eq   python
+Group:         Libraries/Python
+%pyrequires_eq python
 Requires:      python-%{module} = %{version}
 
 %description -n python-mx-DateTime
@@ -67,7 +59,7 @@ build upon. This is especially interesting for database applications
 which often have to deal with date/time values (the mxODBC package is
 one example of an extension using this interface).
 
-%description -l pl -n python-mx-DateTime
+%description -n python-mx-DateTime -l pl
 mxDateTime jest pakietem modu³ów, które definiuj± trzy nowe klasy -
 DateTime, DateTimeDelta oraz RelativeDateTime. Umo¿liwiaj± one
 przechowywanie oraz operowanie na dacie i czasie w bardziej naturalny
@@ -86,15 +78,23 @@ innych rozszerze
 interesuj±ca w przypadku aplikacji bazodanowych, które operuj± na
 dacie i czasie.
 
+%package -n python-mx-DateTime-devel
+Summary:       Headers for date and time Python extension
+Summary(pl):   Nag³ówki modu³ów daty i czasu
+Group:         Libraries/Python
+Requires:      python-mx-DateTime = %{version}
+
+%description -n python-mx-DateTime-devel
+Headers for date and time Python extension.
+
+%description -n python-mx-DateTime-devel -l pl
+Nag³ówki dla modu³ów daty i czasu.
+
 %package -n python-mx-TextTools
 Summary:       Efficient text manipulation extensions for Python
 Summary(pl):   Wydajne manipulowanie tekstem w jêzyku Python
-Group:         Development/Languages/Python
-Group(de):     Entwicklung/Sprachen/Python
-Group(es):     Desarrollo/Lenguages/Python
-Group(fr):     Development/Langues/Python
-Group(pl):     Programowanie/Jêzyki/Python
-%requires_eq   python
+Group:         Libraries/Python
+%pyrequires_eq python
 Requires:      python-%{module} = %{version}
 
 %description -n python-mx-TextTools
@@ -111,7 +111,7 @@ Applications include parsing structured text, finding and extracting
 text (either exact or using translation tables) and recombining
 strings to form new text.
 
-%description -l pl -n python-mx-TextTools
+%description -n python-mx-TextTools -l pl
 Pakiet mxTextTools dostarcza szereg u¿ytecznych typów i funkcji, które
 implementuj± wysokiej jako¶ci algorytmy do wyszukiwania i manipulacji
 tekstu. Programista dostaje wydajne (na poziomie kodu napisanego w
@@ -125,12 +125,8 @@ manipulowa
 %package -n python-mx-Stack
 Summary:       Stack implementation for Python
 Summary(pl):   Implementacja stosu dla jêzyka Python
-Group:         Development/Languages/Python
-Group(de):     Entwicklung/Sprachen/Python
-Group(es):     Desarrollo/Lenguages/Python
-Group(fr):     Development/Langues/Python
-Group(pl):     Programowanie/Jêzyki/Python
-%requires_eq   python
+Group:         Libraries/Python
+%pyrequires_eq python
 Requires:      python-%{module} = %{version}
 
 %description -n python-mx-Stack
@@ -139,7 +135,7 @@ Stack. It works much like what you would expect from such a type,
 having .push() and .pop() methods and focusses on obtaining maximum
 speed at low memory costs.
 
-%description -l pl -n python-mx-Stack
+%description -n python-mx-Stack -l pl
 Pakiet mxStack zawiera implementacjê stosu, która zawiera typowe
 metody takie jak pop() czy push(). Mechanizm zosta³ napisany tak by,
 przy minimalnym zu¿yciu pamiêci, by³ bardzo wydajny.
@@ -147,12 +143,8 @@ przy minimalnym zu
 %package -n python-mx-Queue
 Summary:       Queue implementation for Python
 Summary(pl):   Implementacja kolejki dla jêzyka Python
-Group:         Development/Languages/Python
-Group(de):     Entwicklung/Sprachen/Python
-Group(es):     Desarrollo/Lenguages/Python
-Group(fr):     Development/Langues/Python
-Group(pl):     Programowanie/Jêzyki/Python
-%requires_eq   python
+Group:         Libraries/Python
+%pyrequires_eq python
 Requires:      python-%{module} = %{version}
 
 %description -n python-mx-Queue
@@ -161,7 +153,7 @@ Queue. It works much like what you would expect from such a type,
 having .push() and .pop() methods and focusses on obtaining maximum
 speed at low memory costs.
 
-%description -l pl -n python-mx-Queue
+%description -n python-mx-Queue -l pl
 Pakiet mxQueue zawiera implementacjê kolejki, która zawiera typowe
 metody takie jak pop() czy push(). Mechanizm zosta³ napisany tak by,
 przy minimalnym zu¿yciu pamiêci, by³ bardzo wydajny.
@@ -169,12 +161,8 @@ przy minimalnym zu
 %package -n python-mx-Tools
 Summary:       Some handy functions and objects which provides new builtins for Python
 Summary(pl):   Kilka u¿ytecznych klas i funkcji w postaci wew. mechanizmów Pythona
-Group:         Development/Languages/Python
-Group(de):     Entwicklung/Sprachen/Python
-Group(es):     Desarrollo/Lenguages/Python
-Group(fr):     Development/Langues/Python
-Group(pl):     Programowanie/Jêzyki/Python
-%requires_eq   python
+Group:         Libraries/Python
+%pyrequires_eq python
 Requires:      python-%{module} = %{version}
 
 %description -n python-mx-Tools
@@ -189,7 +177,7 @@ line import mx.Tools.NewBuiltins to your site.py script and they will
 be available to all users at your site as if they were installed in
 the Python interpreter itself.
 
-%description -l pl -n python-mx-Tools
+%description -n python-mx-Tools -l pl
 Pakiet mxTools zawiera kilka u¿ytecznych klas i funkcji, które daj±
 wiêcej mo¿liwo¶ci programi¶cie, w postaci wewnêtrznych mechanizmów
 jêzyka Python.
@@ -205,12 +193,8 @@ j
 %package -n python-mx-Proxy
 Summary:       Support for Bastion like implementations for Python
 Summary(pl):   Wsparcie dla implementacji typu Bastion dla jêzyka Python
-Group:         Development/Languages/Python
-Group(de):     Entwicklung/Sprachen/Python
-Group(es):     Desarrollo/Lenguages/Python
-Group(fr):     Development/Langues/Python
-Group(pl):     Programowanie/Jêzyki/Python
-%requires_eq   python
+Group:         Libraries/Python
+%pyrequires_eq python
 Requires:      python-%{module} = %{version}
 
 %description -n python-mx-Proxy
@@ -228,7 +212,7 @@ The latest version adds a very interesting new feature: weak
 references which help you work with circular references in a way that
 doesn't cause memory leakage in a Python system.
 
-%description -l pl -n python-mx-Proxy
+%description -n python-mx-Proxy -l pl
 Pakiet mxProxy dostarcza nowe klasy, które implementuj± funkcjonalno¶æ
 typu Bastion bez potrzeby ograniczania ¶rodowiska, w którym jest
 wykonywana aplikacja.
@@ -245,12 +229,8 @@ powoduj
 %package -n python-mx-BeeBase
 Summary:       High performance construction kit for disk based indexed databases (B+Tree)
 Summary(pl):   Wysokiej jako¶ci pakiet do tworzenia indeksowanych baz danych (B+Tree)
-Group:         Development/Languages/Python
-Group(de):     Entwicklung/Sprachen/Python
-Group(es):     Desarrollo/Lenguages/Python
-Group(fr):     Development/Langues/Python
-Group(pl):     Programowanie/Jêzyki/Python
-%requires_eq   python
+Group:         Libraries/Python
+%pyrequires_eq python
 Requires:      python-%{module} = %{version}
 
 %description -n python-mx-BeeBase
@@ -267,7 +247,7 @@ locking for multi process access. Indexes use a high performance
 optimized B+Tree implementation built on top of Thomas Niemann's
 Cookbook B+Tree implementation.
 
-%description -l pl -n python-mx-BeeBase
+%description -n python-mx-BeeBase -l pl
 mxBeeBase jest wysokiej jako¶ci pakietem do tworzenia indeksowanych
 baz danych. Zawiera komponenty, które mo¿na razem ³±czyæ w celu
 zbudowania w³asnej bazy. Obecny limit ilo¶ci danych wynosi 2GB (max.
@@ -290,14 +270,12 @@ env CFLAGS="%{rpmcflags}" python setup.py build
 rm -rf $RPM_BUILD_ROOT
 python setup.py install --root=$RPM_BUILD_ROOT
 
-gzip -9nf README mx/LICENSE mx/COPYRIGHT
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc *.gz mx/*.gz mx/Doc/mxLicense.html
+%doc README mx/LICENSE mx/COPYRIGHT mx/Doc/mxLicense.html
 %dir %{mxdir}
 %{mxdir}/*.py[co]
 
@@ -314,6 +292,11 @@ rm -rf $RPM_BUILD_ROOT
 %{mxdir}/DateTime/mxDateTime/*.py[co]
 %attr(755,root,root) %{mxdir}/DateTime/mxDateTime/*.so
 
+%files -n python-mx-DateTime-devel
+%defattr(644,root,root,755)
+%dir %{mxdir}/DateTime/mxDateTime
+%{mxdir}/DateTime/mxDateTime/*.h
+
 %files -n python-mx-TextTools
 %defattr(644,root,root,755)
 %doc mx/TextTools/Doc/*.html
This page took 0.05608 seconds and 4 git commands to generate.