]> git.pld-linux.org Git - packages/python-egenix-mx-base.git/blobdiff - python-egenix-mx-base.spec
- release 9 for rebuild with python 2.4
[packages/python-egenix-mx-base.git] / python-egenix-mx-base.spec
index 7b614e68df52c49ec4477e0566a8ae436aaf7d1e..c63b7829930739118e9ad693995ede73a2099a02 100644 (file)
@@ -1,16 +1,15 @@
 # TODO make examples package
 
-%include       /usr/lib/rpm/macros.python
-%define                module egenix-mx-base
-%define                mxdir %{py_sitedir}/mx
-#%%define              beta_num 5
-#%%define              fn_sufix 0b%{beta_num}
+%define                module  egenix-mx-base
+%define                mxdir   %{py_sitedir}/mx
+#%%define              beta_num        5
+#%%define              fn_sufix        0b%{beta_num}
 
 Summary:       eGenix mx-Extensions for Python
 Summary(pl):   eGenix mx-Extensions dla jêzyka Python
 Name:          python-%{module}
 Version:       2.0.5
-Release:       8
+Release:       9
 License:       distributable
 Group:         Libraries/Python
 # Source0:     http://www.egenix.com/files/python/%{module}-%{version}.%{fn_sufix}.tar.gz
@@ -18,6 +17,7 @@ Source0:      http://www.egenix.com/files/python/%{module}-%{version}.tar.gz
 # Source0-md5: a793a8fd2d5f646a2fb683d2d967a16b
 # URL:         http://www.lemburg.com/python/eGenix-mx-Extensions.html
 URL:           http://www.egenix.com/mailman-archives/egenix-users/2002-August/000078.html
+BuildRequires: python
 BuildRequires: python-devel >= 2.2.2
 BuildRequires: python-modules >= 2.2.2
 BuildRequires: rpm-pythonprov
@@ -55,7 +55,7 @@ Summary:      Date and time Python extension
 Summary(pl):   Obiekty daty i czasu dla jêzyka Python
 Group:         Libraries/Python
 %pyrequires_eq python
-Requires:      python-%{module} = %{version}
+Requires:      python-%{module} = %{version}-%{release}
 
 %description -n python-mx-DateTime
 mxDateTime is an extension package that provides three new object
@@ -99,7 +99,7 @@ dacie i czasie.
 Summary:       Headers for date and time Python extension
 Summary(pl):   Nag³ówki modu³ów daty i czasu
 Group:         Development/Languages/Python
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description -n python-mx-DateTime-devel
 Headers for date and time Python extension.
@@ -112,7 +112,7 @@ Summary:    Efficient text manipulation extensions for Python
 Summary(pl):   Wydajne manipulowanie tekstem w jêzyku Python
 Group:         Libraries/Python
 %pyrequires_eq python
-Requires:      python-%{module} = %{version}
+Requires:      python-%{module} = %{version}-%{release}
 
 %description -n python-mx-TextTools
 mxTextTools is an extension package for Python that provides several
@@ -144,7 +144,7 @@ Summary:    Stack implementation for Python
 Summary(pl):   Implementacja stosu dla jêzyka Python
 Group:         Libraries/Python
 %pyrequires_eq python
-Requires:      python-%{module} = %{version}
+Requires:      python-%{module} = %{version}-%{release}
 
 %description -n python-mx-Stack
 mxStack is an extension package that provides a new object type called
@@ -162,7 +162,7 @@ Summary:    Queue implementation for Python
 Summary(pl):   Implementacja kolejki dla jêzyka Python
 Group:         Libraries/Python
 %pyrequires_eq python
-Requires:      python-%{module} = %{version}
+Requires:      python-%{module} = %{version}-%{release}
 
 %description -n python-mx-Queue
 mxQueue is an extension package that provides a new object type called
@@ -180,7 +180,7 @@ Summary:    Some handy functions and objects which provides new builtins for Python
 Summary(pl):   Kilka u¿ytecznych klas i funkcji w postaci wew. mechanizmów Pythona
 Group:         Libraries/Python
 %pyrequires_eq python
-Requires:      python-%{module} = %{version}
+Requires:      python-%{module} = %{version}-%{release}
 
 %description -n python-mx-Tools
 mxTools is an extension package that includes a collection of handy
@@ -212,7 +212,7 @@ Summary:    Support for Bastion like implementations for Python
 Summary(pl):   Wsparcie dla implementacji typu Bastion dla jêzyka Python
 Group:         Libraries/Python
 %pyrequires_eq python
-Requires:      python-%{module} = %{version}
+Requires:      python-%{module} = %{version}-%{release}
 
 %description -n python-mx-Proxy
 mxProxy is an extension package that provides a new type that is
@@ -248,7 +248,7 @@ Summary:    High performance construction kit for disk based indexed databases (B+T
 Summary(pl):   Wysokiej jako¶ci pakiet do tworzenia indeksowanych baz danych (B+Tree)
 Group:         Libraries/Python
 %pyrequires_eq python
-Requires:      python-%{module} = %{version}
+Requires:      python-%{module} = %{version}-%{release}
 
 %description -n python-mx-BeeBase
 mxBeeBase is a high performance construction kit for disk based
@@ -287,7 +287,10 @@ env CFLAGS="%{rpmcflags}" python setup.py build
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{py_incdir}/mx
-python setup.py install --root=$RPM_BUILD_ROOT
+python setup.py install \
+       --root=$RPM_BUILD_ROOT \
+       --install-purelib=%{py_sitedir}
+
 find $RPM_BUILD_ROOT%{py_sitedir} -name \*.h \
        -exec mv {} $RPM_BUILD_ROOT%{py_incdir}/mx \;
 
This page took 0.088715 seconds and 4 git commands to generate.