]> git.pld-linux.org Git - packages/python-egenix-mx-base.git/blobdiff - python-egenix-mx-base.spec
- release 9 for rebuild with python 2.4
[packages/python-egenix-mx-base.git] / python-egenix-mx-base.spec
index 6979042893e0c4d8a9d8131e3d8cb5ca5d21b630..c63b7829930739118e9ad693995ede73a2099a02 100644 (file)
@@ -1,19 +1,25 @@
-%include       /usr/lib/rpm/macros.python
+# TODO make examples package
 
-%define module egenix-mx-base
-%define mxdir %{py_sitedir}/mx
+%define                module  egenix-mx-base
+%define                mxdir   %{py_sitedir}/mx
+#%%define              beta_num        5
+#%%define              fn_sufix        0b%{beta_num}
 
 Summary:       eGenix mx-Extensions for Python
 Summary(pl):   eGenix mx-Extensions dla jêzyka Python
 Name:          python-%{module}
-Version:       2.0.3
-Release:       2
+Version:       2.0.5
+Release:       9
 License:       distributable
 Group:         Libraries/Python
-Source0:       http://www.lemburg.com/python/%{module}-%{version}.tar.gz
-URL:           http://www.lemburg.com/python/eGenix-mx-Extensions.html
-BuildRequires: python-devel >= 2.2
-BuildRequires: python-modules >= 2.2
+# Source0:     http://www.egenix.com/files/python/%{module}-%{version}.%{fn_sufix}.tar.gz
+Source0:       http://www.egenix.com/files/python/%{module}-%{version}.tar.gz
+# Source0-md5: a793a8fd2d5f646a2fb683d2d967a16b
+# URL:         http://www.lemburg.com/python/eGenix-mx-Extensions.html
+URL:           http://www.egenix.com/mailman-archives/egenix-users/2002-August/000078.html
+BuildRequires: python
+BuildRequires: python-devel >= 2.2.2
+BuildRequires: python-modules >= 2.2.2
 BuildRequires: rpm-pythonprov
 %pyrequires_eq python
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -33,12 +39,23 @@ Pythonie.
 
 Ten pakiet zawiera podstawowe modu³y wymagane przez inne pakiety.
 
+%package devel
+Summary:       Basic header files for eGenix extensions
+Summary(pl):   Podstawowe pliki nag³ówkowe dla rozszerzeñ eGenix
+Group:         Development/Languages/Python
+
+%description devel
+Basic header files for eGenix extensions.
+
+%description devel -l pl
+Podstawowe pliki nag³ówkowe dla rozszerzeñ eGenix.
+
 %package -n python-mx-DateTime
 Summary:       Date and time Python extension
 Summary(pl):   Obiekty daty i czasu dla jêzyka Python
 Group:         Libraries/Python
 %pyrequires_eq python
-Requires:      python-%{module} = %{version}
+Requires:      python-%{module} = %{version}-%{release}
 
 %description -n python-mx-DateTime
 mxDateTime is an extension package that provides three new object
@@ -78,12 +95,24 @@ innych rozszerze
 interesuj±ca w przypadku aplikacji bazodanowych, które operuj± na
 dacie i czasie.
 
+%package -n python-mx-DateTime-devel
+Summary:       Headers for date and time Python extension
+Summary(pl):   Nag³ówki modu³ów daty i czasu
+Group:         Development/Languages/Python
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description -n python-mx-DateTime-devel
+Headers for date and time Python extension.
+
+%description -n python-mx-DateTime-devel -l pl
+Nag³ówki dla modu³ów daty i czasu.
+
 %package -n python-mx-TextTools
 Summary:       Efficient text manipulation extensions for Python
 Summary(pl):   Wydajne manipulowanie tekstem w jêzyku Python
 Group:         Libraries/Python
 %pyrequires_eq python
-Requires:      python-%{module} = %{version}
+Requires:      python-%{module} = %{version}-%{release}
 
 %description -n python-mx-TextTools
 mxTextTools is an extension package for Python that provides several
@@ -115,7 +144,7 @@ Summary:    Stack implementation for Python
 Summary(pl):   Implementacja stosu dla jêzyka Python
 Group:         Libraries/Python
 %pyrequires_eq python
-Requires:      python-%{module} = %{version}
+Requires:      python-%{module} = %{version}-%{release}
 
 %description -n python-mx-Stack
 mxStack is an extension package that provides a new object type called
@@ -133,7 +162,7 @@ Summary:    Queue implementation for Python
 Summary(pl):   Implementacja kolejki dla jêzyka Python
 Group:         Libraries/Python
 %pyrequires_eq python
-Requires:      python-%{module} = %{version}
+Requires:      python-%{module} = %{version}-%{release}
 
 %description -n python-mx-Queue
 mxQueue is an extension package that provides a new object type called
@@ -151,7 +180,7 @@ Summary:    Some handy functions and objects which provides new builtins for Python
 Summary(pl):   Kilka u¿ytecznych klas i funkcji w postaci wew. mechanizmów Pythona
 Group:         Libraries/Python
 %pyrequires_eq python
-Requires:      python-%{module} = %{version}
+Requires:      python-%{module} = %{version}-%{release}
 
 %description -n python-mx-Tools
 mxTools is an extension package that includes a collection of handy
@@ -183,7 +212,7 @@ Summary:    Support for Bastion like implementations for Python
 Summary(pl):   Wsparcie dla implementacji typu Bastion dla jêzyka Python
 Group:         Libraries/Python
 %pyrequires_eq python
-Requires:      python-%{module} = %{version}
+Requires:      python-%{module} = %{version}-%{release}
 
 %description -n python-mx-Proxy
 mxProxy is an extension package that provides a new type that is
@@ -219,7 +248,7 @@ Summary:    High performance construction kit for disk based indexed databases (B+T
 Summary(pl):   Wysokiej jako¶ci pakiet do tworzenia indeksowanych baz danych (B+Tree)
 Group:         Libraries/Python
 %pyrequires_eq python
-Requires:      python-%{module} = %{version}
+Requires:      python-%{module} = %{version}-%{release}
 
 %description -n python-mx-BeeBase
 mxBeeBase is a high performance construction kit for disk based
@@ -249,6 +278,7 @@ wydajne B-drzewa zaimplementowane na podstawie Cookbook B+Tree Thomasa
 Newmanna.
 
 %prep
+#%%setup -q -n %{module}-%{version}.%{fn_sufix}
 %setup -q -n %{module}-%{version}
 
 %build
@@ -256,22 +286,31 @@ env CFLAGS="%{rpmcflags}" python setup.py build
 
 %install
 rm -rf $RPM_BUILD_ROOT
-python setup.py install --root=$RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{py_incdir}/mx
+python setup.py install \
+       --root=$RPM_BUILD_ROOT \
+       --install-purelib=%{py_sitedir}
 
-gzip -9nf README mx/LICENSE mx/COPYRIGHT
+find $RPM_BUILD_ROOT%{py_sitedir} -name \*.h \
+       -exec mv {} $RPM_BUILD_ROOT%{py_incdir}/mx \;
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc *.gz mx/*.gz mx/Doc/mxLicense.html
+%doc README mx/LICENSE mx/COPYRIGHT mx/Doc/mxLicense.html
 %dir %{mxdir}
+%dir %{py_incdir}/mx
 %{mxdir}/*.py[co]
 
 %dir %{mxdir}/Misc
 %{mxdir}/Misc/*.py[co]
 
+%files devel
+%defattr(644,root,root,755)
+%{py_incdir}/mx/mxh.h
+
 %files -n python-mx-DateTime
 %defattr(644,root,root,755)
 %doc mx/DateTime/Doc/*.html
@@ -282,6 +321,10 @@ rm -rf $RPM_BUILD_ROOT
 %{mxdir}/DateTime/mxDateTime/*.py[co]
 %attr(755,root,root) %{mxdir}/DateTime/mxDateTime/*.so
 
+%files -n python-mx-DateTime-devel
+%defattr(644,root,root,755)
+%{py_incdir}/mx/mxDateTime.h
+
 %files -n python-mx-TextTools
 %defattr(644,root,root,755)
 %doc mx/TextTools/Doc/*.html
This page took 0.061728 seconds and 4 git commands to generate.